summaryrefslogtreecommitdiff
path: root/dev-haskell/vector-binary-instances
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/vector-binary-instances
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/vector-binary-instances')
-rw-r--r--dev-haskell/vector-binary-instances/Manifest1
-rw-r--r--dev-haskell/vector-binary-instances/metadata.xml28
-rw-r--r--dev-haskell/vector-binary-instances/vector-binary-instances-0.2.1.0.ebuild26
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/vector-binary-instances/Manifest b/dev-haskell/vector-binary-instances/Manifest
new file mode 100644
index 00000000000..3365f4e6f51
--- /dev/null
+++ b/dev-haskell/vector-binary-instances/Manifest
@@ -0,0 +1 @@
+DIST vector-binary-instances-0.2.1.0.tar.gz 3114 SHA256 9450018a61ee5a62b802c1b2cfe8d289b7c8f3debeb0f8828679a4c085d31909 SHA512 37955552fc7ea24f35760f8e791d115329591ac720f66bc94db172cf609c67b51d8f075cdcda96e3fcbf9f4fd566557ebdeb306d86e7512e8acf526d691b4ff7 WHIRLPOOL 3e5564bab5b6ff3a0e13cbb6f918772c56cced118410928e194131ee53c7f1032890d90b458891356512a8bfba44fa614c38608cb2458b32a0f1246add6fef73
diff --git a/dev-haskell/vector-binary-instances/metadata.xml b/dev-haskell/vector-binary-instances/metadata.xml
new file mode 100644
index 00000000000..82ae408d0ad
--- /dev/null
+++ b/dev-haskell/vector-binary-instances/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Instances for Binary for the types defined in the vector package,
+ making it easy to serialize vectors to and from disk. We use the
+ generic interface to vectors, so all vector types are supported.
+ Specific instances are provided for unboxed, boxed and storable
+ vectors.
+
+ To serialize a vector:
+
+ &gt; *Data.Vector.Binary&gt; let v = Data.Vector.fromList [1..10]
+ &gt; *Data.Vector.Binary&gt; v
+ &gt; fromList [1,2,3,4,5,6,7,8,9,10] :: Data.Vector.Vector
+ &gt; *Data.Vector.Binary&gt; encode v
+ &gt; Chunk "\NUL\NUL\NUL\NUL\NUL...\NUL\NUL\NUL\t\NUL\NUL\NUL\NUL\n" Empty
+
+ Which you can in turn compress before writing to disk:
+
+ &gt; compress . encode $ v
+ &gt; Chunk "\US\139\b\NUL\NUL\N...\229\240,\254:\NUL\NUL\NUL" Empty
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bos/vector-binary-instances</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/vector-binary-instances/vector-binary-instances-0.2.1.0.ebuild b/dev-haskell/vector-binary-instances/vector-binary-instances-0.2.1.0.ebuild
new file mode 100644
index 00000000000..13c65ae550d
--- /dev/null
+++ b/dev-haskell/vector-binary-instances/vector-binary-instances-0.2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Instances of Data.Binary and Data.Serialize for vector"
+HOMEPAGE="https://github.com/bos/vector-binary-instances"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ dev-haskell/cereal:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"