summaryrefslogtreecommitdiff
path: root/dev-haskell/wxc/wxc-0.90.0.4.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/wxc/wxc-0.90.0.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/wxc/wxc-0.90.0.4.ebuild')
-rw-r--r--dev-haskell/wxc/wxc-0.90.0.4.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-haskell/wxc/wxc-0.90.0.4.ebuild b/dev-haskell/wxc/wxc-0.90.0.4.ebuild
new file mode 100644
index 00000000000..8e19699bf4f
--- /dev/null
+++ b/dev-haskell/wxc/wxc-0.90.0.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+WX_GTK_VER="2.9"
+
+CABAL_FEATURES="lib profile"
+inherit base haskell-cabal multilib versionator wxwidgets
+
+DESCRIPTION="wxHaskell C++ wrapper"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/wxdirect-0.90:${WX_GTK_VER}=[profile?]
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${PN}-0.90.0.4-wxGTK-2.9.4.1.patch")
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s@\"wx-config\"@\"${WX_CONFIG}\"@g" \
+ -i "${S}/Setup.hs" || die "Could not specify wx-config in Setup.hs"
+}
+
+src_configure() {
+ local cgcc=()
+ for i in ${CXXFLAGS}
+ do
+ cgcc+=( --gcc-option="${i}" )
+ done
+ # Trying to specify the LDFLAGS in --ld-option does not work, as ld does
+ # not understand ld options prefixed with -Wl,
+ # The linker that is used to link the libwxc.so shared library is hard coded
+ # in Setup.hs. So the --with-ld would not change the linker used when
+ # linking libwxc.so. --with-ld="gcc" does not help, as then cabal passes
+ # ld options like -x to gcc which then returns a non-zero exit status, then
+ # cabal ignores all the --ld-option parameters.
+ # So I place all the LDFLAGS in --gcc-option parameters. They are ignored
+ # when building .o files.
+ local cld=()
+ for i in ${LDFLAGS}
+ do
+ cld+=( --gcc-option="${i}" )
+ done
+ cabal_src_configure ${cgcc[*]} ${cld[*]} --verbose=3
+}
+
+src_install() {
+ cabal_src_install
+ dolib.so dist/build/lib${PN}.so.${PV}
+ dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.$(get_version_component_range 1-2)
+ dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.$(get_major_version)
+ dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
+}