summaryrefslogtreecommitdiff
path: root/dev-haskell/x509-system
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/x509-system
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/x509-system')
-rw-r--r--dev-haskell/x509-system/Manifest3
-rw-r--r--dev-haskell/x509-system/metadata.xml11
-rw-r--r--dev-haskell/x509-system/x509-system-1.4.2.ebuild29
-rw-r--r--dev-haskell/x509-system/x509-system-1.4.5.ebuild29
-rw-r--r--dev-haskell/x509-system/x509-system-1.5.0.ebuild29
5 files changed, 101 insertions, 0 deletions
diff --git a/dev-haskell/x509-system/Manifest b/dev-haskell/x509-system/Manifest
new file mode 100644
index 00000000000..79030fafc4d
--- /dev/null
+++ b/dev-haskell/x509-system/Manifest
@@ -0,0 +1,3 @@
+DIST x509-system-1.4.2.tar.gz 3508 SHA256 69d0978dd1886f918b53debb6b84a52c198ff33d90dbba8cf8614f5eed8b42e4 SHA512 6a3e7ea7e635bad13ca82a193569005047196cd3b0c728f926a6f25d7aac77c4e24e7e35ff0e3b4bc58fc18c1e5be423be737205c0a357263871dc994ac0d924 WHIRLPOOL 9be26d6717a92bf267c3d446221138d13cf98e9aacdca2860450cc2537a61e957fdfdd76a34818ba874872dcad1e797427777fb58942e4010eaa21ff447af12b
+DIST x509-system-1.4.5.tar.gz 3596 SHA256 1d098a4df1a71ac7cb371f43794c402c8b20a6e8095cc1737a4f39638930965f SHA512 609dfd0a8095f9a9b9b869a871b9da463f50c2973a48d60dad8e6c8f652cdebc09675391f8193bf183b64dab9d81dab09e1561bc253534958d10d325e217c3a9 WHIRLPOOL d5218e3f7da46f286b03b732bbeb2ffd426d7cafa8ab2cf595713f4a5849677fcb307a2968e92dc90bef52410bea258f24623b37d0542d2e143745c6c99d4627
+DIST x509-system-1.5.0.tar.gz 3832 SHA256 235725e9b9a2f16b33f85bcdd320223e0ed720009d5c40739082605bc6e33f95 SHA512 275423717680d62978fbe0703861c05ca2ebe2f0185bd479b5590c725380508d3aefcb229f62111647592f28bddef5285d1224cedab71349b28ee23d8a7d1ee4 WHIRLPOOL d95e7f122c3713365af1607f3271c09a2d88c236c121b04d2d170414ba9ea17215d91e190f965455fe038bff8fcb46b49d56fa55beb3044e68a10cf3b91673c5
diff --git a/dev-haskell/x509-system/metadata.xml b/dev-haskell/x509-system/metadata.xml
new file mode 100644
index 00000000000..20f5a6c88b0
--- /dev/null
+++ b/dev-haskell/x509-system/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ System X.509 handling
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-certificate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/x509-system/x509-system-1.4.2.ebuild b/dev-haskell/x509-system/x509-system-1.4.2.ebuild
new file mode 100644
index 00000000000..0d095195caf
--- /dev/null
+++ b/dev-haskell/x509-system/x509-system-1.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Handle per-operating-system X.509 accessors and storage"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-haskell/x509-1.4:=[profile?] <dev-haskell/x509-1.5:=[profile?]
+ >=dev-haskell/x509-store-1.4:=[profile?] <dev-haskell/x509-store-1.5:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/x509-system/x509-system-1.4.5.ebuild b/dev-haskell/x509-system/x509-system-1.4.5.ebuild
new file mode 100644
index 00000000000..a44268f9172
--- /dev/null
+++ b/dev-haskell/x509-system/x509-system-1.4.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Handle per-operating-system X.509 accessors and storage"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-haskell/x509-1.4:=[profile?] <dev-haskell/x509-1.5:=[profile?]
+ >=dev-haskell/x509-store-1.4:=[profile?] <dev-haskell/x509-store-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/x509-system/x509-system-1.5.0.ebuild b/dev-haskell/x509-system/x509-system-1.5.0.ebuild
new file mode 100644
index 00000000000..ec79b098118
--- /dev/null
+++ b/dev-haskell/x509-system/x509-system-1.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Handle per-operating-system X.509 accessors and storage"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-haskell/x509-1.5:=[profile?] <dev-haskell/x509-1.6:=[profile?]
+ >=dev-haskell/x509-store-1.5:=[profile?] <dev-haskell/x509-store-1.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"