summaryrefslogtreecommitdiff
path: root/dev-haskell/xss-sanitize
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/xss-sanitize
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/xss-sanitize')
-rw-r--r--dev-haskell/xss-sanitize/Manifest2
-rw-r--r--dev-haskell/xss-sanitize/metadata.xml14
-rw-r--r--dev-haskell/xss-sanitize/xss-sanitize-0.3.5.5.ebuild39
-rw-r--r--dev-haskell/xss-sanitize/xss-sanitize-0.3.5.6.ebuild39
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-haskell/xss-sanitize/Manifest b/dev-haskell/xss-sanitize/Manifest
new file mode 100644
index 00000000000..df50069f6e2
--- /dev/null
+++ b/dev-haskell/xss-sanitize/Manifest
@@ -0,0 +1,2 @@
+DIST xss-sanitize-0.3.5.5.tar.gz 10851 SHA256 42930cf564da3cead031b6cd67f613c444d25511356fbc2df8c5b7054a831517 SHA512 acc29dd8cf4e4c2421522f330f30449c7aaf5387a8a0a21c072dffd1f1465358eb343874e774cf9e3bd100c9c5d5aa93575d98152fb3716c54b5550378bdd11a WHIRLPOOL 6c1555b7204ef31a082798ce0b71e06d40ddf46c01e9fc8a0f5dac40fd832e1ade742ce8d6340098e1ce15248691ea325e1e2e9e9ae3a9a6f7157acbdb165b3e
+DIST xss-sanitize-0.3.5.6.tar.gz 10874 SHA256 008a20e0266f7e4255cb6009336bc25cfe74eda3314dff4f0da0bbd584cd58c8 SHA512 9799979f2632b5a5d446913e1b465110a9f4ce6c25dddf27d4fd54a492293ab9f1937668213af762494fc44d4ec270beb0816a2afb3f2b3a5da22c180cb6707d WHIRLPOOL c8d536df45e8301b43c224a6a5d8b484d757d52f8ddef782caca6ad90aaa20dd7debd3f3fd5e712a378b655ecc49775ebbc7ab88733d2b084e3f30b8ce6043db
diff --git a/dev-haskell/xss-sanitize/metadata.xml b/dev-haskell/xss-sanitize/metadata.xml
new file mode 100644
index 00000000000..5a38b07f29d
--- /dev/null
+++ b/dev-haskell/xss-sanitize/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ run untrusted HTML through Text.HTML.SanitizeXSS.sanitizeXSS to prevent XSS attacks. see README.md &lt;http://github.com/yesodweb/haskell-xss-sanitize&gt; for more details
+ </longdescription>
+ <use>
+ <flag name="network-uri">Get Network.URI from the network-uri package.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">yesodweb/haskell-xss-sanitize</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.5.ebuild b/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.5.ebuild
new file mode 100644
index 00000000000..bbbf3653428
--- /dev/null
+++ b/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="sanitize untrusted HTML to prevent XSS attacks"
+HOMEPAGE="http://github.com/yesodweb/haskell-xss-sanitize"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.0.3:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
+ >=dev-haskell/css-text-0.1.1:=[profile?] <dev-haskell/css-text-0.2:=[profile?]
+ >=dev-haskell/tagsoup-0.12.2:=[profile?] <dev-haskell/tagsoup-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/hunit-1.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}
diff --git a/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.6.ebuild b/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.6.ebuild
new file mode 100644
index 00000000000..8dd513dd557
--- /dev/null
+++ b/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="sanitize untrusted HTML to prevent XSS attacks"
+HOMEPAGE="http://github.com/yesodweb/haskell-xss-sanitize"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.0.3:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
+ >=dev-haskell/css-text-0.1.1:=[profile?] <dev-haskell/css-text-0.2:=[profile?]
+ >=dev-haskell/tagsoup-0.12.2:=[profile?] <dev-haskell/tagsoup-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/hunit-1.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}