summaryrefslogtreecommitdiff
path: root/dev-haskell/zlib-bindings
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/zlib-bindings
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/zlib-bindings')
-rw-r--r--dev-haskell/zlib-bindings/Manifest2
-rw-r--r--dev-haskell/zlib-bindings/metadata.xml11
-rw-r--r--dev-haskell/zlib-bindings/zlib-bindings-0.1.1.3.ebuild27
-rw-r--r--dev-haskell/zlib-bindings/zlib-bindings-0.1.1.5.ebuild28
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-haskell/zlib-bindings/Manifest b/dev-haskell/zlib-bindings/Manifest
new file mode 100644
index 00000000000..087b003b746
--- /dev/null
+++ b/dev-haskell/zlib-bindings/Manifest
@@ -0,0 +1,2 @@
+DIST zlib-bindings-0.1.1.3.tar.gz 55555 SHA256 d96193eaa6ca5bb1f92bbc05f3153e37ee47935dc7f29aea54572dc8ce5650a2 SHA512 02e094d3f7e171986981cd510efd83fd9aa10a35ca96b260fa6a5f39a23412ed7b74fe041675e59e6317f1a98e16c0c355e114018bb1fa9f7d912e6fbcd21c4f WHIRLPOOL 43d8cd174db7ba17604a7b845514f2417e3a76881740f4f8f8b58a785a0cbfbe027235a9aa4c22490d9393c3a2d6f8f1deac0868587ae2de4875c54afd40c6c5
+DIST zlib-bindings-0.1.1.5.tar.gz 54770 SHA256 c83bb438f9b6c5fe860982731eb8ac7eff993e8b56cbc15ef5b471f229f79109 SHA512 1ce7a21f462ce5fb1c6ae0ccd40b6f59eb95772b46fa8f5cb3b94f76d55189b7c020dfd97cb18afe21cd826d1a511d9d02909c4376b165c2f574ec881f7de299 WHIRLPOOL 93d5b098cd7a918fd9c9b94a55f18ade8e119233c9c66458552a665397794e92f10d3516fc66d01bcffe97faf6138ac5978dd6c1162890be30691e02ee7c2660
diff --git a/dev-haskell/zlib-bindings/metadata.xml b/dev-haskell/zlib-bindings/metadata.xml
new file mode 100644
index 00000000000..e18648afdcd
--- /dev/null
+++ b/dev-haskell/zlib-bindings/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Low-level bindings to the zlib package.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/zlib-bindings</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/zlib-bindings/zlib-bindings-0.1.1.3.ebuild b/dev-haskell/zlib-bindings/zlib-bindings-0.1.1.3.ebuild
new file mode 100644
index 00000000000..000a272f389
--- /dev/null
+++ b/dev-haskell/zlib-bindings/zlib-bindings-0.1.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Low-level bindings to the zlib package"
+HOMEPAGE="http://github.com/snoyberg/zlib-bindings"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/zlib-0.5.2.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/quickcheck-2.3
+ )
+ >=dev-haskell/cabal-1.8"
diff --git a/dev-haskell/zlib-bindings/zlib-bindings-0.1.1.5.ebuild b/dev-haskell/zlib-bindings/zlib-bindings-0.1.1.5.ebuild
new file mode 100644
index 00000000000..3a1bf071e47
--- /dev/null
+++ b/dev-haskell/zlib-bindings/zlib-bindings-0.1.1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Low-level bindings to the zlib package. (deprecated)"
+HOMEPAGE="http://github.com/snoyberg/zlib-bindings"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/zlib-0.5.2.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/quickcheck-2.3 )
+"