summaryrefslogtreecommitdiff
path: root/dev-haskell
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 22:27:30 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 22:27:30 +0000
commit867fdf18ccb78321cdd3eabc0d4ef6e0dd14ff28 (patch)
tree00e46100fb9d73dc12b5968529a2c8489ebe0e89 /dev-haskell
parent0f09e4cef36a5727550afc2f4781a92526fb87c4 (diff)
downloadgentoo-867fdf18ccb78321cdd3eabc0d4ef6e0dd14ff28.tar.gz
gentoo-867fdf18ccb78321cdd3eabc0d4ef6e0dd14ff28.tar.xz
dev-haskell/wxhaskell: tweak for ghc-7.10, bug #561254
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/wxhaskell/files/wxhaskell-0.13.2.3-ghc-7.10.patch8
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild4
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild4
3 files changed, 16 insertions, 0 deletions
diff --git a/dev-haskell/wxhaskell/files/wxhaskell-0.13.2.3-ghc-7.10.patch b/dev-haskell/wxhaskell/files/wxhaskell-0.13.2.3-ghc-7.10.patch
new file mode 100644
index 00000000000..0d137416994
--- /dev/null
+++ b/dev-haskell/wxhaskell/files/wxhaskell-0.13.2.3-ghc-7.10.patch
@@ -0,0 +1,8 @@
+diff --git a/src/Graphics/UI/WX/Window.hs b/src/Graphics/UI/WX/Window.hs
+index 0b04fa9..39c0505 100644
+--- a/src/Graphics/UI/WX/Window.hs
++++ b/src/Graphics/UI/WX/Window.hs
+@@ -1,2 +1,2 @@
+-{-# LANGUAGE TypeSynonymInstances, FlexibleInstances #-}
++{-# LANGUAGE TypeSynonymInstances, FlexibleInstances, FlexibleContexts #-}
+ --------------------------------------------------------------------------------
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild
index 56a388d2171..491be5e431e 100644
--- a/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild
+++ b/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild
@@ -31,6 +31,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.2.3-ghc-7.10.patch
+}
+
src_configure() {
# ghc DCE bug: https://ghc.haskell.org/trac/ghc/ticket/9155
[[ $(ghc-version) == 7.8.2 ]] && replace-hcflags -O[2-9] -O1
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild
index 0ce4f06b344..0b28b638bbd 100644
--- a/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild
+++ b/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild
@@ -31,6 +31,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.2.3-ghc-7.10.patch
+}
+
src_configure() {
# ghc DCE bug: https://ghc.haskell.org/trac/ghc/ticket/9155
[[ $(ghc-version) == 7.8.2 ]] && replace-hcflags -O[2-9] -O1