summaryrefslogtreecommitdiff
path: root/dev-java/batik
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/batik
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/batik')
-rw-r--r--dev-java/batik/Manifest1
-rw-r--r--dev-java/batik/batik-1.8-r1.ebuild116
-rw-r--r--dev-java/batik/batik-1.8-r2.ebuild116
-rw-r--r--dev-java/batik/metadata.xml10
4 files changed, 243 insertions, 0 deletions
diff --git a/dev-java/batik/Manifest b/dev-java/batik/Manifest
new file mode 100644
index 00000000000..79f320e6ee5
--- /dev/null
+++ b/dev-java/batik/Manifest
@@ -0,0 +1 @@
+DIST batik-src-1.8.tar.gz 14970684 SHA256 0f1175146d45445fc4940e214c3e1e5cfa0294ae6a9787859bda00964f97c2bd SHA512 352843fd0cec43c6d9d54426fe1c20a9bd2234798404b101f2e8d43f6089c0bf6bb5102cb5674de11d37a0d820a8bb79fe9dd854030b23fd8c68f3931eb12f1b WHIRLPOOL fa50d1f87257c6018f99076bf759066b2311f483d424ef743e45fe17c74c646a215c1211c5431b2a522913f23ff5f53934a1606d4d4a223e8298abd6ce94bb46
diff --git a/dev-java/batik/batik-1.8-r1.ebuild b/dev-java/batik/batik-1.8-r1.ebuild
new file mode 100644
index 00000000000..7294a5aa44e
--- /dev/null
+++ b/dev-java/batik/batik-1.8-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Java based SVG toolkit"
+HOMEPAGE="https://xmlgraphics.apache.org/batik/"
+SRC_URI="http://apache.mirrors.ovh.net/ftp.apache.org/dist/xmlgraphics/${PN}/source/${PN}-src-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.8"
+KEYWORDS="amd64 x86 ppc ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc python tcl"
+
+CDEPEND="dev-java/xalan:0
+ dev-java/rhino:1.6
+ dev-java/xml-commons-external:1.3
+ dev-java/xmlgraphics-commons:2
+ python? ( dev-java/jython:0 )
+ tcl? ( dev-java/jacl:0 )
+ dev-java/ant-core:0"
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="
+ xml-commons-external-1.3
+ xmlgraphics-commons-2
+ xalan
+ rhino-1.6
+"
+
+java_prepare() {
+ # bug #318323
+ for file in build.xml contrib/rasterizertask/build.xml; do
+ java-ant_xml-rewrite -f ${file} -c -e javadoc -a failonerror -v no -a maxmemory -v 512m
+ done
+
+ # Add some missing imports to avoid a compiling issue.
+ # https://bugs.gentoo.org/show_bug.cgi?id=551952
+ # https://issues.apache.org/jira/browse/BATIK-1123
+ local imports=()
+ imports+=(sources/org/apache/batik/script/jpython/JPythonInterpreterFactory.java)
+ imports+=(sources/org/apache/batik/script/jacl/JaclInterpreterFactory.java)
+ for import in ${imports[@]}; do
+ einfo "Fixing missing import in ${import}"
+ sed -i '23i import org.apache.batik.script.ImportInfo;' ${import} || die
+ eend $?
+ done
+
+ cd lib || die
+ rm -v *.jar build/*.jar || die
+ use python && java-pkg_jar-from jython
+ use tcl && java-pkg_jar-from jacl
+}
+
+src_compile() {
+ # Fails to build on amd64 without this
+ if use amd64 ; then
+ export ANT_OPTS="-Xmx1g"
+ else
+ export ANT_OPTS="-Xmx256m"
+ fi
+
+ eant jars all-jar $(use_doc)
+ cd contrib/rasterizertask || die
+ eant -Dgentoo.classpath="$(java-pkg_getjar ant-core ant.jar):../../classes" jar $(use_doc)
+
+ cd "${S}"/"${P}/lib" || die
+
+ # batik-all-1.8.jar is a all-in-one jar that contains all other jars.
+ # We don't want to package it.
+ rm -v ${PN}-all-${PV}.jar || die
+}
+
+src_install() {
+ batik_unversion_jars() {
+ for jar in batik-*.jar; do
+ newj="${jar%-*}.jar"
+ java-pkg_newjar ${jar} ${newj}
+ done
+ }
+
+ # First unversion jars in ${P}/lib
+ cd "${S}"/"${P}"/lib || die
+ batik_unversion_jars
+
+ # Then, only those in ${P}
+ cd "${S}"/"${P}" || die
+ batik_unversion_jars
+
+ # Proceed with documentation installation
+ cd "${S}" || die
+ dodoc README CHANGES
+ use doc && java-pkg_dojavadoc ${P}/docs/javadoc
+
+ # pwd fixes bug #116976
+ java-pkg_dolauncher batik-${SLOT} --pwd "${EPREFIX}/usr/share/${PN}-${SLOT}/" \
+ --main org.apache.batik.apps.svgbrowser.Main
+
+ # To find these lsjar batik-${SLOT} | grep Main.class
+ for launcher in ttf2svg slideshow svgpp rasterizer; do
+ java-pkg_dolauncher batik-${launcher}-${SLOT} \
+ --main org.apache.batik.apps.${launcher}.Main
+ done
+
+ # Install and register the ant task.
+ java-pkg_dojar contrib/rasterizertask/build/lib/RasterizerTask.jar
+ java-pkg_register-ant-task
+}
diff --git a/dev-java/batik/batik-1.8-r2.ebuild b/dev-java/batik/batik-1.8-r2.ebuild
new file mode 100644
index 00000000000..3de7fc01865
--- /dev/null
+++ b/dev-java/batik/batik-1.8-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Java based SVG toolkit"
+HOMEPAGE="https://xmlgraphics.apache.org/batik/"
+SRC_URI="http://apache.mirrors.ovh.net/ftp.apache.org/dist/xmlgraphics/${PN}/source/${PN}-src-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.8"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc python tcl"
+
+CDEPEND="dev-java/xalan:0
+ dev-java/rhino:1.6
+ dev-java/xml-commons-external:1.3
+ dev-java/xmlgraphics-commons:2
+ python? ( dev-java/jython:0 )
+ tcl? ( dev-java/jacl:0 )
+ dev-java/ant-core:0"
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="
+ xml-commons-external-1.3
+ xmlgraphics-commons-2
+ xalan
+ rhino-1.6
+"
+
+java_prepare() {
+ # bug #318323
+ for file in build.xml contrib/rasterizertask/build.xml; do
+ java-ant_xml-rewrite -f ${file} -c -e javadoc -a failonerror -v no -a maxmemory -v 512m
+ done
+
+ # Add some missing imports to avoid a compiling issue.
+ # https://bugs.gentoo.org/show_bug.cgi?id=551952
+ # https://issues.apache.org/jira/browse/BATIK-1123
+ local imports=()
+ imports+=(sources/org/apache/batik/script/jpython/JPythonInterpreterFactory.java)
+ imports+=(sources/org/apache/batik/script/jacl/JaclInterpreterFactory.java)
+ for import in ${imports[@]}; do
+ einfo "Fixing missing import in ${import}"
+ sed -i '23i import org.apache.batik.script.ImportInfo;' ${import} || die
+ eend $?
+ done
+
+ cd lib || die
+ rm -v *.jar build/*.jar || die
+ use python && java-pkg_jar-from jython
+ use tcl && java-pkg_jar-from jacl
+}
+
+src_compile() {
+ # Fails to build on amd64 without this
+ if use amd64 ; then
+ export ANT_OPTS="-Xmx1g"
+ else
+ export ANT_OPTS="-Xmx256m"
+ fi
+
+ eant jars all-jar $(use_doc)
+ cd contrib/rasterizertask || die
+ eant -Dgentoo.classpath="$(java-pkg_getjar ant-core ant.jar):../../classes" jar $(use_doc)
+
+ # batik-all-1.8.jar is a all-in-one jar that contains all other jars.
+ # We don't want to package it.
+ # No actually we do. See bug 556062.
+ # cd "${S}"/"${P}/lib" || die
+ # rm -v ${PN}-all-${PV}.jar || die
+}
+
+src_install() {
+ batik_unversion_jars() {
+ for jar in batik-*.jar; do
+ newj="${jar%-*}.jar"
+ java-pkg_newjar ${jar} ${newj}
+ done
+ }
+
+ # First unversion jars in ${P}/lib
+ cd "${S}"/"${P}"/lib || die
+ batik_unversion_jars
+
+ # Then, only those in ${P}
+ cd "${S}"/"${P}" || die
+ batik_unversion_jars
+
+ # Proceed with documentation installation
+ cd "${S}" || die
+ dodoc README CHANGES
+ use doc && java-pkg_dojavadoc ${P}/docs/javadoc
+
+ # pwd fixes bug #116976
+ java-pkg_dolauncher batik-${SLOT} --pwd "${EPREFIX}/usr/share/${PN}-${SLOT}/" \
+ --main org.apache.batik.apps.svgbrowser.Main
+
+ # To find these lsjar batik-${SLOT} | grep Main.class
+ for launcher in ttf2svg slideshow svgpp rasterizer; do
+ java-pkg_dolauncher batik-${launcher}-${SLOT} \
+ --main org.apache.batik.apps.${launcher}.Main
+ done
+
+ # Install and register the ant task.
+ java-pkg_dojar contrib/rasterizertask/build/lib/RasterizerTask.jar
+ java-pkg_register-ant-task
+}
diff --git a/dev-java/batik/metadata.xml b/dev-java/batik/metadata.xml
new file mode 100644
index 00000000000..d44ab745e7a
--- /dev/null
+++ b/dev-java/batik/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<longdescription>
+ Java toolkit for applications or applets that want to use
+ images in the Scalable Vector Graphics (SVG) format for various
+ purposes, such as viewing, generation or manipulation.
+</longdescription>
+</pkgmetadata>