summaryrefslogtreecommitdiff
path: root/dev-java/beansbinding
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/beansbinding
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/beansbinding')
-rw-r--r--dev-java/beansbinding/Manifest1
-rw-r--r--dev-java/beansbinding/beansbinding-1.2.1-r1.ebuild45
-rw-r--r--dev-java/beansbinding/beansbinding-1.2.1.ebuild33
-rw-r--r--dev-java/beansbinding/metadata.xml9
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-java/beansbinding/Manifest b/dev-java/beansbinding/Manifest
new file mode 100644
index 00000000000..0cfaf19a9bf
--- /dev/null
+++ b/dev-java/beansbinding/Manifest
@@ -0,0 +1 @@
+DIST beansbinding-1.2.1-src.zip 236905 SHA256 ed77bd6e0351bb00832dd4248cb4a6a69f5ccd08cf41f2f3806ae3732b7f0aa4 SHA512 f617f0b5068c416bcaaa46fe141e9b8b1fec128403738093b205451f9bcd624d2588b9b77e0c67f6de97490f44a4cf7c5e58b1728d5d7d921bd861e3dfffb415 WHIRLPOOL 5545a5a3ee19c3b0170d4e57ebb8f39c58ec7599995db9e516caa9f5fd952dc89e5f8091f7ee2073689986e2d240d283bdb53b48ab8cdf6abe4bb72761062d62
diff --git a/dev-java/beansbinding/beansbinding-1.2.1-r1.ebuild b/dev-java/beansbinding/beansbinding-1.2.1-r1.ebuild
new file mode 100644
index 00000000000..946df38da70
--- /dev/null
+++ b/dev-java/beansbinding/beansbinding-1.2.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Implementation of JSR295"
+HOMEPAGE="https://beansbinding.dev.java.net"
+SRC_URI="https://beansbinding.dev.java.net/files/documents/6779/73673/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+# https://bugs.gentoo.org/show_bug.cgi?id=249740
+# Quite weird. Should look into why this is happening.
+JAVA_PKG_FILTER_COMPILER="ecj-3.5 ecj-3.4 ecj-3.3 ecj-3.2"
+
+java_prepare() {
+ # Avoid the usual "Javadoc returned 1" error.
+ java-ant_xml-rewrite \
+ -f nbproject/build-impl.xml \
+ -c -e javadoc \
+ -a failonerror \
+ -v "false"
+}
+
+src_install() {
+ java-pkg_dojar "dist/${PN}.jar"
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/beansbinding/beansbinding-1.2.1.ebuild b/dev-java/beansbinding/beansbinding-1.2.1.ebuild
new file mode 100644
index 00000000000..baf239dd534
--- /dev/null
+++ b/dev-java/beansbinding/beansbinding-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Implementation of JSR295"
+HOMEPAGE="https://beansbinding.dev.java.net"
+SRC_URI="https://beansbinding.dev.java.net/files/documents/6779/73673/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+# https://bugs.gentoo.org/show_bug.cgi?id=249740
+# Quite weird. Should look into why this is happening.
+JAVA_PKG_FILTER_COMPILER="ecj-3.5 ecj-3.4 ecj-3.3 ecj-3.2"
+
+src_install() {
+ java-pkg_dojar "dist/${PN}.jar"
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/beansbinding/metadata.xml b/dev-java/beansbinding/metadata.xml
new file mode 100644
index 00000000000..6f5f1773935
--- /dev/null
+++ b/dev-java/beansbinding/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<longdescription lang="en">
+Beans Binding (JSR 295) is about keeping the properties of two beans in sync. This project provides the reference implementation of Beans Binding, with an additional emphasis on the ability to bind to Swing components, and easy integration with IDEs such as NetBeans.
+</longdescription>
+</pkgmetadata>
+