summaryrefslogtreecommitdiff
path: root/dev-java/fastinfoset
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/fastinfoset
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/fastinfoset')
-rw-r--r--dev-java/fastinfoset/Manifest2
-rw-r--r--dev-java/fastinfoset/fastinfoset-1.2.1-r1.ebuild49
-rw-r--r--dev-java/fastinfoset/fastinfoset-1.2.1-r2.ebuild24
-rw-r--r--dev-java/fastinfoset/fastinfoset-1.2.11.ebuild26
-rw-r--r--dev-java/fastinfoset/files/build.xml-1.2.116
-rw-r--r--dev-java/fastinfoset/metadata.xml5
6 files changed, 122 insertions, 0 deletions
diff --git a/dev-java/fastinfoset/Manifest b/dev-java/fastinfoset/Manifest
new file mode 100644
index 00000000000..9e0ad5a6b14
--- /dev/null
+++ b/dev-java/fastinfoset/Manifest
@@ -0,0 +1,2 @@
+DIST FastInfoset-1.2.11-sources.jar 255054 SHA256 5d5ffc5002d78edf3c838cc60567447f5dfd3b22fda623afe15a4bd44c92c4f4 SHA512 a1e850e4b235bf767a168dacdaf61f4e1261b6cb50387c3f3cda575f87bed5cf3974c9d04a273baf1aeb47bfa1851aab95432a3890b8bd99f3672c88f0205e3a WHIRLPOOL e20edda9a8d2314cb66c450442260683e701fc5c9fd40ca228c1adf4eacc1967e5ea36423021404df42d396f9b6b562d0a6a727859aa85a53a3976d0e5155ae7
+DIST FastInfoset_src_1.2.1.zip 296557 SHA256 7a72fd95990235b5d07e153e77ca8c372840529b6f2a70e8b66f2da8c0e73d07 SHA512 cc97222787068db91058c997995261d10bac25a35e63fc40d87704bdc9857bb1624e3adaeaa4ff008295cc39e3519354b23a1ebcb43e430864526ddf08b23c36 WHIRLPOOL b5ac27bb5d6e78b9a1d27d8db6196021cf6b5d3a131d6fb0449918a04c7e6bc311d9a4a76a50ddb5e9f4bba25b6337a15a4bf71f2203835443a603b898140151
diff --git a/dev-java/fastinfoset/fastinfoset-1.2.1-r1.ebuild b/dev-java/fastinfoset/fastinfoset-1.2.1-r1.ebuild
new file mode 100644
index 00000000000..374eee8ae4e
--- /dev/null
+++ b/dev-java/fastinfoset/fastinfoset-1.2.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Fast Infoset"
+HOMEPAGE="https://fi.dev.java.net/"
+SRC_URI="https://fi.dev.java.net/files/documents/2634/45735/FastInfoset_src_${PV}.zip"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEP="java-virtuals/stax-api"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ mkdir src lib
+ mv com org src/ || die
+
+ cp "${FILESDIR}/build.xml-${PV}" "${S}/build.xml" || die
+
+ cd "${S}/lib"
+ java-pkg_jar-from --virtual stax-api
+
+}
+
+src_install() {
+
+ java-pkg_newjar fi.jar
+
+ use source && java-pkg_dosrc src/*
+
+}
diff --git a/dev-java/fastinfoset/fastinfoset-1.2.1-r2.ebuild b/dev-java/fastinfoset/fastinfoset-1.2.1-r2.ebuild
new file mode 100644
index 00000000000..a25841aa43c
--- /dev/null
+++ b/dev-java/fastinfoset/fastinfoset-1.2.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Fast Infoset specifies a standardized binary encoding for the XML Information Sets"
+HOMEPAGE="https://fi.java.net/"
+SRC_URI="https://fi.dev.java.net/files/documents/2634/45735/FastInfoset_src_${PV}.zip"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+S="${WORKDIR}"
diff --git a/dev-java/fastinfoset/fastinfoset-1.2.11.ebuild b/dev-java/fastinfoset/fastinfoset-1.2.11.ebuild
new file mode 100644
index 00000000000..02b4efc784b
--- /dev/null
+++ b/dev-java/fastinfoset/fastinfoset-1.2.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="FastInfoset"
+
+DESCRIPTION="Fast Infoset specifies a standardized binary encoding for the XML Information Sets"
+HOMEPAGE="https://fi.java.net/"
+SRC_URI="http://search.maven.org/remotecontent?filepath=com/sun/xml/${PN}/${MY_PN}/${PV}/${MY_PN}-${PV}-sources.jar"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+S="${WORKDIR}"
diff --git a/dev-java/fastinfoset/files/build.xml-1.2.1 b/dev-java/fastinfoset/files/build.xml-1.2.1
new file mode 100644
index 00000000000..15dcdf616a7
--- /dev/null
+++ b/dev-java/fastinfoset/files/build.xml-1.2.1
@@ -0,0 +1,16 @@
+<?xml version="1.0"?>
+<project name="fi" default="jar" basedir=".">
+ <target name="compile">
+ <mkdir dir="build"/>
+ <javac debug="false" srcdir="src" destdir="build">
+ <classpath>
+ <fileset dir="lib" includes="**/*.jar"/>
+ </classpath>
+ </javac>
+ </target>
+ <target name="jar" depends="compile">
+ <jar destfile="fi.jar">
+ <fileset dir="build" includes="**/*.class"/>
+ </jar>
+ </target>
+</project>
diff --git a/dev-java/fastinfoset/metadata.xml b/dev-java/fastinfoset/metadata.xml
new file mode 100644
index 00000000000..250f2d1940e
--- /dev/null
+++ b/dev-java/fastinfoset/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>