summaryrefslogtreecommitdiff
path: root/dev-java/gjdoc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/gjdoc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/gjdoc')
-rw-r--r--dev-java/gjdoc/Manifest1
-rw-r--r--dev-java/gjdoc/files/0.7.9-main-execute.patch17
-rw-r--r--dev-java/gjdoc/files/gjdoc3
-rw-r--r--dev-java/gjdoc/files/gjdoc-0.7.7-gcp.patch56
-rw-r--r--dev-java/gjdoc/gjdoc-0.7.9-r2.ebuild72
-rw-r--r--dev-java/gjdoc/metadata.xml15
6 files changed, 164 insertions, 0 deletions
diff --git a/dev-java/gjdoc/Manifest b/dev-java/gjdoc/Manifest
new file mode 100644
index 00000000000..b358cc7eb8b
--- /dev/null
+++ b/dev-java/gjdoc/Manifest
@@ -0,0 +1 @@
+DIST gjdoc-0.7.9.tar.gz 752491 SHA256 3d07eb7ea85c71614ae1ff8a64f70f9b9df0210194313ac159b71fef63389043 SHA512 462f629650e48a0c15f80ef6cd14656745d3ad8b7424fee425b449a7f206e76c142be3a63ca099166f5e3177d74e2c26a5db33e206013c62ff60242e95f33a81 WHIRLPOOL 9a7f69ff8a92129204f25aff2206864ea219da4a2040637719c46648be95cc6e1d4f4b6941bcd631d25b7f8140caafa700fd621229c7e3637ae5c3f8d0bbc1be
diff --git a/dev-java/gjdoc/files/0.7.9-main-execute.patch b/dev-java/gjdoc/files/0.7.9-main-execute.patch
new file mode 100644
index 00000000000..79a8e5f3473
--- /dev/null
+++ b/dev-java/gjdoc/files/0.7.9-main-execute.patch
@@ -0,0 +1,17 @@
+Index: src/com/sun/tools/javadoc/Main.java
+===================================================================
+RCS file: /sources/classpath/gjdoc/src/com/sun/tools/javadoc/Main.java,v
+retrieving revision 1.3
+diff -u -r1.3 Main.java
+--- src/com/sun/tools/javadoc/Main.java 12 May 2007 10:40:10 -0000 1.3
++++ src/com/sun/tools/javadoc/Main.java 15 Feb 2009 00:32:57 -0000
+@@ -6,4 +6,9 @@
+ {
+ gnu.classpath.tools.gjdoc.Main.main(args);
+ }
++
++ public static int execute(String[] args)
++ {
++ return gnu.classpath.tools.gjdoc.Main.execute(args);
++ }
+ }
diff --git a/dev-java/gjdoc/files/gjdoc b/dev-java/gjdoc/files/gjdoc
new file mode 100644
index 00000000000..cfa2b84ec22
--- /dev/null
+++ b/dev-java/gjdoc/files/gjdoc
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+$(java-config --java) -classpath "$(java-config --classpath=gjdoc,antlr):$CLASSPATH" gnu.classpath.tools.gjdoc.Main ${1+"$@"}
diff --git a/dev-java/gjdoc/files/gjdoc-0.7.7-gcp.patch b/dev-java/gjdoc/files/gjdoc-0.7.7-gcp.patch
new file mode 100644
index 00000000000..a09b745931a
--- /dev/null
+++ b/dev-java/gjdoc/files/gjdoc-0.7.7-gcp.patch
@@ -0,0 +1,56 @@
+Index: gjdoc-0.7.7/configure.ac
+===================================================================
+--- gjdoc-0.7.7.orig/configure.ac
++++ gjdoc-0.7.7/configure.ac
+@@ -101,6 +101,38 @@ AC_SUBST(jni_linkflag)
+ AM_CONDITIONAL([ENABLE_XMLDOCLET], [test x${enable_xmldoclet} = xyes])
+ AM_CONDITIONAL([ENABLE_NATIVE], [test x${enable_native} = xyes])
+
++dnl Start testing for cp -u availability
++dnl Fallback to rsync otherwise
++
++AC_MSG_CHECKING([for working cp -u])
++
++: ${TMPDIR=/tmp}
++{
++ tmp=`
++ (umask 077 && mktemp -d "$TMPDIR/fooXXXXXX") 2>/dev/null
++ ` && test -n "$tmp" && test -d "$tmp"
++} || {
++ tmp=$TMPDIR/foo$$-$RANDOM
++ (umask 077 && mkdir "$tmp")
++} || AC_MSG_ERROR([Unable to create a temporary directory])
++
++touch "$tmp/origin"
++if cp -u "$tmp/origin" "$tmp/destination" 2>/dev/null; then
++ AC_MSG_RESULT([yes])
++ CP_U="cp -u"
++else
++ AC_MSG_RESULT([no])
++ AC_CHECK_PROG([CP_U], [rsync], [rsync -u])
++fi
++
++rm -rf "$tmp/origin"
++
++if test "x$CP_U" = "x"; then
++ AC_MSG_ERROR([Unable to find a workign cp -u implementation.])
++fi
++
++AC_SUBST([CP_U])
++
+ AC_CONFIG_FILES([gjdoc.sh src/resources/version.properties], [chmod +x gjdoc.sh])
+
+ AC_OUTPUT([Makefile docs/Makefile])
+Index: gjdoc-0.7.7/Makefile.am
+===================================================================
+--- gjdoc-0.7.7.orig/Makefile.am
++++ gjdoc-0.7.7/Makefile.am
+@@ -385,7 +385,7 @@ gjdoc_resources_src = $(patsubst %, $(sr
+
+ gnu-classpath-tools-gjdoc-$(VERSION).jar: $(srcdir)/gjdoc.manifest src/resources/version.properties $(gnu_classpath_tools_gjdoc_jar_CLASSES) $(gnu_classpath_tools_gjdoc_jar_GENCLASSES) $(gjdoc_resources_src)
+ for res in $(gjdoc_resources) ; \
+- do cp -u $(srcdir)/src/resources/$$res $$res ; done
++ do $(CP_U) $(srcdir)/src/resources/$$res $$res ; done
+ $(JAR) cfm $@ $(srcdir)/gjdoc.manifest \
+ $(gjdoc_resources) \
+ -C src/resources version.properties \
diff --git a/dev-java/gjdoc/gjdoc-0.7.9-r2.ebuild b/dev-java/gjdoc/gjdoc-0.7.9-r2.ebuild
new file mode 100644
index 00000000000..232704c39c6
--- /dev/null
+++ b/dev-java/gjdoc/gjdoc-0.7.9-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="source"
+
+inherit eutils autotools java-pkg-2
+
+DESCRIPTION="A javadoc compatible Java source documentation generator"
+HOMEPAGE="http://www.gnu.org/software/cp-tools/"
+SRC_URI="mirror://gnu/classpath/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# Possible USE flags.
+#
+# native: to --enable-native
+# doc: to generate javadoc
+# debug: There is a debug doclet installed by default but maybe could
+# have a wrapper that uses it.
+#
+IUSE="xmldoclet"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/antlr-2.7.1:0[java]"
+
+# Refused to emerge with sun-jdk-1.3* complaining about wanting a bigger stack size
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.4"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.7.7-gcp.patch"
+ epatch "${FILESDIR}/0.7.9-main-execute.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # I think that configure will do --enable-native if it finds gcj
+ # so we'll disable it explicitly
+ local myc="--with-antlr-jar=$(java-pkg_getjar antlr antlr.jar) --disable-native"
+ myc="${myc} --disable-dependency-tracking"
+
+ # Does not work with gcc 3.* and without these it tries to use gij
+ # see bug #116804 for details
+
+ # TODO ideally, would respect JAVACFLAGS
+ JAVA="java" JAVAC="javac $(java-pkg_javac-args)" \
+ econf ${myc} \
+ $(use_enable xmldoclet) || die "econf failed"
+}
+
+src_compile() {
+ default # Don't use from java-pkg-2
+}
+
+src_install() {
+ local jars="com-sun-tools-doclets-Taglet gnu-classpath-tools-gjdoc com-sun-javadoc"
+ for jar in ${jars}; do
+ java-pkg_newjar ${jar}-${PV}.jar ${jar}.jar
+ done
+
+ java-pkg_dolauncher ${PN} --main gnu.classpath.tools.gjdoc.Main
+ dodoc AUTHORS ChangeLog NEWS README || die
+
+ cd "${S}"/docs
+ emake DESTDIR="${D}" install || die "Failed to install documentation"
+
+ use source && java-pkg_dosrc "${S}/src"/{com,gnu}
+}
diff --git a/dev-java/gjdoc/metadata.xml b/dev-java/gjdoc/metadata.xml
new file mode 100644
index 00000000000..a247e16439a
--- /dev/null
+++ b/dev-java/gjdoc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+Gjdoc provides a framework for generating documentation in various
+formats from java source files. It implements all features of the
+traditional javadoc tool version 1.4 - except for one unimplemented
+option (-serialwarn), it is fully command-line compatible and it
+provides a compatible Doclet API (package com.sun.javadoc).
+ </longdescription>
+ <use>
+ <flag name="xmldoclet">Also build support for the xml doclet that generates output in xml instead of the traditional html javadoc.</flag>
+ </use>
+</pkgmetadata>