summaryrefslogtreecommitdiff
path: root/dev-java/hessian
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/hessian
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/hessian')
-rw-r--r--dev-java/hessian/Manifest1
-rw-r--r--dev-java/hessian/files/3.0.8-java5.patch28
-rw-r--r--dev-java/hessian/files/build-3.0.8.xml52
-rw-r--r--dev-java/hessian/files/build.xml-3.0.2027
-rw-r--r--dev-java/hessian/files/build.xml-3.1.627
-rw-r--r--dev-java/hessian/files/build.xml-4.0.327
-rw-r--r--dev-java/hessian/hessian-4.0.3.ebuild53
-rw-r--r--dev-java/hessian/metadata.xml11
8 files changed, 226 insertions, 0 deletions
diff --git a/dev-java/hessian/Manifest b/dev-java/hessian/Manifest
new file mode 100644
index 00000000000..5c92f9fe716
--- /dev/null
+++ b/dev-java/hessian/Manifest
@@ -0,0 +1 @@
+DIST hessian-4.0.3-src.jar 374965 SHA256 1084632007a583c2669e90ec5d72d7ffcb5ab0e14d4209c03adefdd144b252ed SHA512 88185b981f7ba95874899b0ccdddc9e30340e31e43e45c73722a2db8c40cb052d93a98c55aa046a0cc946c722045bfeb618390d2dde8c162916e67a22d68b0fc WHIRLPOOL df8a7aabf2010c6868e0e0a092aebfecaa42c0eec22588dd422177b1ad8524851dd7637f67b15e5b442a2e0c3762222d7ce05851edefdd39cf9885ccd2a2553b
diff --git a/dev-java/hessian/files/3.0.8-java5.patch b/dev-java/hessian/files/3.0.8-java5.patch
new file mode 100644
index 00000000000..906eb7efca1
--- /dev/null
+++ b/dev-java/hessian/files/3.0.8-java5.patch
@@ -0,0 +1,28 @@
+diff -uNr hessian-3.0.8.orig/src/com/caucho/hessian/client/HessianProxyFactory.java hessian-3.0.8/src/com/caucho/hessian/client/HessianProxyFactory.java
+--- hessian-3.0.8.orig/src/com/caucho/hessian/client/HessianProxyFactory.java 2006-08-15 10:38:05.000000000 +0200
++++ hessian-3.0.8/src/com/caucho/hessian/client/HessianProxyFactory.java 2006-08-15 10:40:24.000000000 +0200
+@@ -230,7 +230,7 @@
+ {
+ HessianProxy handler = new HessianProxy(this, new URL(url));
+
+- return Proxy.newProxyInstance(api.getClassLoader(),
++ return java.lang.reflect.Proxy.newProxyInstance(api.getClassLoader(),
+ new Class[] { api,
+ HessianRemoteObject.class },
+ handler);
+diff -uNr hessian-3.0.8.orig/src/com/caucho/hessian/client/HessianProxy.java hessian-3.0.8/src/com/caucho/hessian/client/HessianProxy.java
+--- hessian-3.0.8.orig/src/com/caucho/hessian/client/HessianProxy.java 2006-08-15 10:38:05.000000000 +0200
++++ hessian-3.0.8/src/com/caucho/hessian/client/HessianProxy.java 2006-08-15 10:40:06.000000000 +0200
+@@ -94,10 +94,10 @@
+ if (methodName.equals("equals") &&
+ params.length == 1 && params[0].equals(Object.class)) {
+ Object value = args[0];
+- if (value == null || ! Proxy.isProxyClass(value.getClass()))
++ if (value == null || ! java.lang.reflect.Proxy.isProxyClass(value.getClass()))
+ return new Boolean(false);
+
+- HessianProxy handler = (HessianProxy) Proxy.getInvocationHandler(value);
++ HessianProxy handler = (HessianProxy) java.lang.reflect.Proxy.getInvocationHandler(value);
+
+ return new Boolean(_url.equals(handler.getURL()));
+ }
diff --git a/dev-java/hessian/files/build-3.0.8.xml b/dev-java/hessian/files/build-3.0.8.xml
new file mode 100644
index 00000000000..d3a85de83b8
--- /dev/null
+++ b/dev-java/hessian/files/build-3.0.8.xml
@@ -0,0 +1,52 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!---
+ @author: Saleem Abdulrasool <compnerd@gentoo.org>
+ @date: 5/9/2005
+ @revision: 1.0_alpha
+
+ @notes: Call using the following: ant -f build.xml -Dproject.name=${project name} -Dpackage.name=${package name}
+-->
+
+<project name="Gentoo_Builder" default="jar" basedir=".">
+ <property name="src" value="src"/>
+ <property name="build" value="build"/>
+ <property name="dist" value="dist"/>
+
+ <property name="pkg" value="${package.name}"/>
+ <property name="jar" value="${project.name}.jar"/>
+
+ <!-- Override any defined properties -->
+ <property file="build.properties"/>
+
+ <target name="init">
+ <tstamp/>
+ <mkdir dir="${build}"/>
+ <mkdir dir="${dist}"/>
+ <mkdir dir="${dist}/doc"/>
+ </target>
+
+ <target name="compile" depends="init">
+ <javac srcdir="${src}" destdir="${build}" classpath="${classpath}"/>
+ </target>
+
+ <target name="manifest" depends="init">
+ <manifest file="${build}/MANIFEST.MF" mode="update">
+ <attribute name="Built-By" value="Gentoo Portage"/>
+ </manifest>
+ </target>
+
+ <target name="jar" depends="compile,manifest">
+ <jar jarfile="${dist}/${jar}" manifest="${build}/MANIFEST.MF">
+ <fileset dir="${build}"/>
+ </jar>
+ </target>
+
+ <target name="javadoc" depends="compile">
+ <javadoc destdir="${dist}/doc/api" sourcepath="${src}"/>
+ </target>
+
+ <target name="clean">
+ <delete dir="${build}"/>
+ <delete dir="${dist}"/>
+ </target>
+</project>
diff --git a/dev-java/hessian/files/build.xml-3.0.20 b/dev-java/hessian/files/build.xml-3.0.20
new file mode 100644
index 00000000000..ebef8932b34
--- /dev/null
+++ b/dev-java/hessian/files/build.xml-3.0.20
@@ -0,0 +1,27 @@
+<?xml version="1.0"?>
+<project name="hessian" default="all" basedir=".">
+ <target name="compile">
+ <mkdir dir="build"/>
+ <javac debug="false" srcdir="src" destdir="build">
+ <classpath>
+ <fileset dir="lib" includes="**/*.jar"/>
+ </classpath>
+ </javac>
+ </target>
+ <target name="all" depends="hessian.jar,burlap.jar,services.jar"/>
+ <target name="hessian.jar" depends="compile">
+ <jar destfile="hessian.jar">
+ <fileset dir="build" includes="**/hessian/**/*.class"/>
+ </jar>
+ </target>
+ <target name="burlap.jar" depends="compile">
+ <jar destfile="burlap.jar">
+ <fileset dir="build" includes="**/burlap/**/*.class"/>
+ </jar>
+ </target>
+ <target name="services.jar" depends="compile">
+ <jar destfile="services.jar">
+ <fileset dir="build" includes="**/services/**/*.class"/>
+ </jar>
+ </target>
+</project>
diff --git a/dev-java/hessian/files/build.xml-3.1.6 b/dev-java/hessian/files/build.xml-3.1.6
new file mode 100644
index 00000000000..ebef8932b34
--- /dev/null
+++ b/dev-java/hessian/files/build.xml-3.1.6
@@ -0,0 +1,27 @@
+<?xml version="1.0"?>
+<project name="hessian" default="all" basedir=".">
+ <target name="compile">
+ <mkdir dir="build"/>
+ <javac debug="false" srcdir="src" destdir="build">
+ <classpath>
+ <fileset dir="lib" includes="**/*.jar"/>
+ </classpath>
+ </javac>
+ </target>
+ <target name="all" depends="hessian.jar,burlap.jar,services.jar"/>
+ <target name="hessian.jar" depends="compile">
+ <jar destfile="hessian.jar">
+ <fileset dir="build" includes="**/hessian/**/*.class"/>
+ </jar>
+ </target>
+ <target name="burlap.jar" depends="compile">
+ <jar destfile="burlap.jar">
+ <fileset dir="build" includes="**/burlap/**/*.class"/>
+ </jar>
+ </target>
+ <target name="services.jar" depends="compile">
+ <jar destfile="services.jar">
+ <fileset dir="build" includes="**/services/**/*.class"/>
+ </jar>
+ </target>
+</project>
diff --git a/dev-java/hessian/files/build.xml-4.0.3 b/dev-java/hessian/files/build.xml-4.0.3
new file mode 100644
index 00000000000..ebef8932b34
--- /dev/null
+++ b/dev-java/hessian/files/build.xml-4.0.3
@@ -0,0 +1,27 @@
+<?xml version="1.0"?>
+<project name="hessian" default="all" basedir=".">
+ <target name="compile">
+ <mkdir dir="build"/>
+ <javac debug="false" srcdir="src" destdir="build">
+ <classpath>
+ <fileset dir="lib" includes="**/*.jar"/>
+ </classpath>
+ </javac>
+ </target>
+ <target name="all" depends="hessian.jar,burlap.jar,services.jar"/>
+ <target name="hessian.jar" depends="compile">
+ <jar destfile="hessian.jar">
+ <fileset dir="build" includes="**/hessian/**/*.class"/>
+ </jar>
+ </target>
+ <target name="burlap.jar" depends="compile">
+ <jar destfile="burlap.jar">
+ <fileset dir="build" includes="**/burlap/**/*.class"/>
+ </jar>
+ </target>
+ <target name="services.jar" depends="compile">
+ <jar destfile="services.jar">
+ <fileset dir="build" includes="**/services/**/*.class"/>
+ </jar>
+ </target>
+</project>
diff --git a/dev-java/hessian/hessian-4.0.3.ebuild b/dev-java/hessian/hessian-4.0.3.ebuild
new file mode 100644
index 00000000000..76fcd2a6e44
--- /dev/null
+++ b/dev-java/hessian/hessian-4.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Binary web service protocol"
+HOMEPAGE="http://hessian.caucho.com/"
+SRC_URI="http://hessian.caucho.com/download/${P}-src.jar"
+
+LICENSE="Apache-1.1"
+SLOT="4.0"
+KEYWORDS="amd64 ~ppc x86"
+
+IUSE=""
+
+COMMON_DEP="java-virtuals/servlet-api:2.5"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+EANT_BUILD_TARGET="all"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+
+ mkdir -p "${S}/src"
+ mkdir -p "${S}/lib"
+
+ cp "${FILESDIR}/build.xml-${PV}" "${S}/build.xml"
+
+ cd "${S}/src"
+ mv ../com .
+
+ cd "${S}/lib"
+ java-pkg_jarfrom --virtual servlet-api:2.5
+}
+
+src_install() {
+ java-pkg_dojar "hessian.jar"
+ java-pkg_dojar "burlap.jar"
+ java-pkg_dojar "services.jar"
+
+ use source && java-pkg_dosrc src
+}
diff --git a/dev-java/hessian/metadata.xml b/dev-java/hessian/metadata.xml
new file mode 100644
index 00000000000..65653697039
--- /dev/null
+++ b/dev-java/hessian/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<longdescription>
+The Hessian binary web service protocol makes web services usable without
+requiring a large framework, and without learning yet another alphabet soup
+of protocols. Because it is a binary protocol, it is well-suited to sending
+binary data without any need to extend the protocol with attachments.
+</longdescription>
+</pkgmetadata>