summaryrefslogtreecommitdiff
path: root/dev-java/icedtea
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-03-08 13:47:09 +0000
committerJames Le Cuirot <chewi@gentoo.org>2017-03-08 13:48:38 +0000
commit75443af4774ae964a1225dd823e4929d0a3aa2da (patch)
treee636140041bdb1c76d67eeaa4d25beb3325b55d9 /dev-java/icedtea
parent46851bd763a58e9a914edda395f2617680b57719 (diff)
downloadgentoo-75443af4774ae964a1225dd823e4929d0a3aa2da.tar.gz
gentoo-75443af4774ae964a1225dd823e4929d0a3aa2da.tar.xz
dev-java/icedtea: Always disable PCH on PaX systems, bug #601016
I will add this to 7.2 when it supports disabling PCH in 7.2.7.0. Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-java/icedtea')
-rw-r--r--dev-java/icedtea/icedtea-3.3.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-java/icedtea/icedtea-3.3.0.ebuild b/dev-java/icedtea/icedtea-3.3.0.ebuild
index 1bde5048e78..56c7b57cf85 100644
--- a/dev-java/icedtea/icedtea-3.3.0.ebuild
+++ b/dev-java/icedtea/icedtea-3.3.0.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
EAPI="6"
@@ -280,6 +281,13 @@ src_configure() {
config+=" --disable-ccache"
fi
+ # PaX breaks pch, bug #601016
+ if use pch && ! host-is-pax; then
+ config+=" --enable-precompiled-headers"
+ else
+ config+=" --disable-precompiled-headers"
+ fi
+
config+=" --with-parallel-jobs=$(makeopts_jobs)"
unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
@@ -310,7 +318,6 @@ src_configure() {
$(use_enable doc docs) \
$(use_enable kerberos system-kerberos) \
$(use_with pax_kernel pax "${EPREFIX}/usr/sbin/paxmark.sh") \
- $(use_enable pch precompiled-headers) \
$(use_enable sctp system-sctp) \
$(use_enable smartcard system-pcsc) \
$(use_enable sunec) \