summaryrefslogtreecommitdiff
path: root/dev-java/invokebinder
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-16 15:18:50 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-16 15:20:02 +0000
commitf7b897a27191ba477f225cb2b877ce413516243f (patch)
treea5f62b64b4a0f44e71ffd309f0748923c74a67f7 /dev-java/invokebinder
parent713098141f1305d66da876193706bc24247dfdcf (diff)
downloadgentoo-f7b897a27191ba477f225cb2b877ce413516243f.tar.gz
gentoo-f7b897a27191ba477f225cb2b877ce413516243f.tar.xz
dev-java/invokebinder: Clean up old. Fixes bug 472306.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/invokebinder')
-rw-r--r--dev-java/invokebinder/Manifest1
-rw-r--r--dev-java/invokebinder/files/invokebinder-1.2-build.xml255
-rw-r--r--dev-java/invokebinder/invokebinder-1.2.ebuild46
3 files changed, 0 insertions, 302 deletions
diff --git a/dev-java/invokebinder/Manifest b/dev-java/invokebinder/Manifest
index 966c75c5a0e..dd9c156f45d 100644
--- a/dev-java/invokebinder/Manifest
+++ b/dev-java/invokebinder/Manifest
@@ -1,2 +1 @@
-DIST invokebinder-1.2.tar.gz 28581 SHA256 378ab47e625729974b25c81a60abd425abf155a27f60c7c2728ad3a78fd9a1d4 SHA512 aaf56fa008307d56805c6de7d47285d358f4c5018f1704a8f3b44c5bda5045dc20f588e70ce6fbb3486a48f80d30a7669d568e373717401780b13dd4737a8b16 WHIRLPOOL 1c46acfcb2d6c2c53bb24e94aca5afdc578fb6a72c7b3f83e80c22e69cb98e44257c10ba92bfa86c4ec766fea6216cb0604d9be5b2bb755efcae0fa5b0bc8859
DIST invokebinder-1.6.tar.gz 36027 SHA256 db59600de448c9253976c0a288ad6575edbdc83ed6a6d58332b902ab9d337c4d SHA512 cacdd6dd5fe74bbba940be1b3d53b183adc247b74e89cc0784805b2ad2c63d12ca1abe20bacf0a90ea50db7574e43d4ac52b5a46e61912e5153e2ac2f6bc559a WHIRLPOOL 967f8bb39b588d381e3495756e79b7e738f631935aadddf5c6396d7367fcd19584f4d4ae3cb9734aafac17ca62906da8fc0459a9194f9f55671d5503b19265de
diff --git a/dev-java/invokebinder/files/invokebinder-1.2-build.xml b/dev-java/invokebinder/files/invokebinder-1.2-build.xml
deleted file mode 100644
index fdf898483bb..00000000000
--- a/dev-java/invokebinder/files/invokebinder-1.2-build.xml
+++ /dev/null
@@ -1,255 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 6/4/13 6:11 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="invokebinder-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="invokebinder-1.2"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"/>
- <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="UTF-8"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.7"
- verbose="false"
- fork="false"
- source="1.7">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- encoding="UTF-8"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.7"
- verbose="false"
- fork="false"
- source="1.7">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- <mkdir dir="${maven.repo.local}"/>
- <mkdir dir="${maven.repo.local}/junit/junit/4.9"/>
- <get src="https://oss.sonatype.org/content/repositories/snapshots/junit/junit/4.9/junit-4.9.jar"
- dest="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/junit/junit/4.9/junit-4.9.jar"
- dest="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1"/>
- <get src="https://oss.sonatype.org/content/repositories/snapshots/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
- dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
- dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- </target>
-
-</project>
diff --git a/dev-java/invokebinder/invokebinder-1.2.ebuild b/dev-java/invokebinder/invokebinder-1.2.ebuild
deleted file mode 100644
index c90d0704c9b..00000000000
--- a/dev-java/invokebinder/invokebinder-1.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Provide a friendly DSL for binding method handles"
-SRC_URI="https://github.com/headius/invokebinder/archive/invokebinder-1.2.tar.gz"
-HOMEPAGE="https://github.com/headius/invokebinder"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LICENSE="Apache-2.0"
-
-S="${WORKDIR}/${PN}-${P}"
-
-DEPEND=">=virtual/jdk-1.7"
-RDEPEND=">=virtual/jre-1.7"
-
-# Tests fail, three similar errors where a string is inconvertible to int.
-# Bug #472306.
-RESTRICT="test"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-build.xml build.xml || die
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar ${PN}.jar
-
- use source && java-pkg_dosrc src/main/java/com
-
- if use doc ; then
- java-pkg_dojavadoc target/site/apidocs
-
- dodoc README.markdown
- fi
-}