summaryrefslogtreecommitdiff
path: root/dev-java/jansi
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-12-18 16:29:47 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-12-18 16:32:44 +0000
commita7e188e8e63b00e028ea5118f21d2d9a823e2303 (patch)
tree51a2e56ca41778c46b97f52e0b677f3aacb34432 /dev-java/jansi
parentcd624bb9dd8e8431f3a05d58ec0ffb6d3c972d20 (diff)
downloadgentoo-a7e188e8e63b00e028ea5118f21d2d9a823e2303.tar.gz
gentoo-a7e188e8e63b00e028ea5118f21d2d9a823e2303.tar.xz
dev-java/jansi: Make use of java-pkg-simple and allow for compilation to go through. Fixes bug 568616.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/jansi')
-rw-r--r--dev-java/jansi/jansi-1.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/jansi/jansi-1.5-r1.ebuild b/dev-java/jansi/jansi-1.5-r1.ebuild
new file mode 100644
index 00000000000..9eb6c5e1b3f
--- /dev/null
+++ b/dev-java/jansi/jansi-1.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jansi is a small java library that allows you to use ANSI escape sequences in your console output"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/archive/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+
+CDEPEND="dev-java/jansi-native:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_GENTOO_CLASSPATH="jansi-native"
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ rm -rf src/test || die
+}