summaryrefslogtreecommitdiff
path: root/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.131.ebuild
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-04-25 09:52:31 +0100
committerJames Le Cuirot <chewi@gentoo.org>2017-04-25 09:58:25 +0100
commit0d7e1898b2c3790e3d08081930bfe7aba8cd66e2 (patch)
tree25fe9c9cac3f5eb3f99802b142b809f66c4bbbac /dev-java/java-sdk-docs/java-sdk-docs-1.8.0.131.ebuild
parent1340b37c064df2043a86584c8d3b9ac68ce702db (diff)
downloadgentoo-0d7e1898b2c3790e3d08081930bfe7aba8cd66e2.tar.gz
gentoo-0d7e1898b2c3790e3d08081930bfe7aba8cd66e2.tar.xz
dev-java/java-sdk-docs: Version bump to 1.8.0.131
Straight to stable as the old version has gone. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-java/java-sdk-docs/java-sdk-docs-1.8.0.131.ebuild')
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.131.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.131.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.131.ebuild
new file mode 100644
index 00000000000..5c8882f486c
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.131.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="amd64 ~arm ~ppc64 x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins -r index.html */
+}