summaryrefslogtreecommitdiff
path: root/dev-java/jdom/jdom-2.0.6.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdom/jdom-2.0.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdom/jdom-2.0.6.ebuild')
-rw-r--r--dev-java/jdom/jdom-2.0.6.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-java/jdom/jdom-2.0.6.ebuild b/dev-java/jdom/jdom-2.0.6.ebuild
new file mode 100644
index 00000000000..76dcf19c1d4
--- /dev/null
+++ b/dev-java/jdom/jdom-2.0.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="source test"
+
+#JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2
+
+DESCRIPTION="Java API to manipulate XML data"
+SRC_URI="http://www.jdom.org/dist/binary/${P}.zip"
+HOMEPAGE="http://www.jdom.org"
+LICENSE="JDOM"
+SLOT="2"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+COMMON_DEP="dev-java/iso-relax
+ dev-java/jaxen:1.1
+ dev-java/xalan
+ dev-java/xml-commons-external:1.4"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.6"
+DEPEND="${COMMON_DEP}
+ app-arch/unzip
+ test? ( dev-java/junit:0 )
+ >=virtual/jdk-1.6"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./${P}-sources.jar
+}
+
+java_prepare() {
+ find "${S}" -name '*.jar' -delete || die
+ mkdir "${S}"/classes "${S}"/docs
+}
+
+src_compile() {
+ find org -name "*.java" > "${T}"/src.list
+
+ local cp="$(java-pkg_getjars iso-relax,jaxen-1.1,xalan,xml-commons-external-1.4)"
+ if use test ; then
+ cp="${cp}:junit.jar"
+ else
+ sed -i 's/PerfTest/PerfTemp/' "${T}"/src.list || die "Failed to rename PerfTest"
+ sed -i '/test/Id' "${T}"/src.list || die "Failed to remove test classes"
+ sed -i 's/PerfTemp/PerfTest/' "${T}"/src.list || die "Failed to rename PerfTest"
+ fi
+
+ ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
+
+ # Disabled for the time being.
+ # if use doc; then
+ # ejavadoc -d "${S}"/docs -classpath ${cp} "@${T}"/src.list -quiet || die "javadoc failed"
+ # fi
+
+ cd "${S}"/classes
+ jar -cf "${S}"/${PN}.jar * || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ # Disabled for the time being.
+ # if use doc; then
+ # java-pkg_dojavadoc docs
+ # fi
+
+ dodoc README.txt LICENSE.txt || die
+ use source && java-pkg_dosrc org
+}