summaryrefslogtreecommitdiff
path: root/dev-java/jpfcodegen
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jpfcodegen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jpfcodegen')
-rw-r--r--dev-java/jpfcodegen/Manifest1
-rw-r--r--dev-java/jpfcodegen/jpfcodegen-0.4.ebuild41
-rw-r--r--dev-java/jpfcodegen/metadata.xml5
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-java/jpfcodegen/Manifest b/dev-java/jpfcodegen/Manifest
new file mode 100644
index 00000000000..a6157e49a56
--- /dev/null
+++ b/dev-java/jpfcodegen/Manifest
@@ -0,0 +1 @@
+DIST jpfcodegen-0.4.tar.bz2 27201 SHA256 c88401b6d872bf52aeb473bda16a77fb51b2f0236a4fb88ba4847d1bde174699 SHA512 9af5de54621afc941ac56f463b76a31732d97ad4fbbeabf43772c27e91f0e8fdfe5c089fc1cd22b2ad0bbac88d624086c94d751110bc77348706b39cedd45897 WHIRLPOOL c7005df485de6694658444cabdbcfa5ce20b35fe563f253a5b213801e98ee19eae48087df688281edc5ffd6f99eb481478ade568c2da3fc49287ac7e6795fe49
diff --git a/dev-java/jpfcodegen/jpfcodegen-0.4.ebuild b/dev-java/jpfcodegen/jpfcodegen-0.4.ebuild
new file mode 100644
index 00000000000..27a86ec635a
--- /dev/null
+++ b/dev-java/jpfcodegen/jpfcodegen-0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Generator of classes for accessing the attributes and extensions of JPF plug-ins"
+HOMEPAGE="http://jabref.sourceforge.net/"
+
+# packaging instructions:
+# svn export https://jabref.svn.sourceforge.net/svnroot/jabref/tags/jpfcodegen-0.4
+# rm jpfcodegen-0.4/lib/*.jar
+# sed -i 's/, unjarlib"/"/' jpfcodegen-0.4/build.xml
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="LGPL-3"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+COMMON_DEP="dev-java/velocity:0
+ dev-java/jpf:1.5"
+DEPEND="app-arch/unzip
+ >=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+# doc target is name="-javadoc" and would need a patch, on demand
+EANT_BUILD_TARGET="jars"
+EANT_GENTOO_CLASSPATH="jpf-1.5,velocity"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_newjar JPFCodeGenerator-${PV}.jar JPFCodeGenerator.jar
+ java-pkg_newjar JPFCodeGenerator-${PV}-rt.jar JPFCodeGenerator-rt.jar
+ dohtml index.html
+}
diff --git a/dev-java/jpfcodegen/metadata.xml b/dev-java/jpfcodegen/metadata.xml
new file mode 100644
index 00000000000..250f2d1940e
--- /dev/null
+++ b/dev-java/jpfcodegen/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>