summaryrefslogtreecommitdiff
path: root/dev-java/jrobin
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jrobin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jrobin')
-rw-r--r--dev-java/jrobin/Manifest1
-rw-r--r--dev-java/jrobin/jrobin-1.6.0-r1.ebuild65
-rw-r--r--dev-java/jrobin/metadata.xml14
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-java/jrobin/Manifest b/dev-java/jrobin/Manifest
new file mode 100644
index 00000000000..d5bac1796d6
--- /dev/null
+++ b/dev-java/jrobin/Manifest
@@ -0,0 +1 @@
+DIST jrobin-1.6.0-1.tar.gz 7340700 SHA256 0e00afc9b0fdd45bd7e62b3857fc7bd40f08e5f0cf155e0ba614cdabe58fcf5b SHA512 c5428906bf975f6c31f90185da3f0cbcaaff74d68e35e37b5e425340899fe01290d3d9813f1ecd60bd599512e3d62f635de290db9a9a1bd45292ac9c187b15c7 WHIRLPOOL b83007fb4aea92aaad62842b56b4e3bff98ce6ee509684536176420869228c8a86057f03bcebc2a1a637a9ffd2ba794d05756cc479901fff2765ced352ef5d25
diff --git a/dev-java/jrobin/jrobin-1.6.0-r1.ebuild b/dev-java/jrobin/jrobin-1.6.0-r1.ebuild
new file mode 100644
index 00000000000..2257f1c64e7
--- /dev/null
+++ b/dev-java/jrobin/jrobin-1.6.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JRobin is a 100% pure Java alternative to RRDTool"
+HOMEPAGE="http://www.jrobin.org/"
+SRC_URI="https://github.com/OpenNMS/${PN}/archive/${P}-1.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/asm:4
+ >=dev-java/cglib-3.1:3
+ dev-java/easymock:3.2
+ dev-java/junit:4
+ dev-java/objenesis:0 )"
+
+S="${WORKDIR}/${PN}-${P}-1/src"
+JAVA_SRC_DIR="main/java"
+
+java_prepare() {
+ find "${WORKDIR}" -name "*.jar" -delete || die
+
+ # The tests need the resources in this directory for some reason.
+ mkdir -p test/java/target/classes || die
+ cd test/java/target/classes || die
+ ln -snf ../../../../main/resources/* . || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ jar uf "${PN}.jar" -C main/resources . || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher "${PN}-rrdtool" --main org.jrobin.cmd.RrdCommander
+}
+
+src_test() {
+ cd test/java || die
+
+ local CP=".:${S}/${PN}.jar:$(java-pkg_getjars asm-4,cglib-3,easymock-3.2,junit-4,objenesis)"
+ local TESTS=$(find * -name "*Test.java")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d . $(find * -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}
+
+pkg_postinst() {
+ elog "The rrdtool executable has been installed as ${PN}-rrdtool to"
+ elog "avoid conflicting with net-analyzer/rrdtool."
+}
diff --git a/dev-java/jrobin/metadata.xml b/dev-java/jrobin/metadata.xml
new file mode 100644
index 00000000000..a99edeb6c59
--- /dev/null
+++ b/dev-java/jrobin/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ JRobin is a 100% pure Java alternative to RRDTool, with about exactly
+ the same specifications. If you provide the same data to RRDTool and
+ JRobin, you will get exactly the same results and graphs. All standard
+ RRDTool operations are supported.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">OpenNMS/jrobin</remote-id>
+ </upstream>
+</pkgmetadata>