summaryrefslogtreecommitdiff
path: root/dev-java/jtds/jtds-1.3.1.ebuild
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-02-06 13:38:25 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-02-06 13:40:07 +0000
commit5755c8a5b3239463cc8f6895780a3af5fc1361e3 (patch)
treef64d196ba9d48dc1c904857cb08b89445e5b5d7f /dev-java/jtds/jtds-1.3.1.ebuild
parentdb21c283b846584ce1aa5e1bc7677876aec19007 (diff)
downloadgentoo-5755c8a5b3239463cc8f6895780a3af5fc1361e3.tar.gz
gentoo-5755c8a5b3239463cc8f6895780a3af5fc1361e3.tar.xz
dev-java/jtds: Version bump to 1.3.1
Includes a rewrite using java-pkg-simple because it is simpler and doesn't require a patch. More importantly, this ebuild isn't restricted to Java 7. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-java/jtds/jtds-1.3.1.ebuild')
-rw-r--r--dev-java/jtds/jtds-1.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/jtds/jtds-1.3.1.ebuild b/dev-java/jtds/jtds-1.3.1.ebuild
new file mode 100644
index 00000000000..510d183a8b5
--- /dev/null
+++ b/dev-java/jtds/jtds-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="jTDS - SQL Server and Sybase JDBC driver"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+HOMEPAGE="http://jtds.sourceforge.net"
+LICENSE="LGPL-2.1"
+SLOT="1.3"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Needs a running server
+
+CDEPEND="dev-java/jcifs:1.1"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.7
+ app-arch/unzip"
+
+JAVA_SRC_DIR="src/main"
+JAVA_ENCODING="ISO-8859-1"
+JAVA_GENTOO_CLASSPATH="jcifs-1.1"
+
+java_prepare() {
+ java-pkg_clean
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar ${JAVA_SRC_DIR}
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc CHANGELOG README*
+}