summaryrefslogtreecommitdiff
path: root/dev-java/maven-hawtjni-plugin
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-04-04 22:43:28 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-04-07 22:45:33 +0100
commitc7e010feac692c8eed36742bb1df1e17273ad590 (patch)
tree57673c9d7b2be17e9fd211814e3b06b5a71cf2b8 /dev-java/maven-hawtjni-plugin
parent444be19304389b5f0ffb08c15e8fa2c1378b56d8 (diff)
downloadgentoo-c7e010feac692c8eed36742bb1df1e17273ad590.tar.gz
gentoo-c7e010feac692c8eed36742bb1df1e17273ad590.tar.xz
dev-java/maven-hawtjni-plugin: New package, resources only
We currently don't use Maven in ebuilds and we haven't found the need to build the many plugins. This one has useful resource files for building netty-tcnative and potentially other native libraries. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-java/maven-hawtjni-plugin')
-rw-r--r--dev-java/maven-hawtjni-plugin/Manifest1
-rw-r--r--dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild30
-rw-r--r--dev-java/maven-hawtjni-plugin/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/maven-hawtjni-plugin/Manifest b/dev-java/maven-hawtjni-plugin/Manifest
new file mode 100644
index 00000000000..4575b62b6f7
--- /dev/null
+++ b/dev-java/maven-hawtjni-plugin/Manifest
@@ -0,0 +1 @@
+DIST hawtjni-project-1.11.tar.gz 1603735 SHA256 4f8665931329effd0d0b3444e20d2c5d72b01640da2f180f05f26e79f0692fed SHA512 0fafe29dd058eee07e9c26179b7605cc092254199ccb913064002c882e7ab55ecc4045dd2baab99bbc46d6bf28a9f4f2108c210616e3a9c4a92582c65e6de4e4 WHIRLPOOL 60bdab794130fa85aa2b27da0bb6d1684793b45575425dcc06e413426652703b673a1c735c3c4c5c12056bbc2005316c00d13cc9c46ff362579b172a564ddccb
diff --git a/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild b/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild
new file mode 100644
index 00000000000..f614eaff7fc
--- /dev/null
+++ b/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2
+
+MY_P="hawtjni-project-${PV}"
+
+DESCRIPTION="Maven plugin for the HawtJNI code generator (resources only)"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/hawtjni-${MY_P}/${PN}"
+
+src_compile() {
+ touch ${PN}.jar || die # jar won't create on update.
+ java-pkg_addres ${PN}.jar src/main/resources
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+}
diff --git a/dev-java/maven-hawtjni-plugin/metadata.xml b/dev-java/maven-hawtjni-plugin/metadata.xml
new file mode 100644
index 00000000000..6208a5add14
--- /dev/null
+++ b/dev-java/maven-hawtjni-plugin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fusesource/hawtjni</remote-id>
+ </upstream>
+</pkgmetadata>