summaryrefslogtreecommitdiff
path: root/dev-java/sjsxp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sjsxp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sjsxp')
-rw-r--r--dev-java/sjsxp/Manifest1
-rw-r--r--dev-java/sjsxp/metadata.xml5
-rw-r--r--dev-java/sjsxp/sjsxp-1.0.1-r1.ebuild44
-rw-r--r--dev-java/sjsxp/sjsxp-1.0.1.ebuild43
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-java/sjsxp/Manifest b/dev-java/sjsxp/Manifest
new file mode 100644
index 00000000000..10bc4314163
--- /dev/null
+++ b/dev-java/sjsxp/Manifest
@@ -0,0 +1 @@
+DIST sjsxp-1.0.1.tar.bz2 414706 SHA256 3ed146a4726f701ab72c11017655a69471fc1c77a9e668756d7150893f879501 SHA512 0e8e8841d87400f9978b8e053f3658f14f2c1b85007bc431681c6489ae78972cd892021821b00a37ba06098ba1bdf6954a3c294cddbb69e5cdb7936f4736daa5 WHIRLPOOL 56dd5745bdaf15e671a0d0c6fa35da145a237fe4a21b23276393b374fcfe1c61d6051f24876f21302a8da17e5174977f0873a8eb332279eae51264de486d35da
diff --git a/dev-java/sjsxp/metadata.xml b/dev-java/sjsxp/metadata.xml
new file mode 100644
index 00000000000..7303cef9696
--- /dev/null
+++ b/dev-java/sjsxp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/sjsxp/sjsxp-1.0.1-r1.ebuild b/dev-java/sjsxp/sjsxp-1.0.1-r1.ebuild
new file mode 100644
index 00000000000..7bf787574fb
--- /dev/null
+++ b/dev-java/sjsxp/sjsxp-1.0.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Sun Java Streaming XML Parser (SJSXP) is an efficient implementation of the StAX API"
+HOMEPAGE="http://sjsxp.dev.java.net/"
+# CVS: cvs -d :pserver:guest@cvs.dev.java.net:/cvs checkout -r sjsxp-1_0_1 sjsxp/zephyr
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="bea.ri.jsr173"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEP="java-virtuals/stax-api"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/zephyr"
+
+EANT_GENTOO_CLASSPATH="stax-api"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ java-ant_rewrite-classpath
+}
+
+EANT_DOC_TARGET="javadocs"
+
+src_install() {
+ java-pkg_dojar "build/${PN}.jar"
+
+ use doc && java-pkg_dojavadoc build/docs/javadocs/sjsxp
+ use source && java-pkg_dosrc src
+}
diff --git a/dev-java/sjsxp/sjsxp-1.0.1.ebuild b/dev-java/sjsxp/sjsxp-1.0.1.ebuild
new file mode 100644
index 00000000000..64b24b0eb84
--- /dev/null
+++ b/dev-java/sjsxp/sjsxp-1.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Sun Java Streaming XML Parser (SJSXP) is an efficient implementation of the StAX API"
+HOMEPAGE="http://sjsxp.dev.java.net/"
+# CVS: cvs -d :pserver:guest@cvs.dev.java.net:/cvs checkout -r sjsxp-1_0_1 sjsxp/zephyr
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="bea.ri.jsr173"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEP="dev-java/jsr173"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/zephyr"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}/lib"
+ java-pkg_jar-from jsr173 jsr173.jar jsr173_1.0_api.jar
+}
+
+EANT_DOC_TARGET="javadocs"
+
+src_install() {
+ java-pkg_dojar "build/${PN}.jar"
+
+ use doc && java-pkg_dojavadoc build/docs/javadocs
+ use source && java-pkg_dosrc src
+}