summaryrefslogtreecommitdiff
path: root/dev-java/sun-jms/sun-jms-1.1-r2.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sun-jms/sun-jms-1.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sun-jms/sun-jms-1.1-r2.ebuild')
-rw-r--r--dev-java/sun-jms/sun-jms-1.1-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/sun-jms/sun-jms-1.1-r2.ebuild b/dev-java/sun-jms/sun-jms-1.1-r2.ebuild
new file mode 100644
index 00000000000..d58f46f4071
--- /dev/null
+++ b/dev-java/sun-jms/sun-jms-1.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+DOWNLOAD_PAGE="http://download.oracle.com/otndocs/jcp/7542-jms-1.1-fr-doc-oth-JSpec/"
+At="jms-${PV/./_}-fr-apidocs.zip"
+DESCRIPTION="The Java Message Service (JMS) API"
+HOMEPAGE="http://java.sun.com/products/jms/"
+SRC_URI="${At}"
+LICENSE="sun-bcla-jms"
+SLOT=0
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+RDEPEND=">=virtual/jre-1.3"
+DEPEND="app-arch/unzip
+ >=virtual/jdk-1.3"
+RESTRICT="fetch"
+
+S="${WORKDIR}/${PN//sun-/}${PV}"
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${DOWNLOAD_PAGE}"
+ einfo " 2. Accept the License Agreement"
+ einfo " 3. Download ${At}"
+ einfo " 4. Move the file to ${DISTDIR}"
+ einfo
+}
+
+src_unpack() {
+ unpack ${A}
+ rm -v "${S}"/lib/*.jar
+}
+
+src_compile() {
+ mkdir build
+ cd src/share
+ ejavac -nowarn -d "${S}"/build $(find . -name "*.java") || die "failed too build"
+ if use doc ; then
+ mkdir "${S}"/api
+ javadoc -d "${S}"/api -quiet javax.jms
+ fi
+
+ cd "${S}"
+ jar cf jms.jar -C build . || die "failed too create jar"
+}
+
+src_install() {
+ java-pkg_dojar jms.jar
+ use doc && java-pkg_dohtml -r api
+}