summaryrefslogtreecommitdiff
path: root/dev-java/tablelayout
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/tablelayout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/tablelayout')
-rw-r--r--dev-java/tablelayout/Manifest1
-rw-r--r--dev-java/tablelayout/metadata.xml6
-rw-r--r--dev-java/tablelayout/tablelayout-1.0.ebuild27
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/tablelayout/Manifest b/dev-java/tablelayout/Manifest
new file mode 100644
index 00000000000..7b5239aff3c
--- /dev/null
+++ b/dev-java/tablelayout/Manifest
@@ -0,0 +1 @@
+DIST tablelayout.jar 112151 SHA256 8ebba0e79da329d88a7c6c33560631143f2a329fdf0554c4e04e3a3049c99390 SHA512 b6e9ef07b50165679df8338123cc636b8165ab989e71afc9d1279e257bb171675aa46cc304e65d7e301c66117149675bd987c07d6cf5b03cd1c7768144e22902 WHIRLPOOL 323b524eff60c9970c91bb8ab6c870d525f92c674841061f269712e31e6cca40f498c43d5f4d202bf54012dcedc9c715ff3e8915d0bbff61ccf335c77c1c6cd5
diff --git a/dev-java/tablelayout/metadata.xml b/dev-java/tablelayout/metadata.xml
new file mode 100644
index 00000000000..e80ed52a09b
--- /dev/null
+++ b/dev-java/tablelayout/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/tablelayout/tablelayout-1.0.ebuild b/dev-java/tablelayout/tablelayout-1.0.ebuild
new file mode 100644
index 00000000000..a0b2fe7c1a8
--- /dev/null
+++ b/dev-java/tablelayout/tablelayout-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Layout manager that makes creating user interfaces fast and easy"
+HOMEPAGE="https://tablelayout.dev.java.net/"
+SRC_URI="http://www.oracle.com/technetwork/java/${PN}.jar"
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+java_prepare() {
+ find . -type f -name \*.class -exec rm -v {} \; || die
+
+ # two commmas cause a compiling error :/
+ sed -i -e 's#Dimension(40, 20);;#Dimension(40, 20);#g;' \
+ example/TypicalGui.java || die
+}