summaryrefslogtreecommitdiff
path: root/dev-lang/crystal
diff options
context:
space:
mode:
authorAzamat Khudaygulov <azamat@hudaygulov.ru>2018-01-10 00:58:55 +0300
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-09 23:09:30 +0000
commita05332599b1f351ec6043914c3e61e3ce8dd1efa (patch)
tree996c81cf71dae2f6552e8d8b68ffd9356c1cb36a /dev-lang/crystal
parent5f7fe4beb0939d19be32efdb8bd436f189f9b55c (diff)
downloadgentoo-a05332599b1f351ec6043914c3e61e3ce8dd1efa.tar.gz
gentoo-a05332599b1f351ec6043914c3e61e3ce8dd1efa.tar.xz
dev-lang/crystal: Fix build with doc use flag
In PR https://github.com/crystal-lang/crystal/pull/5217 directory doc renamed to docs Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6810
Diffstat (limited to 'dev-lang/crystal')
-rw-r--r--dev-lang/crystal/crystal-0.24.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/crystal/crystal-0.24.1.ebuild b/dev-lang/crystal/crystal-0.24.1.ebuild
index 5436a7888dd..d4dafefe6d4 100644
--- a/dev-lang/crystal/crystal-0.24.1.ebuild
+++ b/dev-lang/crystal/crystal-0.24.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -62,7 +62,7 @@ src_compile() {
CRYSTAL_PATH=src \
CRYSTAL_CONFIG_VERSION=${PV} \
CRYSTAL_CONFIG_PATH="lib:${EPREFIX}/usr/$(get_libdir)/crystal"
- use doc && emake doc
+ use doc && emake docs
}
src_test() {
@@ -93,7 +93,7 @@ src_install() {
if use doc ; then
docinto api
- dodoc -r doc/.
+ dodoc -r docs/.
fi
newbashcomp etc/completion.bash ${PN}