summaryrefslogtreecommitdiff
path: root/dev-lang/io
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/io
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/io')
-rw-r--r--dev-lang/io/Manifest1
-rw-r--r--dev-lang/io/files/io-2011.09.12-gentoo-fixes.patch160
-rw-r--r--dev-lang/io/io-2011.09.12-r2.ebuild101
-rw-r--r--dev-lang/io/metadata.xml27
4 files changed, 289 insertions, 0 deletions
diff --git a/dev-lang/io/Manifest b/dev-lang/io/Manifest
new file mode 100644
index 00000000000..b135e8f1c08
--- /dev/null
+++ b/dev-lang/io/Manifest
@@ -0,0 +1 @@
+DIST io-2011.09.12.tar.gz 9213332 SHA256 cdcf10745de2cd0aaa0c08f4ab31ac3aacfe942a8e1c2d52d5b50258862b5209 SHA512 15c994e5ca1c80b90523573000e402d60367f40692d01b9fcbaf0a00fba2a35939ea086cff25bae3533f1b89edc2cdae82f2c600a6d0c3e7792e5e57d92e4b72 WHIRLPOOL fe0d8d66e54104af5dd6e4ec0d44173cbd4e810b10f554f94037fb73d55887904002d236ff5f0da1307553650dd7204f8bff2eb3a74adf47bd2be3e02aa8752e
diff --git a/dev-lang/io/files/io-2011.09.12-gentoo-fixes.patch b/dev-lang/io/files/io-2011.09.12-gentoo-fixes.patch
new file mode 100644
index 00000000000..ff2e9115270
--- /dev/null
+++ b/dev-lang/io/files/io-2011.09.12-gentoo-fixes.patch
@@ -0,0 +1,160 @@
+diff -Nurwp io-2011.09.12-orig/addons/CMakeLists.txt io-2011.09.12-chag/addons/CMakeLists.txt
+--- io-2011.09.12-orig/addons/CMakeLists.txt 2011-09-12 18:14:12.000000000 -0400
++++ io-2011.09.12-chag/addons/CMakeLists.txt 2012-04-29 08:16:56.000000000 -0400
+@@ -52,71 +52,135 @@ add_subdirectory(BigNum)
+ add_subdirectory(Bitly)
+ add_subdirectory(Blowfish)
+ add_subdirectory(Box)
++if(ENABLE_CFFI)
+ add_subdirectory(CFFI)
++endif(ENABLE_CFFI)
++if(ENABLE_CGI)
+ add_subdirectory(CGI)
++endif(ENABLE_CGI)
+ #add_subdirectory(Cairo) # XXX: Broken on OSX: ld: library not found for -lpng12
++if(ENABLE_CLUTTER)
+ add_subdirectory(Clutter)
++endif(ENABLE_CLUTTER)
+ add_subdirectory(ContinuedFraction)
++if(ENABLE_CURSES)
+ add_subdirectory(Curses)
++endif(ENABLE_CURSES)
++if(ENABLE_DBI)
+ add_subdirectory(DBI)
++endif(ENABLE_DBI)
+ add_subdirectory(DistributedObjects)
++if(ENABLE_EDITLINE)
+ add_subdirectory(EditLine)
++endif(ENABLE_EDITLINE)
+ add_subdirectory(Facebook)
++if(ENABLE_FLUX)
+ add_subdirectory(Flux)
++endif(ENABLE_FLUX)
+ add_subdirectory(Fnmatch)
++if(ENABLE_FONT)
+ add_subdirectory(Font)
++endif(ENABLE_FONT)
+ add_subdirectory(GLFW) # XXX: Can't meet dependencies
++if(ENABLE_GOOGLESEARCH)
+ add_subdirectory(GoogleSearch)
++endif(ENABLE_GOOGLESEARCH)
++if(ENABLE_HTTPCLIENT)
+ add_subdirectory(HttpClient)
++endif(ENABLE_HTTPCLIENT)
++if(ENABLE_IMAGE)
+ add_subdirectory(Image)
++endif(ENABLE_IMAGE)
++if(ENABLE_LZO)
+ add_subdirectory(LZO)
++endif(ENABLE_LZO)
++if(ENABLE_LIBSNDFILE)
+ add_subdirectory(LibSndFile)
++endif(ENABLE_LIBSNDFILE)
++if(ENABLE_LIBXML2)
+ add_subdirectory(Libxml2)
++endif(ENABLE_LIBXML2)
+ add_subdirectory(Loki)
++if(ENABLE_LOUDMOUTH)
+ add_subdirectory(Loudmouth)
++endif(ENABLE_LOUDMOUTH)
++if(ENABLE_MD5SUM)
+ add_subdirectory(MD5)
++endif(ENABLE_MD5SUM)
+ add_subdirectory(Memcached)
++if(ENABLE_MYSQL)
+ add_subdirectory(MySQL)
++endif(ENABLE_MYSQL)
+ #add_subdirectory(NetworkAdapter)
+ add_subdirectory(NotificationCenter)
+ #add_subdirectory(Oauth) # OAuth should no longer break CMake configuration on Windows now.
+ #add_subdirectory(ODE) # XXX: Can't meet dependencies
+ add_subdirectory(ObjcBridge) # XXX: Broken for me -- Objective-C 2.0 not supported
+ add_subdirectory(Obsidian)
++if(ENABLE_OGG)
+ add_subdirectory(Ogg)
++endif(ENABLE_OGG)
++if(ENABLE_OPENGL)
+ add_subdirectory(OpenGL)
++endif(ENABLE_OPENGL)
+ #add_subdirectory(PortAudio) # XXX: Dependency broken for me
++if(ENABLE_POSTGRESQL)
+ add_subdirectory(PostgreSQL)
++endif(ENABLE_POSTGRESQL)
+ #add_subdirectory(Postgres)
++if(ENABLE_PYTHON)
+ add_subdirectory(Python)
++endif(ENABLE_PYTHON)
+ add_subdirectory(QDBM)
+ add_subdirectory(Random)
+ add_subdirectory(Range)
+ add_subdirectory(Rational)
++if(ENABLE_READLINE)
+ add_subdirectory(ReadLine)
++endif(ENABLE_READLINE)
++if(ENABLE_REGEX)
+ add_subdirectory(Regex)
++endif(ENABLE_REGEX)
+ add_subdirectory(SGML)
++if(ENABLE_SHA1)
+ add_subdirectory(SHA1)
++endif(ENABLE_SHA1)
+ #add_subdirectory(SQLite) # XXX: Want to delete in favour of SQLite3
++if(ENABLE_SQLITE3)
+ add_subdirectory(SQLite3)
++endif(ENABLE_SQLITE3)
+ #add_subdirectory(SampleRateConverter)
+ add_subdirectory(SecureSocket)
+ #add_subdirectory(SkipDB) # XXX: Disabled...why?
++if(ENABLE_SOCKET)
+ add_subdirectory(Socket)
++endif(ENABLE_SOCKET)
+ #add_subdirectory(SoundTouch) # XXX: I can't meet dependencies
+ add_subdirectory(SqlDatabase)
++if(ENABLE_SYSLOG)
+ add_subdirectory(Syslog)
++endif(ENABLE_SYSLOG)
+ add_subdirectory(SystemCall)
+ #add_subdirectory(TagDB) # XXX: I can't meet dependencies
+ #add_subdirectory(TagLib)
++if(ENABLE_THEORA)
+ add_subdirectory(Theora)
++endif(ENABLE_THEORA)
++if(ENABLE_THREAD)
+ add_subdirectory(Thread)
++endif(ENABLE_THREAD)
+ add_subdirectory(TokyoCabinet)
++if(ENABLE_TWITTER)
+ add_subdirectory(Twitter)
++endif(ENABLE_TWITTER)
+ add_subdirectory(UUID)
+ add_subdirectory(User)
+ add_subdirectory(VertexDB)
+ add_subdirectory(Volcano)
++if(ENABLE_VORBIS)
+ add_subdirectory(Vorbis)
++endif(ENABLE_VORBIS)
+ add_subdirectory(Yajl)
++if(ENABLE_ZLIB)
+ add_subdirectory(Zlib)
++endif(ENABLE_ZLIB)
+diff -Nurwp io-2011.09.12-orig/libs/basekit/CMakeLists.txt io-2011.09.12-chag/libs/basekit/CMakeLists.txt
+--- io-2011.09.12-orig/libs/basekit/CMakeLists.txt 2011-09-12 18:14:12.000000000 -0400
++++ io-2011.09.12-chag/libs/basekit/CMakeLists.txt 2012-04-21 22:06:47.000000000 -0400
+@@ -24,3 +24,6 @@ add_library(basekit SHARED ${SRCS})
+ # The following add the install target, so we put libbasekit.* in our
+ # install prefix.
+ install(TARGETS basekit DESTINATION lib)
++
++# Link basekit library against libdl (required by as-needed linking).
++target_link_libraries(basekit dl)
+diff -Nurwp io-2011.09.12-orig/libs/coroutine/source/asm.S io-2011.09.12-chag/libs/coroutine/source/asm.S
+--- io-2011.09.12-orig/libs/coroutine/source/asm.S 2011-09-12 18:14:12.000000000 -0400
++++ io-2011.09.12-chag/libs/coroutine/source/asm.S 2012-04-21 23:20:26.000000000 -0400
+@@ -258,3 +258,7 @@ SET:
+ ldr r0, [r0]
+ mov pc, lr
+ #endif
++
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/dev-lang/io/io-2011.09.12-r2.ebuild b/dev-lang/io/io-2011.09.12-r2.ebuild
new file mode 100644
index 00000000000..82c52db4f76
--- /dev/null
+++ b/dev-lang/io/io-2011.09.12-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Io is a small, prototype-based programming language"
+HOMEPAGE="http://www.iolanguage.com"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ http://dev.gentoo.org/~araujo/snapshots/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="cgi clutter dbi doc editline google gui http image libffi libxml2
+ lzo md5sum ncurses ogg opengl postgres pcre python readline sha1 sndfile sockets
+ sqlite syslog theora threads truetype twitter vorbis xmpp zlib"
+DEPEND="clutter? ( media-libs/clutter )
+ dbi? ( dev-db/libdbi )
+ editline? ( dev-libs/libedit )
+ image? ( virtual/jpeg
+ media-libs/tiff
+ media-libs/libpng )
+ xmpp? ( net-libs/loudmouth )
+ libffi? ( virtual/libffi )
+ libxml2? ( dev-libs/libxml2 )
+ lzo? ( dev-libs/lzo )
+ ncurses? ( sys-libs/ncurses )
+ ogg? ( media-libs/libogg )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql[server] )
+ readline? ( sys-libs/readline )
+ sndfile? ( media-libs/libsndfile )
+ sqlite? ( >=dev-db/sqlite-3.0.0 )
+ theora? ( media-libs/libtheora )
+ truetype? ( media-libs/freetype )
+ vorbis? ( media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )"
+RDEPEND=""
+REQUIRED_USE="vorbis? ( ogg )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo-fixes.patch"
+ # Fix multilib strict check (bug #430496)
+ sed -i 's/DESTINATION lib/DESTINATION lib${LIB_SUFFIX}/' \
+ addons/*/CMakeLists.txt \
+ libs/*/CMakeLists.txt
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable cgi CGI)
+ $(cmake-utils_use_enable clutter CLUTTER)
+ $(cmake-utils_use_enable dbi DBI)
+ $(cmake-utils_use_enable editline EDITLINE)
+ $(cmake-utils_use_enable libffi CFFI)
+ $(cmake-utils_use_enable gui FLUX)
+ $(cmake-utils_use_enable google GOOGLESEARCH)
+ $(cmake-utils_use_enable http HTTPCLIENT)
+ $(cmake-utils_use_enable xmpp LOUDMOUTH)
+ $(cmake-utils_use_enable image IMAGE)
+ $(cmake-utils_use_enable libxml2 LIBXML2)
+ $(cmake-utils_use_enable lzo LZO)
+ $(cmake-utils_use_enable md5sum MD5SUM)
+ $(cmake-utils_use_enable ncurses CURSES)
+ $(cmake-utils_use_enable ogg OGG)
+ $(cmake-utils_use_enable opengl OPENGL)
+ $(cmake-utils_use_enable postgres POSTGRESQL)
+ $(cmake-utils_use_enable python PYTHON)
+ $(cmake-utils_use_enable readline READLINE)
+ $(cmake-utils_use_enable pcre REGEX)
+ $(cmake-utils_use_enable sndfile LIBSNDFILE)
+ $(cmake-utils_use_enable sha1 SHA1)
+ $(cmake-utils_use_enable sockets SOCKET)
+ $(cmake-utils_use_enable sqlite SQLITE3)
+ $(cmake-utils_use_enable syslog SYSLOG)
+ $(cmake-utils_use_enable theora THEORA)
+ $(cmake-utils_use_enable threads THREADS)
+ $(cmake-utils_use_enable truetype FONT)
+ $(cmake-utils_use_enable twitter TWITTER )
+ $(cmake-utils_use_enable vorbis VORBIS)
+ $(cmake-utils_use_enable zlib ZLIB)
+ -DCMAKE_SKIP_RPATH=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ # Fix bug #414421
+ cmake-utils_src_compile -j1
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ dodoc docs/docs.css docs/*.html
+ fi
+}
diff --git a/dev-lang/io/metadata.xml b/dev-lang/io/metadata.xml
new file mode 100644
index 00000000000..39a9737f1bb
--- /dev/null
+++ b/dev-lang/io/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>araujo@gentoo.org</email>
+</maintainer>
+<use>
+<flag name="clutter">Build add-on for <pkg>media-libs/clutter</pkg></flag>
+<flag name="editline">Build add-on for <pkg>dev-libs/libedit</pkg></flag>
+<flag name="gui">Build the Flux GUI add-on</flag>
+<flag name="google">Build the google search add-on</flag>
+<flag name="http">Build http client add-on</flag>
+<flag name="image">Build add-on for images support (jpeg, png, tiff)</flag>
+<flag name="libxml2">Build add-on for <pkg>dev-libs/libxml2</pkg></flag>
+<flag name="md5sum">Build md5sum add-on</flag>
+<flag name="sha1">Build sha1 add-on</flag>
+<flag name="twitter">Build twitter add-on</flag>
+</use>
+<longdescription lang="en">
+Io is a small, prototype-based programming language. The ideas in Io are mostly
+inspired by Smalltalk (all values are objects), Self (prototype-based),
+NewtonScript (differential inheritance), Act1 (actors and futures for
+concurrency), LISP (code is a runtime inspectable/modifiable tree) and Lua
+(small, embeddable).
+</longdescription>
+</pkgmetadata>
+