summaryrefslogtreecommitdiff
path: root/dev-lang/jimtcl/jimtcl-9999.ebuild
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-02-16 23:40:23 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-02-16 23:40:53 +0300
commit28cd28f5dd96a74d456e2ba070b37439167a1606 (patch)
tree1b6137a59822ef44c09c7d06c4373e9cd4b5f5ea /dev-lang/jimtcl/jimtcl-9999.ebuild
parent08d0f7afc10bf4ac8e24b5527577f310bf17d3a3 (diff)
downloadgentoo-28cd28f5dd96a74d456e2ba070b37439167a1606.tar.gz
gentoo-28cd28f5dd96a74d456e2ba070b37439167a1606.tar.xz
dev-lang/jimtcl: Version bump
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-lang/jimtcl/jimtcl-9999.ebuild')
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
index 64b38756f80..cd5797414a6 100644
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
inherit eutils
@@ -9,8 +9,7 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
inherit git-r3
else
- inherit vcs-snapshot
- SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
+ SRC_URI="https://github.com/msteveb/jimtcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~sh ~x86"
fi
@@ -30,15 +29,9 @@ src_unpack() {
git-2_src_unpack
else
default
- cd "${WORKDIR}"/msteveb-jimtcl-* || die
- S=${PWD}
fi
}
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.75-bootstrap.patch
-}
-
src_configure() {
CCACHE=None econf --with-jim-shared
if use static-libs ; then
@@ -65,5 +58,5 @@ src_install() {
doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h \
jim-win32compat.h jim-eventloop.h jim-config.h
dodoc AUTHORS README TODO
- use doc && dohtml Tcl.html
+ dodoc Tcl.html
}