summaryrefslogtreecommitdiff
path: root/dev-lang/nasm/nasm-2.14.02.ebuild
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-01-15 09:24:04 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-01-15 09:28:25 +0000
commitb4a6514336c311a206526a03ca6b5433e7a33455 (patch)
treed35114cd514662ad6ea1f33a7568c0b3cca4f570 /dev-lang/nasm/nasm-2.14.02.ebuild
parent4c7debeccab9d1ea546ffbd6cbb9ff352aba8f63 (diff)
downloadgentoo-b4a6514336c311a206526a03ca6b5433e7a33455.tar.gz
gentoo-b4a6514336c311a206526a03ca6b5433e7a33455.tar.xz
dev-lang/nasm: bump up to 2.14.02
Reported-by: Arfrever Frehtes Taifersar Arahesis Fixes: https://bugs.gentoo.org/675472 Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/nasm/nasm-2.14.02.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.14.02.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-2.14.02.ebuild b/dev-lang/nasm/nasm-2.14.02.ebuild
new file mode 100644
index 00000000000..2df6236496d
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.14.02.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="https://www.nasm.us/"
+SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+# [fonts note] doc/psfonts.ph defines ordered list of font preference.
+# Currently 'media-fonts/source-pro' is most preferred and is able to
+# satisfy all 6 font flavours: tilt, chapter, head, etc.
+BDEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/source-pro
+ virtual/perl-File-Spec
+ )
+"
+
+S=${WORKDIR}/${P/_}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.13.03-bsd-cp-doc.patch
+)
+
+src_configure() {
+ strip-flags
+ default
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_rdf $(usex doc install_doc '')
+}