summaryrefslogtreecommitdiff
path: root/dev-lang/pocl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/pocl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/pocl')
-rw-r--r--dev-lang/pocl/Manifest1
-rw-r--r--dev-lang/pocl/metadata.xml8
-rw-r--r--dev-lang/pocl/pocl-0.11.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-lang/pocl/Manifest b/dev-lang/pocl/Manifest
new file mode 100644
index 00000000000..56f3cbe787f
--- /dev/null
+++ b/dev-lang/pocl/Manifest
@@ -0,0 +1 @@
+DIST pocl-0.11.tar.gz 1561743 SHA256 24bb801fb87d104b66faaa95d1890776fdeabb37ad1b12fb977281737c7f29bb SHA512 052cbac36a12a5b015779740c45b64adde5fa58a090f298b69de1df3ac9875d7bfc6dfe9f7ae95d14d974d7b44dc64e53ce6ad3a9b8e74708d546ef6e1032151 WHIRLPOOL 860a87904408eb7394e126bf5c8cab619d8f1d48a57440e9d73f585c5eaa1a70e53c5843f4ffbaa742447cd0e8ebf9c11fc0917357f6af203ecb1c3c48c0fa87
diff --git a/dev-lang/pocl/metadata.xml b/dev-lang/pocl/metadata.xml
new file mode 100644
index 00000000000..6719fcd2bb3
--- /dev/null
+++ b/dev-lang/pocl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-lang/pocl/pocl-0.11.ebuild b/dev-lang/pocl/pocl-0.11.ebuild
new file mode 100644
index 00000000000..f55e02299d1
--- /dev/null
+++ b/dev-lang/pocl/pocl-0.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="PortableCL: opensource implementation of the OpenCL standard"
+HOMEPAGE="http://portablecl.org/"
+SRC_URI="http://portablecl.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/ocl-icd
+ =sys-devel/llvm-3.6*
+ sys-apps/hwloc"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ # Needs an OpenCL 1.2 ICD, mesa and nvidia are invalid
+ # Maybe ati works, feel free to add/fix if you can test
+ if [[ $(eselect opencl show) == 'ocl-icd' ]]; then
+ einfo "Valid OpenCL ICD set"
+ else
+ eerror "Please use a supported ICD:"
+ eerror "eselect opencl set ocl-icd"
+ die "OpenCL ICD not set to a supported value"
+ fi
+}