summaryrefslogtreecommitdiff
path: root/dev-lang/polyml
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-04-06 21:11:50 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-04-06 21:12:13 +0200
commitff358332fcfdfb62a0d5b90db18c142849e1aadb (patch)
tree0d82a6d606ae1fc639a727c0683c00b632b46ef4 /dev-lang/polyml
parent3230f4fae4d914eabb4683d57f27d0633d3adc6b (diff)
downloadgentoo-ff358332fcfdfb62a0d5b90db18c142849e1aadb.tar.gz
gentoo-ff358332fcfdfb62a0d5b90db18c142849e1aadb.tar.xz
dev-lang/polyml: bump to 5.8
Closes https://bugs.gentoo.org/619990 Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-lang/polyml')
-rw-r--r--dev-lang/polyml/Manifest1
-rw-r--r--dev-lang/polyml/polyml-5.6.ebuild1
-rw-r--r--dev-lang/polyml/polyml-5.8.ebuild58
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-lang/polyml/Manifest b/dev-lang/polyml/Manifest
index 9d695ab7117..2c0f434a74b 100644
--- a/dev-lang/polyml/Manifest
+++ b/dev-lang/polyml/Manifest
@@ -1,4 +1,5 @@
DIST polyml-5.6.tar.gz 6066166 BLAKE2B dc7e35ad1f51f270f9043736bca8b3d8a96e208dfa2833a2de3c06c969e8bb9d5e92c3ab025e4e55539188a9d6d5000b7befdd3cfc17aa3b0e54315778ab71b0 SHA512 cd4f25c225831dec512f7136dfda4ba31abd6939d9e8e0cacdb6d48212488b56ba5969c76e76fcbfcfa83d015a67d9cf62457286086f3c2b3f7914a7939d7b59
+DIST polyml-5.8.tar.gz 9817105 BLAKE2B 93992c8baa78017bfda6c2151d1f48805829b77c0b7ed9bec87c951fc4a4236459ed59aab1eca88ed4a1d7aa10eb9734f93324583e012b18bb7d8cce84b5a35b SHA512 50baed79b50b14bd87acc637de93fd6d0f05e61fe0f03682a12a1d2c5f382313488d48f84b49ad915b01acc5a3a5769fb05fcaa7b24499c56402ddd3ba393930
DIST polyml.5.4.1.tar.gz 6107319 BLAKE2B 1fdff3b26fa7554a0f3d31cca0dc4a4e013fb930e6295cd6107012bc67e87db1f64916087edb34e403c3e1a88b26bff947c1cc9d946fe93ac7a1144434d15081 SHA512 4a7b404ed648b5a9fd9d52917214688d15f4f9a5f4570ba13b52a8304bde1cc4b534f539ffc3c9554283816ae130e4c898a179d776df6d3220fba9743a19b175
DIST polyml.5.5.1.tar.gz 5465794 BLAKE2B 0ae6973c866cdf33e0eeb26475c95f26f11eca13458ab52c2c6fd3f4b3034cd5e71a7e4dbff5574070a11833479bff2723066bfc71367d71cd6e4f9f17a5cba1 SHA512 283954c8bf5599d83ea69916b827b1acae7137fe4add67537026092da2e6f1a89d71d3a394dbba599bbe9e967ded1446f39f4d81afb90301532db6be949f7a6f
DIST polyml.5.5.2.tar.gz 5599140 BLAKE2B 08b7c4be7c52bd8f57c53f6caa24be7ab457c7419459192f33369bf3c7024002ffd98dfd7af4db53c3a2484f9c966010a635f4e09e9edf8a62b5d5230f9a04bf SHA512 248c2a38c4691898bc1243a041f4683bf227d9c8a98c6c3545af2a8a3249ed5ed96f33f90cb2dede8809b42f33c0557650147302cfe046a5fba965ccd93cbc5b
diff --git a/dev-lang/polyml/polyml-5.6.ebuild b/dev-lang/polyml/polyml-5.6.ebuild
index f4997ba3dd2..6ec40e59241 100644
--- a/dev-lang/polyml/polyml-5.6.ebuild
+++ b/dev-lang/polyml/polyml-5.6.ebuild
@@ -35,6 +35,7 @@ src_configure() {
--enable-shared \
--disable-static \
--with-system-libffi \
+ --with-pic=pic-only \
$(use_with X x) \
$(use_with gmp) \
$(use_with portable) \
diff --git a/dev-lang/polyml/polyml-5.8.ebuild b/dev-lang/polyml/polyml-5.8.ebuild
new file mode 100644
index 00000000000..b38959ceb05
--- /dev/null
+++ b/dev-lang/polyml/polyml-5.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools pax-utils
+
+DESCRIPTION="Poly/ML is a full implementation of Standard ML"
+HOMEPAGE="https://www.polyml.org"
+SRC_URI="https://codeload.github.com/polyml/polyml/tar.gz/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="X elibc_glibc +gmp portable test +threads"
+
+RDEPEND="X? ( x11-libs/motif:0 )
+ gmp? ( >=dev-libs/gmp-5 )
+ elibc_glibc? ( threads? ( >=sys-libs/glibc-2.13 ) )
+ virtual/libffi"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.6-configure.patch
+ "${FILESDIR}"/${PN}-5.6-ffi3.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static \
+ --with-system-libffi \
+ --with-pic=pic-only \
+ $(use_with X x) \
+ $(use_with gmp) \
+ $(use_with portable) \
+ $(use_with threads)
+}
+
+src_compile() {
+ # Bug 453146 - dev-lang/polyml-5.5.0: fails to build (pax kernel?)
+ pushd libpolyml || die "Could not cd to libpolyml"
+ emake
+ popd
+ emake polyimport
+ pax-mark m "${S}/.libs/polyimport"
+ emake
+ pax-mark m "${S}/.libs/poly"
+}
+
+src_test() {
+ emake tests || die "tests failed"
+}