summaryrefslogtreecommitdiff
path: root/dev-lang/python
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-11-11 19:18:49 -0500
committerMike Gilbert <floppym@gentoo.org>2015-11-11 19:45:27 -0500
commit1e379f1f1a61be360bf9cf59030e15862c2a3d21 (patch)
treeafcb2ce9d2e5ade6a07c0b0a66231fffa4ecb3c3 /dev-lang/python
parentfa5cc11feefd6de4503a81714e0dce64f4041a49 (diff)
downloadgentoo-1e379f1f1a61be360bf9cf59030e15862c2a3d21.tar.gz
gentoo-1e379f1f1a61be360bf9cf59030e15862c2a3d21.tar.xz
dev-lang/python: Set PYTHON_SITEDIR manually
The eclass change in fd4001e9 causes python_export to call ${PYTHON} to obtain PYTHON_SITEDIR. This returns an empty string if ${PYTHON} has not yet been merged. Package-Manager: portage-2.2.23_p26
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.7.10-r2.ebuild3
-rw-r--r--dev-lang/python/python-2.7.10-r3.ebuild3
-rw-r--r--dev-lang/python/python-2.7.10.ebuild3
-rw-r--r--dev-lang/python/python-2.7.9-r1.ebuild3
-rw-r--r--dev-lang/python/python-3.3.5-r1.ebuild3
-rw-r--r--dev-lang/python/python-3.3.5-r2.ebuild3
-rw-r--r--dev-lang/python/python-3.3.5-r3.ebuild3
-rw-r--r--dev-lang/python/python-3.4.3-r2.ebuild3
-rw-r--r--dev-lang/python/python-3.4.3-r3.ebuild1
-rw-r--r--dev-lang/python/python-3.4.3.ebuild3
-rw-r--r--dev-lang/python/python-3.5.0-r1.ebuild3
-rw-r--r--dev-lang/python/python-3.5.0-r2.ebuild3
12 files changed, 23 insertions, 11 deletions
diff --git a/dev-lang/python/python-2.7.10-r2.ebuild b/dev-lang/python/python-2.7.10-r2.ebuild
index fbdee646c75..a8eeb9f16d8 100644
--- a/dev-lang/python/python-2.7.10-r2.ebuild
+++ b/dev-lang/python/python-2.7.10-r2.ebuild
@@ -306,7 +306,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-2.7.10-r3.ebuild b/dev-lang/python/python-2.7.10-r3.ebuild
index 70d8d82916b..31c6506f0e6 100644
--- a/dev-lang/python/python-2.7.10-r3.ebuild
+++ b/dev-lang/python/python-2.7.10-r3.ebuild
@@ -304,7 +304,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-2.7.10.ebuild b/dev-lang/python/python-2.7.10.ebuild
index 393636d5cd2..2d6f00d0b1b 100644
--- a/dev-lang/python/python-2.7.10.ebuild
+++ b/dev-lang/python/python-2.7.10.ebuild
@@ -314,7 +314,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-2.7.9-r1.ebuild b/dev-lang/python/python-2.7.9-r1.ebuild
index a31a4475e30..20cdedb0ea7 100644
--- a/dev-lang/python/python-2.7.9-r1.ebuild
+++ b/dev-lang/python/python-2.7.9-r1.ebuild
@@ -315,7 +315,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-3.3.5-r1.ebuild b/dev-lang/python/python-3.3.5-r1.ebuild
index dffc13b9fed..64e520ba1e9 100644
--- a/dev-lang/python/python-3.3.5-r1.ebuild
+++ b/dev-lang/python/python-3.3.5-r1.ebuild
@@ -280,7 +280,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-3.3.5-r2.ebuild b/dev-lang/python/python-3.3.5-r2.ebuild
index f14b1216b49..b6256f8e709 100644
--- a/dev-lang/python/python-3.3.5-r2.ebuild
+++ b/dev-lang/python/python-3.3.5-r2.ebuild
@@ -286,7 +286,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-3.3.5-r3.ebuild b/dev-lang/python/python-3.3.5-r3.ebuild
index 3ec857b2d22..4b773d22fff 100644
--- a/dev-lang/python/python-3.3.5-r3.ebuild
+++ b/dev-lang/python/python-3.3.5-r3.ebuild
@@ -291,7 +291,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${PYVER}" "${ED}etc/init.d/pydoc-${PYVER}" || die "sed failed"
# for python-exec
- python_export python${PYVER} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${PYVER} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${PYVER}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-3.4.3-r2.ebuild b/dev-lang/python/python-3.4.3-r2.ebuild
index cf156152161..86ebb5e5c6b 100644
--- a/dev-lang/python/python-3.4.3-r2.ebuild
+++ b/dev-lang/python/python-3.4.3-r2.ebuild
@@ -267,7 +267,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-3.4.3-r3.ebuild b/dev-lang/python/python-3.4.3-r3.ebuild
index c57324c0dac..dba49e89bb8 100644
--- a/dev-lang/python/python-3.4.3-r3.ebuild
+++ b/dev-lang/python/python-3.4.3-r3.ebuild
@@ -275,6 +275,7 @@ src_install() {
# for python-exec
python_export python${PYVER} EPYTHON PYTHON PYTHON_SITEDIR
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${PYVER}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-3.4.3.ebuild b/dev-lang/python/python-3.4.3.ebuild
index e82805238b1..3ab43cf075a 100644
--- a/dev-lang/python/python-3.4.3.ebuild
+++ b/dev-lang/python/python-3.4.3.ebuild
@@ -275,7 +275,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-3.5.0-r1.ebuild b/dev-lang/python/python-3.5.0-r1.ebuild
index f3d4b419eab..d808c8357f5 100644
--- a/dev-lang/python/python-3.5.0-r1.ebuild
+++ b/dev-lang/python/python-3.5.0-r1.ebuild
@@ -273,7 +273,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
diff --git a/dev-lang/python/python-3.5.0-r2.ebuild b/dev-lang/python/python-3.5.0-r2.ebuild
index 30e4d9f8b4e..e3293e3792e 100644
--- a/dev-lang/python/python-3.5.0-r2.ebuild
+++ b/dev-lang/python/python-3.5.0-r2.ebuild
@@ -277,7 +277,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${PYVER}" "${ED}etc/init.d/pydoc-${PYVER}" || die "sed failed"
# for python-exec
- python_export python${PYVER} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${PYVER} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${PYVER}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then