summaryrefslogtreecommitdiff
path: root/dev-lang/ruby/ruby-2.1.10.ebuild
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-06 08:01:55 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-06 08:01:55 +0200
commit2f0298775dfe7e41ed696ed4d62b702d6fa914f4 (patch)
tree5802815598ce449b17c9a8da17f5e09200e7a4a2 /dev-lang/ruby/ruby-2.1.10.ebuild
parent5e7b1f83ebaf970e5fdde62809e56e41c3af84e1 (diff)
downloadgentoo-2f0298775dfe7e41ed696ed4d62b702d6fa914f4.tar.gz
gentoo-2f0298775dfe7e41ed696ed4d62b702d6fa914f4.tar.xz
dev-lang/ruby: fix bootstrap build on uclibc
With a blank LIBPATHENV the ruby build tools fall back to using LD_PRELOAD to load libruby.so during the build process. With uclibc, preloading is now optional and not enabled at least in the vanilla stage3 that we produce. This causes the build to fail since there are no options left to find libruby.so. Fixed by adding ${S} to the temporary LD_LIBRARY_PATH during the install phase. Thanks to blueness for the original patch. Fixes bug 564272 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang/ruby/ruby-2.1.10.ebuild')
-rw-r--r--dev-lang/ruby/ruby-2.1.10.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/ruby/ruby-2.1.10.ebuild b/dev-lang/ruby/ruby-2.1.10.ebuild
index 82cc4e6f9c8..f49f79df6f2 100644
--- a/dev-lang/ruby/ruby-2.1.10.ebuild
+++ b/dev-lang/ruby/ruby-2.1.10.ebuild
@@ -181,7 +181,7 @@ src_install() {
local MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
- LD_LIBRARY_PATH="${D}/usr/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
+ LD_LIBRARY_PATH="${S}:${D}/usr/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${RUBYVERSION}"
for d in $(find "${S}/ext" -type d) ; do
RUBYLIB="${RUBYLIB}:$d"