summaryrefslogtreecommitdiff
path: root/dev-lang/ucblogo/ucblogo-5.5-r1.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/ucblogo/ucblogo-5.5-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/ucblogo/ucblogo-5.5-r1.ebuild')
-rw-r--r--dev-lang/ucblogo/ucblogo-5.5-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lang/ucblogo/ucblogo-5.5-r1.ebuild b/dev-lang/ucblogo/ucblogo-5.5-r1.ebuild
new file mode 100644
index 00000000000..cd9bdb22ef3
--- /dev/null
+++ b/dev-lang/ucblogo/ucblogo-5.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils elisp-common toolchain-funcs
+
+DESCRIPTION="a reflective, functional programming language"
+HOMEPAGE="http://www.cs.berkeley.edu/~bh/logo.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="emacs X"
+
+DEPEND="emacs? ( virtual/emacs )
+ X? ( x11-libs/libICE x11-libs/libSM x11-libs/libX11 )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-destdir.patch
+ epatch "${FILESDIR}"/${P}-fhs.patch
+ epatch "${FILESDIR}"/${P}-dont-require-tetex.patch
+ use emacs || epatch "${FILESDIR}"/${P}-no-emacs.patch
+# use emacs || echo 'all install:' > emacs/makefile
+}
+
+src_compile() {
+ econf $(use_with X x) || die
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}