summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-01-25 20:44:39 +0100
committerMichał Górny <mgorny@gentoo.org>2016-01-25 20:45:37 +0100
commit4cc1487379c364a4374e94f003efad3176d23124 (patch)
tree7e7afe3c16f98e02472e3e293ea002d0c94e38ab /dev-lang
parent1f81a793c50b740fd615b1be044d8dc569742684 (diff)
downloadgentoo-4cc1487379c364a4374e94f003efad3176d23124.tar.gz
gentoo-4cc1487379c364a4374e94f003efad3176d23124.tar.xz
dev-lang/ekopath: Snapshot bump
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ekopath/Manifest1
-rw-r--r--dev-lang/ekopath/ekopath-6.0.661_p20160124.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-lang/ekopath/Manifest b/dev-lang/ekopath/Manifest
index 6466e017953..b4f4c5e87a3 100644
--- a/dev-lang/ekopath/Manifest
+++ b/dev-lang/ekopath/Manifest
@@ -1,2 +1,3 @@
DIST ekopath-2015-12-13-installer.run 57231316 SHA256 85a3fc7df59373bfef32bf9388fd77c19d7c780dc5e9e52e1e8664f0139a9ac6 SHA512 9454f263c921d26f521e374eb2f346f1e257bf58daf2ce5e54ce1a2cced7291bd9b5ece08cd4da441498f66bcd6a01a45309d4463fe65ea5d094b21612a8d3f8 WHIRLPOOL 3157ed63da3d87912163af2e8927a332640b2682289234b25b5f7b75a698490dc2cf8e0d5f51d82eb0b072654f15040c6b94f94e3cf7a428b793a575d6f71ed0
DIST ekopath-2015-12-31-installer.run 57236877 SHA256 f8e5a2910ac001ace7d42254553e27f79b62eb6650d89778eced3ff483854917 SHA512 d191ce829c1c285c848c58f7bca194df72975d0d0685cf70c324831ca9ce67729dbf9fa46f36b4e17cc726fb8144739608fa825d4e2dd447b40dc0b1461f9f9b WHIRLPOOL 7988f8c93522aa38ec18c69979789fda1f64ab647d712da02260961a98e7ee75d90525c76947e6f32c073f289af419154d58072e5edac5093fdeaee7489c096c
+DIST ekopath-2016-01-24-installer.run 57266129 SHA256 3ea7471dc29ccfd89b7a7cee788243cd94f0b86cbe4345f7576a4444119b1122 SHA512 514e1a317822ca8edf2bfe2f2d99928717876731fbb3949165ded97fe7ed99acf01eb27f862ba9c84e8a3fd4f0c46aa31734925847351ad0b74a4d0bde8c4240 WHIRLPOOL a9ca485f5196563fd5fe449c3ab745c162492eff6c51b560234338ab0aa96b3128fd44e401eb28e50c47425315447c1b8f2f9a80bb9ce59fdac21232c6262f8d
diff --git a/dev-lang/ekopath/ekopath-6.0.661_p20160124.ebuild b/dev-lang/ekopath/ekopath-6.0.661_p20160124.ebuild
new file mode 100644
index 00000000000..c886d135281
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.661_p20160124.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator multilib pax-utils
+
+MY_PV=$(get_version_component_range 1-3)
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND=""
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="
+ opt/${PN}/lib/${MY_PV}/x8664/*
+ opt/${PN}/bin/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_prepare() {
+ cat > 99${PN} <<-EOF || die
+ PATH=${EROOT%/}/opt/${PN}/bin
+ ROOTPATH=${EROOT%/}/opt/${PN}/bin
+ LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
+ MANPATH=${EROOT%/}/opt/${PN}/docs/man
+ EOF
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${PN}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${PN}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${PN}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${PN}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${PN}"/uninstall* || die
+ doenvd 99${PN}
+}