summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2018-07-25 10:20:41 -0400
committerIan Stakenvicius <axs@gentoo.org>2018-07-25 10:21:14 -0400
commit52881c05b0e493b710f847d16780357ce768135b (patch)
tree1c13a527c9213d1b8a33f55168d50c406ead9bcd /dev-lang
parent8ac733120e798eaaf0f1ffa20442a8d9ace5fd55 (diff)
downloadgentoo-52881c05b0e493b710f847d16780357ce768135b.tar.gz
gentoo-52881c05b0e493b710f847d16780357ce768135b.tar.xz
dev-lang/spidermonkey: don't hardcode libc soname on :45 and :52
Applying patch from bug 631574 to both versions as upstream did not address this issue until :60 Bug: http://bugs.gentoo.org/631574 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-45.0.2.ebuild7
-rw-r--r--dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild4
2 files changed, 6 insertions, 5 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-45.0.2.ebuild b/dev-lang/spidermonkey/spidermonkey-45.0.2.ebuild
index 2602ecc5e97..065995e59d0 100644
--- a/dev-lang/spidermonkey/spidermonkey-45.0.2.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-45.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ MY_PN="mozjs"
MY_P="${MY_PN}-${PV/_/.}"
DESCRIPTION="Stand-alone JavaScript C library"
HOMEPAGE="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
-SRC_URI="https://people.mozilla.org/~sfink/${MY_P}.tar.bz2
+SRC_URI="https://archive.mozilla.org/pub/${PN}/releases/${PV}/${MY_P}.tar.bz2
https://dev.gentoo.org/~axs/distfiles/${PN}-slot45-patches-01.tar.xz"
LICENSE="NPL-1.1"
@@ -40,7 +40,8 @@ src_prepare() {
"${WORKDIR}"/sm45/mozjs45-1266366.patch \
"${WORKDIR}"/sm45/mozjs38-pkg-config-version.patch \
"${WORKDIR}"/sm45/mozilla_configure_regexp_esr.patch \
- "${WORKDIR}"/sm45/${PN}-${SLOT}-dont-symlink-non-objfiles.patch
+ "${WORKDIR}"/sm45/${PN}-${SLOT}-dont-symlink-non-objfiles.patch \
+ "${FILESDIR}"/moz38-dont-hardcode-libc-soname.patch
# apply relevant (modified) patches from gentoo's firefox-45 patchset
eapply "${WORKDIR}"/sm45/ff45
diff --git a/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild b/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild
index c8ae70994d2..f1a9493f9fd 100644
--- a/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://ftp.mozilla.org/pub/spidermonkey/prereleases/52/pre1/mozjs-52.9.
LICENSE="NPL-1.1"
SLOT="52"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug +jit minimal +system-icu test"
+IUSE="debug minimal +system-icu test"
RESTRICT="ia64? ( test )"
@@ -45,6 +45,7 @@ src_prepare() {
|| die
eapply "${WORKDIR}/${PN}"
+ eapply "${FILESDIR}"/moz38-dont-hardcode-libc-soname.patch
#eapply "${FILESDIR}"/${PN}-52-baseconfig.patch
eapply_user
@@ -76,7 +77,6 @@ src_configure() {
--with-intl-api \
$(use_with system-icu) \
$(use_enable debug) \
- $(use_enable jit ion) \
$(use_enable test tests) \
XARGS="/usr/bin/xargs" \
SHELL="${SHELL:-${EPREFIX}/bin/bash}" \