summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-22 01:24:16 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-22 03:04:58 +1200
commitb57e85b8819e26f2f4514b5c1df9d3ec4fcc22fd (patch)
treeaf90dcd217583ba63c3f0d81f8091ddfd16eb6db /dev-lang
parent38a9278233b784c5115e344b9b3d8263d5268f2e (diff)
downloadgentoo-b57e85b8819e26f2f4514b5c1df9d3ec4fcc22fd.tar.gz
gentoo-b57e85b8819e26f2f4514b5c1df9d3ec4fcc22fd.tar.xz
dev-lang/perl: Ensure PATCH_BASE is common between -9999 and not
This is because we don't need to update the patches as often as perl updates, because the patch set tends to be portable across versions. This prevents us from needing a new patch tarball simply because we changed version. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/perl-5.26.9999.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/dev-lang/perl/perl-5.26.9999.ebuild b/dev-lang/perl/perl-5.26.9999.ebuild
index c2fddc553e7..908abf6dd82 100644
--- a/dev-lang/perl/perl-5.26.9999.ebuild
+++ b/dev-lang/perl/perl-5.26.9999.ebuild
@@ -7,6 +7,7 @@ inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessin
PATCH_VER=1
CROSS_VER=1.1.4
+PATCH_BASE="perl-5.25.11-patches-${PATCH_VER}"
DIST_AUTHOR=XSAWYERX
@@ -21,14 +22,12 @@ if [[ "${PV##*.}" == "9999" ]]; then
# Devel Releases are not ABI-intercompatible
SUBSLOT="${DIST_VERSION}"
MY_P="perl-${DIST_VERSION/_rc/-RC}"
- PATCH_BASE="perl-5.25.11-patches-${PATCH_VER}"
MY_PV="${DIST_VERSION%_rc*}"
else
# First 2 digits only
SHORT_PV="${PV%.*}"
SUBSLOT="${SHORT_PV}"
MY_P="perl-${PV/_rc/-RC}"
- PATCH_BASE="${MY_P}-patches-${PATCH_VER}"
MY_PV="${PV%_rc*}"
fi