summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-01-18 11:39:10 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-01-18 11:40:09 -0800
commitd677f9472c401dc87721904b156d6857ef62551f (patch)
tree9f8a1f1a6ada606d41b36decd0887ff23bc24d5e /dev-lang
parent0740046ab6c12a019bc28056e9e334264ae9286d (diff)
downloadgentoo-d677f9472c401dc87721904b156d6857ef62551f.tar.gz
gentoo-d677f9472c401dc87721904b156d6857ef62551f.tar.xz
dev-lang/rust: Disable system-llvm USE flag in 1.32.0 (bug #675752)
Add "!system-llvm" to REQUIRED_USE since 1.32.0 pulls in a git version of llvm to fix the segfault. Also bump the llvm dep to >=7 since 7 is required now. Bug: https://bugs.gentoo.org/675752 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.32.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.32.0.ebuild b/dev-lang/rust/rust-1.32.0.ebuild
index 8b125eb86e3..6adfe7ff5b4 100644
--- a/dev-lang/rust/rust-1.32.0.ebuild
+++ b/dev-lang/rust/rust-1.32.0.ebuild
@@ -45,7 +45,7 @@ COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
net-libs/libssh2
net-libs/http-parser:=
net-misc/curl[ssl]
- system-llvm? ( >=sys-devel/llvm-6:= )"
+ system-llvm? ( >=sys-devel/llvm-7:= )"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
|| (
@@ -59,6 +59,9 @@ RDEPEND="${COMMON_DEPEND}
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
x86? ( cpu_flags_x86_sse2 )"
+# bug #675752
+REQUIRED_USE+=" !system-llvm"
+
S="${WORKDIR}/${MY_P}-src"
PATCHES=( "${FILESDIR}"/1.30.1-clippy-sysroot.patch )