summaryrefslogtreecommitdiff
path: root/dev-libs/DirectFB
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-10-02 23:18:10 +0300
committerDavid Seifert <soap@gentoo.org>2016-10-02 22:38:15 +0200
commite7ff8b0cb8ac46a520b4c7de22b4c28c1ebb26a7 (patch)
tree3633a1c5b367b78ea6913b383ec1a8822d9c334b /dev-libs/DirectFB
parentb8dc70338e454eff146c7c5584a6b053ef37ea6b (diff)
downloadgentoo-e7ff8b0cb8ac46a520b4c7de22b4c28c1ebb26a7.tar.gz
gentoo-e7ff8b0cb8ac46a520b4c7de22b4c28c1ebb26a7.tar.xz
dev-libs/DirectFB: fix build with divine use flag
Add a patch to create a header file, which was omitted from dist tarball, but is present in upstream vcs. Gentoo-Bug: 573584 Closes: https://github.com/gentoo/gentoo/pull/2454 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-1.7.6.ebuild3
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.7.6-idivine.patch57
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/DirectFB/DirectFB-1.7.6.ebuild b/dev-libs/DirectFB/DirectFB-1.7.6.ebuild
index 3ea4b16cd6e..68679a58ec3 100644
--- a/dev-libs/DirectFB/DirectFB-1.7.6.ebuild
+++ b/dev-libs/DirectFB/DirectFB-1.7.6.ebuild
@@ -76,7 +76,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.7.1-build.patch \
"${FILESDIR}"/${PN}-1.6.3-setregion.patch \
"${FILESDIR}"/${PN}-1.6.3-atomic-fix-compiler-error-when-building-for-thumb2.patch \
- "${FILESDIR}"/${PN}-1.7.6-cle266.patch
+ "${FILESDIR}"/${PN}-1.7.6-cle266.patch \
+ "${FILESDIR}"/${PN}-1.7.6-idivine.patch
sed -i \
-e '/#define RASPBERRY_PI/d' \
systems/egl/egl_system.c || die #497124
diff --git a/dev-libs/DirectFB/files/DirectFB-1.7.6-idivine.patch b/dev-libs/DirectFB/files/DirectFB-1.7.6-idivine.patch
new file mode 100644
index 00000000000..561db23aeed
--- /dev/null
+++ b/dev-libs/DirectFB/files/DirectFB-1.7.6-idivine.patch
@@ -0,0 +1,57 @@
+--- lib/divine/idivine.h.orig
++++ lib/divine/idivine.h
+@@ -0,0 +1,54 @@
++/*
++ (c) Copyright 2012-2013 DirectFB integrated media GmbH
++ (c) Copyright 2001-2013 The world wide DirectFB Open Source Community (directfb.org)
++ (c) Copyright 2000-2004 Convergence (integrated media) GmbH
++
++ All rights reserved.
++
++ Written by Denis Oliver Kropp <dok@directfb.org>,
++ Andreas Shimokawa <andi@directfb.org>,
++ Marek Pikarski <mass@directfb.org>,
++ Sven Neumann <neo@directfb.org>,
++ Ville Syrjälä <syrjala@sci.fi> and
++ Claudio Ciccani <klan@users.sf.net>.
++
++ This library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2 of the License, or (at your option) any later version.
++
++ This library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with this library; if not, write to the
++ Free Software Foundation, Inc., 59 Temple Place - Suite 330,
++ Boston, MA 02111-1307, USA.
++*/
++
++
++
++#ifndef __IDIVINE_H__
++#define __IDIVINE_H__
++
++#include <divine.h>
++
++/*
++ * private data struct of IDiVine
++ */
++typedef struct {
++ int ref; /* reference counter */
++
++ DiVine *divine;
++} IDiVine_data;
++
++/*
++ * IDiVine constructor/destructor
++ */
++DFBResult IDiVine_Construct( IDiVine *thiz );
++
++void IDiVine_Destruct ( IDiVine *thiz );
++
++#endif