summaryrefslogtreecommitdiff
path: root/dev-libs/Ice
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/Ice
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/Ice')
-rw-r--r--dev-libs/Ice/Ice-3.5.1.ebuild284
-rw-r--r--dev-libs/Ice/Manifest2
-rw-r--r--dev-libs/Ice/files/Ice-3.4.1-db5.patch16
-rw-r--r--dev-libs/Ice/files/Ice-3.4.2-gcc46.patch10
-rw-r--r--dev-libs/Ice/metadata.xml11
5 files changed, 323 insertions, 0 deletions
diff --git a/dev-libs/Ice/Ice-3.5.1.ebuild b/dev-libs/Ice/Ice-3.5.1.ebuild
new file mode 100644
index 00000000000..33d31cf261c
--- /dev/null
+++ b/dev-libs/Ice/Ice-3.5.1.ebuild
@@ -0,0 +1,284 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby19"
+
+inherit toolchain-funcs versionator python-r1 mono-env ruby-ng db-use
+
+DESCRIPTION="ICE middleware C++ library and generator tools"
+HOMEPAGE="http://www.zeroc.com/"
+SRC_URI="http://www.zeroc.com/download/Ice/$(get_version_component_range 1-2)/${P}.tar.gz
+ doc? ( http://www.zeroc.com/download/Ice/$(get_version_component_range 1-2)/${P}.pdf )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 x86 ~x86-linux ~x64-macos"
+IUSE="doc examples +ncurses mono python ruby test debug"
+
+RDEPEND=">=dev-libs/expat-2.0.1
+ >=app-arch/bzip2-1.0.5
+ >=dev-libs/openssl-0.9.8o:0
+ || (
+ sys-libs/db:5.3[cxx]
+ sys-libs/db:5.1[cxx]
+ sys-libs/db:4.8[cxx]
+ )
+ ~dev-cpp/libmcpp-2.7.2
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( $(ruby_implementation_depend ruby19) )
+ mono? ( dev-lang/mono )
+ !dev-python/IcePy
+ !dev-ruby/IceRuby"
+DEPEND="${RDEPEND}
+ ncurses? ( sys-libs/ncurses sys-libs/readline )
+ test? ( ${PYTHON_DEPS} )"
+
+# Maintainer notes:
+# - yes, we have to do the trickery with the move for the python functions
+# since the build and test frameworks deduce various settings from the path
+# and they can't be tricked by a symlink. And we also need
+# SUPPORT_PYTHON_ABIS=1 otherwise we can't get pyc/pyo anymore the sane way.
+# TODO: php bindings
+# TODO: java bindings
+
+#overwrite ruby-ng.eclass default
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ # prevent ruby-ng.eclass from messing with src_unpack
+ :;
+}
+
+src_unpack() {
+ # prevent ruby-ng.eclass from messing with src_unpack
+ default
+}
+
+src_prepare() {
+ sed -i \
+ -e 's|\(install_docdir[[:space:]]*\):=|\1?=|' \
+ -e 's|\(install_configdir[[:space:]]*\):=|\1?=|' \
+ cpp/config/Make.rules || die "sed failed"
+
+ sed -i \
+ -e 's|\(install_pythondir[[:space:]]*\):=|\1?=|' \
+ -e 's|\(install_rubydir[[:space:]]*\):=|\1?=|' \
+ -e 's|\(install_libdir[[:space:]]*\):=|\1?=|' \
+ {py,rb}/config/Make.rules || die "sed failed"
+
+ sed -i \
+ -e 's|-O2 ||g' \
+ -e 's|-Werror ||g' \
+ cpp/config/Make.rules.Linux || die "sed failed"
+
+ sed -i \
+ -e 's|install-common||' \
+ -e 's|demo||' \
+ {cpp,cs,php,py,rb}/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's|-f -root|-f -gacdir $(GAC_DIR) -root|' \
+ cs/config/Make.rules.cs || die "sed failed"
+
+ # skip mono tests, bug #498484
+ sed -i \
+ -e 's|^\(SUBDIRS.*\)test|\1|' \
+ cs/Makefile || die "sed failed"
+
+ if ! use test ; then
+ sed -i \
+ -e 's|^\(SUBDIRS.*\)test|\1|' \
+ {cpp,php,py,rb}/Makefile || die "sed failed"
+ fi
+}
+
+suitable_db_version() {
+ local tested_slots="5.3 5.1 4.8"
+ for ver in ${tested_slots}; do
+ if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then
+ echo ${ver}
+ return 0
+ fi
+ done
+ die "No suitable BerkDB versions found, aborting"
+}
+
+src_configure() {
+ MAKE_RULES="prefix=\"${ED}/usr\"
+ install_docdir=\"${ED}/usr/share/doc/${PF}\"
+ install_configdir=\"${ED}/usr/share/Ice-${PV}/config\"
+ install_mandir=\"${ED}/usr/share/man\"
+ embedded_runpath_prefix=\"${EPREFIX}/usr\"
+ LP64=yes"
+
+ use ncurses && OPTIONS="${MAKE_RULES} USE_READLINE=yes" || MAKE_RULES="${MAKE_RULES} USE_READLINE=no"
+ use debug && OPTIONS"${MAKE_RULES} OPTIMIZE=no" || MAKE_RULES="${MAKE_RULES} OPTIMIZE=yes"
+
+ local BERKDB_VERSION="$(suitable_db_version)"
+ MAKE_RULES="${MAKE_RULES} DB_FLAGS=-I$(db_includedir ${BERKDB_VERSION})"
+ sed -i \
+ -e "s|g++|$(tc-getCXX)|" \
+ -e "s|\(CFLAGS[[:space:]]*=\)|\1 ${CFLAGS}|" \
+ -e "s|\(CXXFLAGS[[:space:]]*=\)|\1 ${CXXFLAGS}|" \
+ -e "s|\(LDFLAGS[[:space:]]*=\)|\1 ${LDFLAGS}|" \
+ -e "s|\(DB_LIBS[[:space:]]*=\) \-ldb_cxx|\1 -ldb_cxx-$(db_findver sys-libs/db:${BERKDB_VERSION})|" \
+ cpp/config/Make.rules{,.Linux} py/config/Make.rules || die "sed failed"
+
+ if use python ; then
+ S=${S}/py python_copy_sources
+
+ # make a place for the symlink
+ rm -r py/python || die
+ fi
+
+ if use ruby ; then
+ SITERUBY="$(ruby19 -r rbconfig -e 'print Config::CONFIG["sitedir"]')"
+ MAKE_RULES_RB="install_rubydir=\"${ED}/${SITERUBY}\"
+ install_libdir=\"${ED}/${SITERUBY}\""
+
+ # make it use ruby19 only
+ sed -i \
+ -e 's|RUBY = ruby|\019|' \
+ rb/config/Make.rules || die "sed failed"
+ fi
+
+ MAKE_RULES_CS="GACINSTALL=yes GAC_ROOT=\"${ED}/usr/$(get_libdir)\" GAC_DIR=${EPREFIX}/usr/$(get_libdir)"
+
+ use test && python_export_best
+}
+
+src_compile() {
+ # Do not remove this export or build will break!
+ tc-export CXX
+
+ emake -C cpp ${MAKE_RULES} || die "emake failed"
+
+ if use doc ; then
+ emake -C cpp/doc || die "building docs failed"
+ fi
+
+ if use python ; then
+ building() {
+ emake -C "${BUILD_DIR}" ${MAKE_RULES} || die "emake py-${EPYTHON} failed"
+ }
+ BUILD_DIR=py python_foreach_impl building
+ fi
+
+ if use ruby ; then
+ emake -C rb ${MAKE_RULES} ${MAKE_RULES_RB} || die "emake rb failed"
+ fi
+
+ if use mono ; then
+ emake -C cs ${MAKE_RULES} ${MAKE_RULES_CS} || die "emake cs failed"
+ fi
+}
+
+src_install() {
+ dodoc CHANGES README
+
+ insinto /usr/share/${P}
+ doins -r slice
+
+ emake -C cpp ${MAKE_RULES} install || die "emake install failed"
+
+ docinto cpp
+ dodoc CHANGES README
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples-cpp
+ doins cpp/config/*.cfg
+ doins -r cpp/demo/*
+ fi
+
+ if use doc ; then
+ dohtml -r cpp/doc/reference/*
+ dodoc "${DISTDIR}/${P}.pdf"
+ fi
+
+ if use python ; then
+ installation() {
+ mkdir -p "${D}/$(python_get_sitedir)" || die
+
+ emake -C "${BUILD_DIR}" ${MAKE_RULES} \
+ install_pythondir="\"${D}/$(python_get_sitedir)\"" \
+ install_libdir="\"${D}/$(python_get_sitedir)\"" \
+ install || die "emake py-${EPYTHON} install failed"
+ }
+ BUILD_DIR=py python_foreach_impl installation
+
+ docinto py
+ dodoc py/CHANGES py/README
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples-py
+ doins -r py/demo/*
+ fi
+ fi
+
+ if use ruby ; then
+ dodir "${SITERUBY}"
+ emake -C rb ${MAKE_RULES} ${MAKE_RULES_RB} install || die "emake rb install failed"
+
+ docinto rb
+ dodoc rb/CHANGES rb/README
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples-rb
+ doins -r rb/demo/*
+ fi
+ fi
+
+ if use mono ; then
+ emake -C cs ${MAKE_RULES} ${MAKE_RULES_CS} install || die "emake cs install failed"
+
+ # TODO: anyone has an idea what those are for?
+ rm "${ED}"/usr/bin/*.xml
+
+ docinto cs
+ dodoc cs/CHANGES cs/README
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples-cs
+ doins -r cs/demo/*
+ fi
+ fi
+}
+
+run_tests() {
+ # Run tests through the script interface since Python test runner
+ # fails to exit with non-zero code for some reason.
+
+ pushd "${1}" >/dev/null || die
+ ./allTests.py --script | sh
+ ret=${?}
+ popd >/dev/null || die
+
+ return ${ret}
+}
+
+src_test() {
+ run_tests cpp || die "emake cpp test failed"
+
+ if use python ; then
+ testing() {
+ # tests require that the directory is named 'py'
+ ln -f -s ../"${BUILD_DIR}"/python py/python || die
+ run_tests py || die "emake py-${EPYTHON} test failed"
+ }
+ BUILD_DIR=py python_foreach_impl testing
+ fi
+
+ if use ruby ; then
+ run_tests rb || die "emake rb test failed"
+ fi
+
+ if use mono ; then
+ # skip mono tests, bug #498484
+ ewarn "Tests for C# are currently disabled."
+# run_tests cs || die "emake cs test failed"
+ fi
+}
diff --git a/dev-libs/Ice/Manifest b/dev-libs/Ice/Manifest
new file mode 100644
index 00000000000..e2bfe639327
--- /dev/null
+++ b/dev-libs/Ice/Manifest
@@ -0,0 +1,2 @@
+DIST Ice-3.5.1.pdf 8279548 SHA256 236f509a3868301ebe688f50417f30155ffa1d330a6c7ab3ef926d40ab145150 SHA512 6fe78ed629de330c56cf260a0a78d650ad9e1507d737a8e58c616f1c61897487dae2f9fb942f1e878706dbc645cb9c672377eeef905f8764b57dd7e6f8d1c7f2 WHIRLPOOL 9fc90d131b028b74f3393df88adb8719a1fef0f829a6226e833c95bcf3bc6b53394a11e3722f0fad2a5597b2468498728310a6e974e1dcb1138fea0ab5b68b28
+DIST Ice-3.5.1.tar.gz 4799296 SHA256 989e51194c6adadbd156da3288e37bad847b93b3b876502e83033b70493af392 SHA512 610fa317bd75e64802d1b5216db4747f86157d3246a2022397bafaefdd9b1b78d131733762003ee779065401c8a83120db65cf9b86fbf1914266309571baf58f WHIRLPOOL 0b760edcd7e3eb1220af81a2236634b86775a18050b0645e4e662bf0fb543aa14177d83e2c8659a62bd5bf6e403384998b893e84b9d547c32bbc2064b5f7de9c
diff --git a/dev-libs/Ice/files/Ice-3.4.1-db5.patch b/dev-libs/Ice/files/Ice-3.4.1-db5.patch
new file mode 100644
index 00000000000..44183ae997a
--- /dev/null
+++ b/dev-libs/Ice/files/Ice-3.4.1-db5.patch
@@ -0,0 +1,16 @@
+--- ./cpp/src/Freeze/MapI.cpp
++++ ./cpp/src/Freeze/MapI.cpp
+@@ -1487,10 +1487,10 @@ Freeze::MapHelperI::size() const
+
+ try
+ {
+-#if DB_VERSION_MAJOR != 4
+-#error Freeze requires DB 4.x
++#if DB_VERSION_MAJOR < 4
++#error Freeze requires DB 4.x or greater
+ #endif
+-#if DB_VERSION_MINOR < 3
++#if DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR < 3
+ _db->stat(&s, 0);
+ #else
+ _db->stat(_connection->dbTxn(), &s, 0); \ No newline at end of file
diff --git a/dev-libs/Ice/files/Ice-3.4.2-gcc46.patch b/dev-libs/Ice/files/Ice-3.4.2-gcc46.patch
new file mode 100644
index 00000000000..a047c6e8541
--- /dev/null
+++ b/dev-libs/Ice/files/Ice-3.4.2-gcc46.patch
@@ -0,0 +1,10 @@
+--- Ice-3.4.1.old/cpp/include/Ice/Buffer.h 2010-06-03 17:48:33.000000000 +0100
++++ Ice-3.4.1.old/cpp/include/Ice/Buffer.h 2011-07-20 13:20:04.000000000 +0100
+@@ -11,6 +11,7 @@
+ #define ICEE_BUFFER_H
+
+ #include <Ice/Config.h>
++#include <cstddef>
+
+ namespace IceInternal
+ {
diff --git a/dev-libs/Ice/metadata.xml b/dev-libs/Ice/metadata.xml
new file mode 100644
index 00000000000..8a5655080a2
--- /dev/null
+++ b/dev-libs/Ice/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <maintainer>
+ <email>cpp@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Ice is a C++ middleware technology with bindings for other languages.
+ </longdescription>
+</pkgmetadata>