summaryrefslogtreecommitdiff
path: root/dev-libs/Ice
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-25 15:09:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-25 15:44:49 +0200
commita8a22ce242f1d1c389de6208b070c10d986cfa56 (patch)
tree5db7747e3e5ad2e2a3911d9f85655a878e1fe4ec /dev-libs/Ice
parent7241a1ec6d657655d1494e269cde0adc1483cdcd (diff)
downloadgentoo-a8a22ce242f1d1c389de6208b070c10d986cfa56.tar.gz
gentoo-a8a22ce242f1d1c389de6208b070c10d986cfa56.tar.xz
dev-libs/Ice: Better sys-libs/db support.
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/Ice')
-rw-r--r--dev-libs/Ice/Ice-3.6.3.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-libs/Ice/Ice-3.6.3.ebuild b/dev-libs/Ice/Ice-3.6.3.ebuild
index 4cd1ef9f73a..b9b237d9463 100644
--- a/dev-libs/Ice/Ice-3.6.3.ebuild
+++ b/dev-libs/Ice/Ice-3.6.3.ebuild
@@ -17,6 +17,10 @@ PHP_EXT_OPTIONAL_USE=php
USE_PHP="php7-0"
+# This variable does not belong to any eclass. It is solely used in this ebuild
+# db:6.2 breaks the build process
+BERKDB_SLOTS=( 6.1 5.3 5.1 4.8 )
+
inherit db-use eutils mono-env php-ext-source-r2 python-r1 ruby-ng toolchain-funcs versionator
DESCRIPTION="ICE middleware C++ library and generator tools"
@@ -33,8 +37,7 @@ RDEPEND=">=dev-libs/expat-2.0.1
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
|| (
- sys-libs/db:5.3[cxx]
- sys-libs/db:5.1[cxx]
+ $(for slot in ${BERKDB_SLOTS[@]} ; do printf '%s\n' "sys-libs/db:${slot}[cxx]" ; done)
)
dev-cpp/libmcpp
python? ( ${PYTHON_DEPS} )
@@ -131,8 +134,8 @@ src_prepare() {
src_configure() {
suitable_db_version() {
- local ver tested_slots=(5.3 5.1)
- for ver in "${tested_slots[@]}"; do
+ local ver
+ for ver in "${BERKDB_SLOTS[@]}"; do
if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then
echo "${ver}"
return 0