summaryrefslogtreecommitdiff
path: root/dev-libs/STLport
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/STLport
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/STLport')
-rw-r--r--dev-libs/STLport/Manifest2
-rw-r--r--dev-libs/STLport/STLport-5.2.1-r1.ebuild96
-rw-r--r--dev-libs/STLport/STLport-5.2.1-r2.ebuild98
-rw-r--r--dev-libs/STLport/metadata.xml11
4 files changed, 207 insertions, 0 deletions
diff --git a/dev-libs/STLport/Manifest b/dev-libs/STLport/Manifest
new file mode 100644
index 00000000000..24e39d97bcb
--- /dev/null
+++ b/dev-libs/STLport/Manifest
@@ -0,0 +1,2 @@
+DIST STLport-5.2.1.tar.bz2 717202 SHA256 755b007b982c4545086c43affc8ed32c0acd577ee206eb1f6967e250c3546fc9 SHA512 c619f1965e42a444714f6a2bcbade3428e09823ad056930b32bf8224b7b3e4b4ae82e25e4ba7b4584f73645a7838a677f314b7bc583d1d9bbcef6fcafc439141 WHIRLPOOL 0d8539b98dd57c8b548bcfaeed3866c348f7f750b676404f40b2beda3c5095a2d94496d670e9f13b7287033fecd8c9f997aad44dfb07b310a8236956bdf2d52e
+DIST STLport-patches-5.2.1-2.tbz2 5245 SHA256 ccf0803a0b5e3c887e52d6132eb48932d566a933d299ebb22858ebd39dddc0c4 SHA512 ddc1b282d1b8008f1f6d5aa3eee0f821063c00fdf851cb569f69955dd3e1ad46b3e57a5c458a1f54aa75737cafe848cf20685b729951a58e80f14234804b92bb WHIRLPOOL cbb1ba74aca4cd454855aad6371ac7140fef42aa70b30c29e70a3b6d24044e5acd221a5a12c90414fb20bfb26ea879e7e3839ff8857b717d793538ca67380e33
diff --git a/dev-libs/STLport/STLport-5.2.1-r1.ebuild b/dev-libs/STLport/STLport-5.2.1-r1.ebuild
new file mode 100644
index 00000000000..a792162a8dd
--- /dev/null
+++ b/dev-libs/STLport/STLport-5.2.1-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils versionator toolchain-funcs multilib
+
+PATCH_V="2"
+
+DESCRIPTION="C++ STL library"
+HOMEPAGE="http://stlport.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stlport/${P}.tar.bz2
+ http://dev.gentoo.org/~xarthisius/distfiles/${PN}-patches-${PV}-${PATCH_V}.tbz2"
+
+LICENSE="boehm-gc HPND"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
+IUSE="boost debug static static-libs threads"
+
+DEPEND="boost? ( >=dev-libs/boost-1.35.0-r5 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # make sure OSNAME is not in the environment (bug #305399)
+ unset OSNAME
+}
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/patches"
+ EPATCH_SUFFIX="diff"
+ epatch
+
+ # We have to add this to host.h to make sure
+ # that dependencies of STLport use the same settings
+ cat <<- EOF >> stlport/stl/config/host.h
+ #define _STLP_NATIVE_INCLUDE_PATH ../g++-v$(gcc-major-version)
+ /* use pthreads for threading */
+ #define _PTHREADS
+ /* enable largefile support */
+ #define _FILE_OFFSET_BITS 64
+ #define _LARGEFILE_SOURCE
+ #define _LARGEFILE64_SOURCE
+ EOF
+}
+
+src_configure() {
+ local myconf
+
+ if use boost ; then
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.35.0-r5")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+
+ myconf+="--with-boost=${BOOST_INC} --with-system-boost "
+ # make sure user apps (e.g. other packges using STLport) use boost as well
+ sed -i \
+ -e 'N;N;N;s:/\**\n\(#define _STLP_USE_BOOST_SUPPORT 1\)*\n\*/:\1:' \
+ stlport/stl/config/user_config.h
+ fi
+
+ use debug || myconf+="--without-debug "
+ use static-libs && myconf+="--enable-static "
+ use threads || myconf+="--without-thread "
+ use static && myconf+="--use-static-gcc "
+
+ # It's not an autoconf script
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --use-compiler-family=gcc \
+ ${myconf} \
+ --with-cc="$(tc-getCC)" \
+ --with-cxx="$(tc-getCXX)" \
+ --with-extra-cflags="${CFLAGS}" \
+ --with-extra-cxxflags="${CXXFLAGS}" \
+ --with-extra-ldflags="${LDFLAGS}" || die "configure failed"
+}
+
+src_install() {
+ # precreate some directories
+ dodir /usr/$(get_libdir)
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README etc/ChangeLog etc/*.txt doc/*.txt doc/{FAQ,README.utf8}
+}
+
+src_test() {
+ if use static ; then
+ ewarn "Tests don't work when building with USE=static. Skipping..."
+ return
+ fi
+ default
+}
diff --git a/dev-libs/STLport/STLport-5.2.1-r2.ebuild b/dev-libs/STLport/STLport-5.2.1-r2.ebuild
new file mode 100644
index 00000000000..3b281c7bdc3
--- /dev/null
+++ b/dev-libs/STLport/STLport-5.2.1-r2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils versionator toolchain-funcs multilib
+
+PATCH_V="2"
+
+DESCRIPTION="C++ STL library"
+HOMEPAGE="http://stlport.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stlport/${P}.tar.bz2
+ http://dev.gentoo.org/~xarthisius/distfiles/${PN}-patches-${PV}-${PATCH_V}.tbz2"
+
+LICENSE="boehm-gc HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost debug static static-libs threads"
+
+DEPEND="boost? ( >=dev-libs/boost-1.35.0-r5 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README etc/ChangeLog doc/FAQ doc/README.utf8 )
+
+pkg_setup() {
+ # make sure OSNAME is not in the environment (bug #305399)
+ unset OSNAME
+}
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/patches"
+ EPATCH_SUFFIX="diff"
+ epatch
+
+ # We have to add this to host.h to make sure
+ # that dependencies of STLport use the same settings
+ cat <<- EOF >> stlport/stl/config/host.h
+ #define _STLP_NATIVE_INCLUDE_PATH ../g++-v$(gcc-major-version)
+ /* use pthreads for threading */
+ #define _PTHREADS
+ /* enable largefile support */
+ #define _FILE_OFFSET_BITS 64
+ #define _LARGEFILE_SOURCE
+ #define _LARGEFILE64_SOURCE
+ EOF
+
+ epatch_user
+}
+
+src_configure() {
+ local myconf
+
+ if use boost ; then
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.35.0-r5")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
+
+ myconf+="--with-boost=${BOOST_INC} --with-system-boost "
+ # make sure user apps (e.g. other packges using STLport) use boost as well
+ sed -i \
+ -e 'N;N;N;s:/\**\n\(#define _STLP_USE_BOOST_SUPPORT 1\)*\n\*/:\1:' \
+ stlport/stl/config/user_config.h || die
+ fi
+
+ # It's not an autoconf script
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --use-compiler-family=gcc \
+ $(use debug || echo "--without-debug") \
+ $(use static && echo "--use-static-gcc") \
+ $(use static-libs && echo "--enable-static") \
+ $(use threads && echo "--without-thread") \
+ ${myconf} \
+ --with-cc="$(tc-getCC)" \
+ --with-cxx="$(tc-getCXX)" \
+ --with-extra-cflags="${CFLAGS}" \
+ --with-extra-cxxflags="${CXXFLAGS}" \
+ --with-extra-ldflags="${LDFLAGS}" || die "configure failed"
+}
+
+src_install() {
+ # precreate some directories
+ dodir /usr/$(get_libdir)
+
+ default
+ dodoc etc/*.txt doc/*.txt
+}
+
+src_test() {
+ if use static ; then
+ ewarn "Tests don't work when building with USE=static. Skipping..."
+ else
+ default
+ fi
+}
diff --git a/dev-libs/STLport/metadata.xml b/dev-libs/STLport/metadata.xml
new file mode 100644
index 00000000000..aa3ea990d7c
--- /dev/null
+++ b/dev-libs/STLport/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <use>
+ <flag name="boost">Enable the usage of <pkg>dev-libs/boost</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">stlport</remote-id>
+ </upstream>
+</pkgmetadata>