summaryrefslogtreecommitdiff
path: root/dev-libs/angelscript
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/angelscript
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/angelscript')
-rw-r--r--dev-libs/angelscript/Manifest1
-rw-r--r--dev-libs/angelscript/angelscript-2.29.2.ebuild57
-rw-r--r--dev-libs/angelscript/files/angelscript-2.29.2-execstack.patch13
-rw-r--r--dev-libs/angelscript/metadata.xml8
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/angelscript/Manifest b/dev-libs/angelscript/Manifest
new file mode 100644
index 00000000000..a22ea1375c0
--- /dev/null
+++ b/dev-libs/angelscript/Manifest
@@ -0,0 +1 @@
+DIST angelscript_2.29.2.zip 1583192 SHA256 c5d549bcd2d04e0dbdfdeea1e1446a34bc9dc449efe0d6fb7fabfb98ee269a8b SHA512 76537a35bfa8f5f90d48a601f4cf1ff6cf8cd648c93b2ea17d3f0fbc7ccaa3d915bbe49d758916d0626a026ece8ecd1646bbb99db41d5a4c9f7c87d915c0d4ff WHIRLPOOL 1f24f56c7601b5f731a4e631f995668f268c26d57dce93944a758c5efd86ed651fd842b16419dad73eb8e7df641ccc5b4a226ccfc99fe1cc9a4c736e5d3076eb
diff --git a/dev-libs/angelscript/angelscript-2.29.2.ebuild b/dev-libs/angelscript/angelscript-2.29.2.ebuild
new file mode 100644
index 00000000000..930c79de931
--- /dev/null
+++ b/dev-libs/angelscript/angelscript-2.29.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="A flexible, cross-platform scripting library"
+HOMEPAGE="http://www.angelcode.com/angelscript/"
+SRC_URI="http://www.angelcode.com/angelscript/sdk/files/angelscript_${PV}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/sdk
+S2=${WORKDIR}/sdk_static
+
+pkg_setup() {
+ tc-export CXX AR RANLIB
+}
+
+src_prepare() {
+ if use static-libs ; then
+ cp -pR "${WORKDIR}"/sdk "${S2}"/ || die
+ fi
+ epatch "${FILESDIR}"/${P}-execstack.patch
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ einfo "Shared build"
+ emake -C ${PN}/projects/gnuc SHARED=1 VERSION=${PV}
+
+ if use static-libs ; then
+ einfo "Static build"
+ emake -C ${PN}/projects/gnuc
+ fi
+}
+
+multilib_src_install() {
+ doheader ${PN}/include/angelscript.h
+ dolib.so ${PN}/lib/libangelscript-${PV}.so
+ dosym libangelscript-${PV}.so /usr/$(get_libdir)/libangelscript.so
+
+ if use static-libs ; then
+ dolib.a ${PN}/lib/libangelscript.a
+ fi
+}
+
+multilib_src_install_all() {
+ use doc && dohtml -r "${WORKDIR}"/sdk/docs/*
+}
diff --git a/dev-libs/angelscript/files/angelscript-2.29.2-execstack.patch b/dev-libs/angelscript/files/angelscript-2.29.2-execstack.patch
new file mode 100644
index 00000000000..2cdb6696dd7
--- /dev/null
+++ b/dev-libs/angelscript/files/angelscript-2.29.2-execstack.patch
@@ -0,0 +1,13 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Mar 23 13:45:39 UTC 2014
+Subject: fix RWX sections
+
+--- a/sdk/angelscript/source/as_callfunc_arm_gcc.S
++++ b/sdk/angelscript/source/as_callfunc_arm_gcc.S
+@@ -696,3 +696,6 @@
+
+ #endif /* arm */
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/dev-libs/angelscript/metadata.xml b/dev-libs/angelscript/metadata.xml
new file mode 100644
index 00000000000..e96e35b1a37
--- /dev/null
+++ b/dev-libs/angelscript/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+