summaryrefslogtreecommitdiff
path: root/dev-libs/atk
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-16 22:14:08 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-16 22:55:32 +0100
commitc47cdb6dfdde77b72d2452a8125697a7b7de53ac (patch)
tree24e8e15d1cada4bf3751e97b198827dfb71cc364 /dev-libs/atk
parentcaa2de92630c61958a7cc9352976ad9481b8da1d (diff)
downloadgentoo-c47cdb6dfdde77b72d2452a8125697a7b7de53ac.tar.gz
gentoo-c47cdb6dfdde77b72d2452a8125697a7b7de53ac.tar.xz
dev-libs/atk: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-libs/atk')
-rw-r--r--dev-libs/atk/Manifest1
-rw-r--r--dev-libs/atk/atk-2.18.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/atk/Manifest b/dev-libs/atk/Manifest
index c3086eadd33..8b8be1269d6 100644
--- a/dev-libs/atk/Manifest
+++ b/dev-libs/atk/Manifest
@@ -1,3 +1,4 @@
DIST atk-2.12.0.tar.xz 688716 SHA256 48a8431974639c5a59c24fcd3ece1a19709872d5dfe78907524d9f5e9993f18f SHA512 422f0f4ef5f29707e77065557516a218ff23e78f61fa8e8c78b4a528c06cfeaff934e67eaaec00dc82cd13b2869e30618883a53010bd828dbebe51baea848272 WHIRLPOOL 2fda41b10a3890e7f097756da5aa3d502a0017ab82abbd67f72835b55240c9d23d53521e5632e0e287cc8c1e17598635c3385ca5362c4e1c42bcbc52c97db984
DIST atk-2.14.0.tar.xz 696064 SHA256 2875cc0b32bfb173c066c22a337f79793e0c99d2cc5e81c4dac0d5a523b8fbad SHA512 3aa5155086d607a2779be1e96ae77798192f93161c855b194f15c49d968bb88535e16ee6114911857f31aeedfc0930f3f828d225f71a7b2f48e85919ab7d057b WHIRLPOOL 0b9f956e35f0baa65a63d7029d4f7317f13c22975696f80ff1f4515af5850368c43e69561c50d8b7b944f98e0482ac7c63d7a496f11566024d497b93e776fe12
DIST atk-2.16.0.tar.xz 699816 SHA256 095f986060a6a0b22eb15eef84ae9f14a1cf8082488faa6886d94c37438ae562 SHA512 dc8827779d14fe7212733464f8775f67d60ab3027fcd935245d57c5899e8fc8acc6ceb88ee58f7bfbf259b89447868b3c93726ac56f46bf30a722b47b7bbd7da WHIRLPOOL 94ab7594c9e2508e6e2c9b62bfd80ebedf802a38e5bcd9c28b1224deb56d38d551687d0280e5af57b9713dd1fdbac84c58a03638856aab72bd060009188df641
+DIST atk-2.18.0.tar.xz 687932 SHA256 ce6c48d77bf951083029d5a396dd552d836fff3c1715d3a7022e917e46d0c92b SHA512 36f88a6f052ec28c4394756b7de3c1f4c021439eba1e4bfde6ecccd87bab1847111f4cc68ed743c762fcc165c4984c03fd09ea4346e49b2d8dad8b5af36189ea WHIRLPOOL 9f6a40535dda422942f635008e022fb38ea6d1683d51a2d4fa7a2cf3ec5a15ef5f45e83f4344994f706d252b5524fdf6512d2a80c45b22be24d62cae1f11a3be
diff --git a/dev-libs/atk/atk-2.18.0.ebuild b/dev-libs/atk/atk-2.18.0.ebuild
new file mode 100644
index 00000000000..23f3d2bc227
--- /dev/null
+++ b/dev-libs/atk/atk-2.18.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+introspection nls test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/gtk-doc-am
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Building out of sources fails, https://bugzilla.gnome.org/show_bug.cgi?id=752507
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+# ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection)
+
+ # work-around gtk-doc out-of-source brokedness
+# if multilib_is_native_abi; then
+# ln -s "${S}"/docs/html docs/html || die
+# fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}