summaryrefslogtreecommitdiff
path: root/dev-libs/beignet
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-03-17 10:28:16 +0100
committerMarek Szuba <marecki@gentoo.org>2018-03-17 10:29:05 +0100
commit7ad4da2b626af9208eb0398691f5e77fdb332455 (patch)
tree0465e120ac93e95f6e42bbd1a3694f38e191d329 /dev-libs/beignet
parent44cabaa5e408ec4f57ef0bd741d317a2e7c567cd (diff)
downloadgentoo-7ad4da2b626af9208eb0398691f5e77fdb332455.tar.gz
gentoo-7ad4da2b626af9208eb0398691f5e77fdb332455.tar.xz
dev-libs/beignet: play nicely with slotted LLVM
The version cap added by 2e80ee40ee74cc3005945355fd1a67ef4347ebbd was not sufficient to solve Bug #650136 because although it did prevent Beignet from pulling in slot 6 of sys-devel/llvm and sys-devel/clang on fresh installations, it did nothing to avoid using these if already installed. Thanks to the use of llvm.eclass this now no longer happens; I have just tested this on a system with llvm6 installed and beignet still ended up using llvm5. Closes: https://bugs.gentoo.org/650136 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs/beignet')
-rw-r--r--dev-libs/beignet/beignet-1.3.2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-libs/beignet/beignet-1.3.2.ebuild b/dev-libs/beignet/beignet-1.3.2.ebuild
index c3f83128332..6624d286bcc 100644
--- a/dev-libs/beignet/beignet-1.3.2.ebuild
+++ b/dev-libs/beignet/beignet-1.3.2.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
CMAKE_BUILD_TYPE="Release"
-inherit python-any-r1 cmake-multilib flag-o-matic toolchain-funcs
+inherit python-any-r1 cmake-multilib flag-o-matic llvm toolchain-funcs
DESCRIPTION="OpenCL implementation for Intel GPUs"
HOMEPAGE="https://01.org/beignet"
@@ -27,7 +27,6 @@ fi
COMMON="media-libs/mesa[${MULTILIB_USEDEP}]
<sys-devel/clang-6.0.0:=[${MULTILIB_USEDEP}]
- <sys-devel/llvm-6.0.0:=[${MULTILIB_USEDEP}]
>=x11-libs/libdrm-2.4.70[video_cards_intel,${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
x11-libs/libXfixes[${MULTILIB_USEDEP}]"
@@ -38,6 +37,8 @@ DEPEND="${COMMON}
ocl-icd? ( dev-libs/ocl-icd )
virtual/pkgconfig"
+LLVM_MAX_SLOT=5
+
PATCHES=(
"${FILESDIR}"/no-debian-multiarch.patch
"${FILESDIR}"/${PN}-1.3.2_cmake-llvm-config-multilib.patch
@@ -62,6 +63,7 @@ pkg_pretend() {
}
pkg_setup() {
+ llvm_pkg_setup
python_setup
}