summaryrefslogtreecommitdiff
path: root/dev-libs/c-blosc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/c-blosc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/c-blosc')
-rw-r--r--dev-libs/c-blosc/Manifest3
-rw-r--r--dev-libs/c-blosc/c-blosc-1.3.2.ebuild42
-rw-r--r--dev-libs/c-blosc/c-blosc-1.3.5.ebuild42
-rw-r--r--dev-libs/c-blosc/c-blosc-1.5.3.ebuild43
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch22
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch27
-rw-r--r--dev-libs/c-blosc/metadata.xml19
7 files changed, 198 insertions, 0 deletions
diff --git a/dev-libs/c-blosc/Manifest b/dev-libs/c-blosc/Manifest
new file mode 100644
index 00000000000..8d8c47535d8
--- /dev/null
+++ b/dev-libs/c-blosc/Manifest
@@ -0,0 +1,3 @@
+DIST c-blosc-1.3.2.tar.gz 229790 SHA256 7c21c4484c1ad7d6beddd73f35379e0d980530466cd6d87402e035c931983697 SHA512 0488042628b8b3d02e8e7b58d3d942751a43567e99e1e89f452765ad1aeba395248322df6a37daf828571b3c262ebaa54d3ca49cfed78ab499994454faf6bbdb WHIRLPOOL 195232123fbbd4f76f3a209069e7895c3ba900e98c49ca8334e1975634770463d993ae36f99fefb680d7c78a28ca979c27cd4af4412e83c804315f6cf52420fe
+DIST c-blosc-1.3.5.tar.gz 231653 SHA256 60efbbd2ef613480d135dbb245260e7cd904cfd785cc2504458615d7b397675a SHA512 4c11309a3f5dd0e2ecb35f62480cf86a9ad8d8d84b0d744c0597a51d8f51010a2ed0ad868cc3aef1f674efc1c35ee3312ad727cb308b348026f08db0ac9ab04a WHIRLPOOL 58742b85bf1d9637492871cab0f0c0b87c96162b2dfbf196e91f62569f6a06077b901a202fab43f39472ccf728550340a85bd60f3fee1d6e0e76d655659db3f0
+DIST c-blosc-1.5.3.tar.gz 240821 SHA256 d6d7c72d8e49311618f5f1609df1a9b2ca070655b563b9f7b80d5dc92fceaf4f SHA512 92f0a47ff6af2b776795315fce52e49c12e947e9007f97d05182a8369831e0ba80ff7b2b116fdedc4ef2b984106b014c90f82e233d5aed85cd91e3256f4a7313 WHIRLPOOL 9178c1a4e8e476b2a0556106ecbf58eb10bd076e3c731048d988f1e3dcaefa593cea176c6f5ec391c54a651421cce40858f1eae4ba9fc91d60a0fc158fe9fbc7
diff --git a/dev-libs/c-blosc/c-blosc-1.3.2.ebuild b/dev-libs/c-blosc/c-blosc-1.3.2.ebuild
new file mode 100644
index 00000000000..7eb4b8b0964
--- /dev/null
+++ b/dev-libs/c-blosc/c-blosc-1.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Blocking, shuffling and lossless compression library"
+HOMEPAGE="http://www.blosc.org/"
+SRC_URI="https://github.com/Blosc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+IUSE="hdf5 +lz4 +snappy static-libs test zlib"
+
+RDEPEND="
+ hdf5? ( sci-libs/hdf5 )
+ lz4? ( >=app-arch/lz4-0_p120 )
+ snappy? ( app-arch/snappy )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-shared-libs.patch )
+DOCS="RE* AN*"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_BENCHMARKS=OFF
+ -DPREFER_EXTERNAL_COMPLIBS=ON
+ $(cmake-utils_use hdf5 BUILD_HDF5_FILTER)
+ $(cmake-utils_use !lz4 DEACTIVATE_LZ4)
+ $(cmake-utils_use !snappy DEACTIVATE_SNAPPY)
+ $(cmake-utils_use static-libs BUILD_STATIC)
+ $(cmake-utils_use test BUILD_TESTS)
+ $(cmake-utils_use !zlib DEACTIVATE_ZLIB)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/c-blosc/c-blosc-1.3.5.ebuild b/dev-libs/c-blosc/c-blosc-1.3.5.ebuild
new file mode 100644
index 00000000000..aebea60f193
--- /dev/null
+++ b/dev-libs/c-blosc/c-blosc-1.3.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Blocking, shuffling and lossless compression library"
+HOMEPAGE="http://www.blosc.org/"
+SRC_URI="https://github.com/Blosc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+IUSE="hdf5 +lz4 +snappy static-libs test zlib"
+
+RDEPEND="
+ hdf5? ( sci-libs/hdf5:0= )
+ lz4? ( >=app-arch/lz4-0_p120:0= )
+ snappy? ( app-arch/snappy:0= )
+ zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3.2-shared-libs.patch )
+DOCS="RE* AN*"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_BENCHMARKS=OFF
+ -DPREFER_EXTERNAL_COMPLIBS=ON
+ $(cmake-utils_use hdf5 BUILD_HDF5_FILTER)
+ $(cmake-utils_use !lz4 DEACTIVATE_LZ4)
+ $(cmake-utils_use !snappy DEACTIVATE_SNAPPY)
+ $(cmake-utils_use static-libs BUILD_STATIC)
+ $(cmake-utils_use test BUILD_TESTS)
+ $(cmake-utils_use !zlib DEACTIVATE_ZLIB)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/c-blosc/c-blosc-1.5.3.ebuild b/dev-libs/c-blosc/c-blosc-1.5.3.ebuild
new file mode 100644
index 00000000000..af0e4ece647
--- /dev/null
+++ b/dev-libs/c-blosc/c-blosc-1.5.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Blocking, shuffling and lossless compression library"
+HOMEPAGE="http://www.blosc.org/"
+SRC_URI="https://github.com/Blosc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="hdf5 +lz4 +snappy static-libs test zlib"
+
+RDEPEND="
+ hdf5? ( sci-libs/hdf5:0= )
+ lz4? ( >=app-arch/lz4-0_p120:0= )
+ snappy? ( app-arch/snappy:0= )
+ zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-shared-libs.patch )
+
+DOCS=( README.rst RELEASE_NOTES.rst THOUGHTS_FOR_2.0.txt ANNOUNCE.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_BENCHMARKS=OFF
+ -DPREFER_EXTERNAL_COMPLIBS=ON
+ $(cmake-utils_use hdf5 BUILD_HDF5_FILTER)
+ $(cmake-utils_use !lz4 DEACTIVATE_LZ4)
+ $(cmake-utils_use !snappy DEACTIVATE_SNAPPY)
+ $(cmake-utils_use static-libs BUILD_STATIC)
+ $(cmake-utils_use test BUILD_TESTS)
+ $(cmake-utils_use !zlib DEACTIVATE_ZLIB)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch b/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch
new file mode 100644
index 00000000000..484db1f6dd3
--- /dev/null
+++ b/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch
@@ -0,0 +1,22 @@
+--- hdf5/CMakeLists.txt.orig 2014-02-05 16:55:55.001344161 -0800
++++ hdf5/CMakeLists.txt 2014-02-05 16:57:03.767739650 -0800
+@@ -23,16 +23,16 @@
+
+ # install
+ install(FILES blosc_filter.h DESTINATION include COMPONENT HDF5_FILTER_DEV)
+-install(TARGETS blosc_filter_static DESTINATION lib COMPONENT HDF5_FILTER)
++install(TARGETS blosc_filter_shared DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER)
+ if(BUILD_STATIC)
+ install(
+- TARGETS blosc_filter_shared DESTINATION lib COMPONENT HDF5_FILTER_DEV)
++ TARGETS blosc_filter_static DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER_DEV)
+ endif(BUILD_STATIC)
+
+
+ # test
+ if(BUILD_TESTS)
+ add_executable(example example.c)
+- target_link_libraries(example blosc_filter_static ${HDF5_LIBRARIES})
++ target_link_libraries(example blosc_filter_shared ${HDF5_LIBRARIES})
+ add_test(test_hdf5_filter example)
+ endif(BUILD_TESTS)
diff --git a/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch b/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch
new file mode 100644
index 00000000000..c46f6698744
--- /dev/null
+++ b/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch
@@ -0,0 +1,27 @@
+ hdf5/CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/hdf5/CMakeLists.txt b/hdf5/CMakeLists.txt
+index d91194f..032a292 100644
+--- a/hdf5/CMakeLists.txt
++++ b/hdf5/CMakeLists.txt
+@@ -44,16 +44,16 @@ endif(MSVC)
+
+ # install
+ install(FILES blosc_filter.h DESTINATION include COMPONENT HDF5_FILTER_DEV)
+-install(TARGETS blosc_filter_shared DESTINATION lib COMPONENT HDF5_FILTER)
++install(TARGETS blosc_filter_shared DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER)
+ if(BUILD_STATIC)
+ install(
+- TARGETS blosc_filter_static DESTINATION lib COMPONENT HDF5_FILTER_DEV)
++ TARGETS blosc_filter_static DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER_DEV)
+ endif(BUILD_STATIC)
+
+
+ # test
+ if(BUILD_TESTS)
+ add_executable(example example.c)
+- target_link_libraries(example blosc_filter_static ${HDF5_LIBRARIES})
++ target_link_libraries(example blosc_filter_shared ${HDF5_LIBRARIES})
+ add_test(test_hdf5_filter example)
+ endif(BUILD_TESTS)
diff --git a/dev-libs/c-blosc/metadata.xml b/dev-libs/c-blosc/metadata.xml
new file mode 100644
index 00000000000..873eced1520
--- /dev/null
+++ b/dev-libs/c-blosc/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Blosc is a compression library designed to transmit data to the
+ processor cache faster than the traditional non-compressed memory fetch.
+ Compression ratios are not very high, but the decompression is very
+ fast. Blosc is meant not only to reduce the size of large datasets on-disk
+ or in-memory, but also to accelerate memory-bound computations.
+</longdescription>
+ <use>
+ <flag name="lz4">Enable lz4 compression</flag>
+ <flag name="snappy">Enable snappy compression</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Blosc/c-blosc</remote-id>
+ </upstream>
+</pkgmetadata>