summaryrefslogtreecommitdiff
path: root/dev-libs/cdk
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/cdk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/cdk')
-rw-r--r--dev-libs/cdk/Manifest2
-rw-r--r--dev-libs/cdk/cdk-5.0.20131107.ebuild49
-rw-r--r--dev-libs/cdk/cdk-5.0.20141106.ebuild49
-rw-r--r--dev-libs/cdk/files/cdk-5.0.20120323-parallel-make.patch12
-rw-r--r--dev-libs/cdk/metadata.xml7
5 files changed, 119 insertions, 0 deletions
diff --git a/dev-libs/cdk/Manifest b/dev-libs/cdk/Manifest
new file mode 100644
index 00000000000..f50709a12f7
--- /dev/null
+++ b/dev-libs/cdk/Manifest
@@ -0,0 +1,2 @@
+DIST cdk-5.0-20131107.tgz 495455 SHA256 2b3670b95d330cce34ddd929f985c423cf86b05ba8a33bf5f217c4702131f565 SHA512 93e0c78bfd12fb9c554b9b6996b9c93542201afb67ddd63ecea7330171ca079da73d81b3f3b2f27a28ecd3527ed6c7333203a9438ecd196a66d3bad78233f439 WHIRLPOOL bedf5a441175436fb0eb54b216a61acd296d97dbbb2be1eb817b024778f58383f0ea00f6159c67c05f116f21ad6e0030a2d979aa8db2798a4f103f36f3e3198b
+DIST cdk-5.0-20141106.tgz 509310 SHA256 d7ce8d9698b4998fa49a63b6e19309d3eb61cc3a019bfc95101d845ef03c4803 SHA512 8a92363c8036acb61fe8dcfcf3690653f2573407123b8c684c0bf165d5b99b6a4c7e8bcded8773304ebc13108e90ae3488f0e74ed026f3bc69f6a5b007e651e4 WHIRLPOOL d497624acb49bec7a1f18afe13c1279f5e8c06b71d4f904b88b9f639e01fae0b4d959ae90df169c477292e0f56f787944e5cffddb4416d30d85784155bde2dee
diff --git a/dev-libs/cdk/cdk-5.0.20131107.ebuild b/dev-libs/cdk/cdk-5.0.20131107.ebuild
new file mode 100644
index 00000000000..fcd0b143c55
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20131107.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator
+
+MY_P="${PN}-$(replace_version_separator 2 -)"
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/5" # subslot = soname version
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~s390 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples static-libs unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2[unicode?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.20120323-parallel-make.patch
+}
+
+src_configure() {
+ econf \
+ --with-libtool \
+ --with-shared \
+ --with-ncurses$(usex unicode "w" "")
+}
+
+src_install() {
+ # parallel make installs duplicate libs
+ emake -j1 \
+ DESTDIR="${ED}" \
+ DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" install
+
+ if use examples ; then
+ for x in include c++ demos examples cli cli/utils cli/samples; do
+ docinto $x
+ find $x -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc
+ done
+ fi
+
+ use static-libs || find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete
+}
diff --git a/dev-libs/cdk/cdk-5.0.20141106.ebuild b/dev-libs/cdk/cdk-5.0.20141106.ebuild
new file mode 100644
index 00000000000..209a4ee1679
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20141106.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator
+
+MY_P="${PN}-$(replace_version_separator 2 -)"
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/6" # subslot = soname version
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples static-libs unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2[unicode?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.20120323-parallel-make.patch
+}
+
+src_configure() {
+ econf \
+ --with-libtool \
+ --with-shared \
+ --with-ncurses$(usex unicode "w" "")
+}
+
+src_install() {
+ # parallel make installs duplicate libs
+ emake -j1 \
+ DESTDIR="${ED}" \
+ DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" install
+
+ if use examples ; then
+ for x in include c++ demos examples cli cli/utils cli/samples; do
+ docinto $x
+ find $x -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc
+ done
+ fi
+
+ use static-libs || find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete
+}
diff --git a/dev-libs/cdk/files/cdk-5.0.20120323-parallel-make.patch b/dev-libs/cdk/files/cdk-5.0.20120323-parallel-make.patch
new file mode 100644
index 00000000000..aa5a1dce04e
--- /dev/null
+++ b/dev-libs/cdk/files/cdk-5.0.20120323-parallel-make.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -269,7 +269,7 @@
+
+ all sources :: $(AUTO_SRC)
+
+-$(OBJECTS) : include/cdk_config.h
++$(OBJECTS) : $(MY_HDR)
+
+ #
+ # Standard library directive.
+
diff --git a/dev-libs/cdk/metadata.xml b/dev-libs/cdk/metadata.xml
new file mode 100644
index 00000000000..1470e032181
--- /dev/null
+++ b/dev-libs/cdk/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>