summaryrefslogtreecommitdiff
path: root/dev-libs/cyrus-imap-dev
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/cyrus-imap-dev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/cyrus-imap-dev')
-rw-r--r--dev-libs/cyrus-imap-dev/Manifest2
-rw-r--r--dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.4.16.ebuild70
-rw-r--r--dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.4.17.ebuild83
-rw-r--r--dev-libs/cyrus-imap-dev/metadata.xml5
4 files changed, 160 insertions, 0 deletions
diff --git a/dev-libs/cyrus-imap-dev/Manifest b/dev-libs/cyrus-imap-dev/Manifest
new file mode 100644
index 00000000000..d0117045f8d
--- /dev/null
+++ b/dev-libs/cyrus-imap-dev/Manifest
@@ -0,0 +1,2 @@
+DIST cyrus-imapd-2.4.16.tar.gz 2484201 SHA256 beac9d6059680bbf65948db60a30c6e8f59786df4a7821c70dc27b2a225f32c4 SHA512 31931e94ebe869516f10886cee5ab152fb6d6376bf009250718077732c6172a6430f3502370e15e94f6165500e5b4108623bceea7c0dcfb3eb746e9ff0fcffab WHIRLPOOL 1e9916d03448e7f036aa6320af69a7ae57ae37205f98d4cfee8c335d9dcdc1c09ba243f4506036da4ca17f859f5c7eef0cb56443dfe51ad3075f0e4d62874fcb
+DIST cyrus-imapd-2.4.17.tar.gz 2486355 SHA256 b3e30052c764ee7163947ffde27bdd58bd4dd2e5697ad144491941e46300a583 SHA512 86ffe1664ca3c3df164ed8fca21cc08ddae12380e1485deccec7da4ec263d8b953a806e05f0b10f6fb7717a0d40fc05669792b77cc66d7c5067061c8506e59ee WHIRLPOOL 22566578217a5901793b886ff020aa1deecbb81bf85f54a524b58de129029e51b0aa358db902a2139584d05f668404cb98ca2ff3fa33803ce986e07b95c69c45
diff --git a/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.4.16.ebuild b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.4.16.ebuild
new file mode 100644
index 00000000000..0c198c7c6ed
--- /dev/null
+++ b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.4.16.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils db-use multilib
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="Developer support for the Cyrus IMAP Server"
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="afs berkdb kerberos snmp ssl tcpd"
+
+RDEPEND=">=dev-libs/cyrus-sasl-2.1.13
+ afs? ( net-fs/openafs )
+ berkdb? ( >=sys-libs/db-3.2 )
+ kerberos? ( virtual/krb5 )
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ !net-mail/cyrus-imapd"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_configure() {
+ local myconf
+ if use afs ; then
+ myconf=" --with-afs-libdir=/usr/$(get_libdir)"
+ myconf+=" --with-afs-incdir=/usr/include/afs"
+ fi
+ if use berkdb ; then
+ myconf+="--with-bdb-incdir=$(db_includedir)"
+ fi
+
+ econf \
+ --enable-murder \
+ --enable-netscapehack \
+ --enable-idled \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --without-perl \
+ --without-krb \
+ --without-krbdes \
+ $(use_enable afs) \
+ $(use_enable afs krb5afspts) \
+ $(use_with berkdb bdb) \
+ $(use_with ssl openssl) \
+ $(use_with snmp) \
+ $(use_with tcpd libwrap) \
+ $(use_enable kerberos gssapi) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${S}/lib" all
+}
+
+src_install() {
+ dodir /usr/include/cyrus
+
+ emake -C "${S}/lib" DESTDIR="${D}" install
+ dodoc README*
+}
diff --git a/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.4.17.ebuild b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.4.17.ebuild
new file mode 100644
index 00000000000..038c81b99c6
--- /dev/null
+++ b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.4.17.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools db-use eutils multilib toolchain-funcs
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="Developer support for the Cyrus IMAP Server"
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 sparc x86"
+IUSE="afs berkdb kerberos snmp ssl tcpd"
+
+RDEPEND=">=dev-libs/cyrus-sasl-2.1.13
+ afs? ( net-fs/openafs )
+ berkdb? ( >=sys-libs/db-3.2 )
+ kerberos? ( virtual/krb5 )
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ !net-mail/cyrus-imapd"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_prepare() {
+ sed -i -e "s/ar cr/$(tc-getAR) cr/" \
+ perl/sieve/lib/Makefile.in \
+ imap/Makefile.in \
+ lib/Makefile.in \
+ installsieve/Makefile.in \
+ com_err/et/Makefile.in \
+ sieve/Makefile.in \
+ syslog/Makefile.in
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use afs ; then
+ myconf=" --with-afs-libdir=/usr/$(get_libdir)"
+ myconf+=" --with-afs-incdir=/usr/include/afs"
+ fi
+ if use berkdb ; then
+ myconf+="--with-bdb-incdir=$(db_includedir)"
+ fi
+
+ econf \
+ --enable-murder \
+ --enable-netscapehack \
+ --enable-idled \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --without-perl \
+ --without-krb \
+ --without-krbdes \
+ $(use_enable afs) \
+ $(use_enable afs krb5afspts) \
+ $(use_with berkdb bdb) \
+ $(use_with ssl openssl) \
+ $(use_with snmp) \
+ $(use_with tcpd libwrap) \
+ $(use_enable kerberos gssapi) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${S}/lib" all
+}
+
+src_install() {
+ dodir /usr/include/cyrus
+
+ emake -C "${S}/lib" DESTDIR="${D}" install
+ dodoc README*
+}
diff --git a/dev-libs/cyrus-imap-dev/metadata.xml b/dev-libs/cyrus-imap-dev/metadata.xml
new file mode 100644
index 00000000000..51f94e3fbe0
--- /dev/null
+++ b/dev-libs/cyrus-imap-dev/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>