summaryrefslogtreecommitdiff
path: root/dev-libs/dbus-glib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/dbus-glib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/dbus-glib')
-rw-r--r--dev-libs/dbus-glib/Manifest2
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.102.ebuild91
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.104.ebuild95
-rw-r--r--dev-libs/dbus-glib/metadata.xml11
4 files changed, 199 insertions, 0 deletions
diff --git a/dev-libs/dbus-glib/Manifest b/dev-libs/dbus-glib/Manifest
new file mode 100644
index 00000000000..4ed0e3716eb
--- /dev/null
+++ b/dev-libs/dbus-glib/Manifest
@@ -0,0 +1,2 @@
+DIST dbus-glib-0.102.tar.gz 783792 SHA256 6964ed585bb8149a14ab744b5ded5e77cf71ec5446e6dcc5fcf5eebcc52df29c SHA512 9bf4b33dd264eaed9ade0e35f0ad47986c31bd5e3de4d3e2fcee66a9be87000b6121bc810b9a5a24eca53190d98323b871dc78f341df8e05bd0247b096cf778f WHIRLPOOL b83f12877118dca1797c935f57a6ae664fbfc70c4d2fb2d95d2cf11abb7c326a098f336225ffb9030fac00a33d988a30038e2734721fc1ddbb5297f864e01bcf
+DIST dbus-glib-0.104.tar.gz 793417 SHA256 bfc1f1a82bfc3ec3ecafe04d0e87bab7e999f50dce4f4a34d0b89caf6bd821f6 SHA512 eff599f169976055545b51459d77845002d8bc7e8dcd056cec2bf83836d07c66b03baed2023bc87a6d7c021d35c744987830f8ed6f9c3391a49ee199db85134b WHIRLPOOL 6e757dee52ea11a7e43cc22a090243cd77ae0b38439fead755c78a6e8b7d6e7e2b1bb1218e23396513e33ef555e35b556f3b333a190077fd9472288e3e96ce91
diff --git a/dev-libs/dbus-glib/dbus-glib-0.102.ebuild b/dev-libs/dbus-glib/dbus-glib-0.102.ebuild
new file mode 100644
index 00000000000..8678e12e9a3
--- /dev/null
+++ b/dev-libs/dbus-glib/dbus-glib-0.102.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit bash-completion-r1 eutils multilib-minimal
+
+DESCRIPTION="D-Bus bindings for glib"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
+IUSE="debug doc static-libs test"
+
+CDEPEND=">=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}]"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+RDEPEND="${CDEPEND}
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-baselibs-20131008-r8
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+set_TBD() {
+ # out of sources build dir for make check
+ export TBD="${BUILD_DIR}-tests"
+}
+
+src_prepare() {
+ epatch_user
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --localstatedir="${EPREFIX}"/var
+ --enable-bash-completion
+ $(use_enable debug asserts)
+ $(use_enable static-libs static)
+ $(multilib_native_use_enable doc gtk-doc)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ use doc || ln -s "${S}"/doc/reference/html doc/reference/html #460042
+
+ if use test; then
+ set_TBD
+ mkdir "${TBD}"
+ cd "${TBD}"
+ einfo "Running configure in ${TBD}"
+ ECONF_SOURCE="${S}" econf \
+ "${myconf[@]}" \
+ $(use_enable test checks) \
+ $(use_enable test tests) \
+ $(use_enable test asserts) \
+ $(use_with test test-socket-dir "${T}"/dbus-test-socket)
+ fi
+}
+
+multilib_src_compile() {
+ emake
+
+ if use test; then
+ set_TBD
+ cd "${TBD}"
+ einfo "Running make in ${TBD}"
+ emake
+ fi
+}
+
+multilib_src_test() {
+ set_TBD
+ cd "${TBD}"
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newbashcomp "${ED}"/etc/bash_completion.d/dbus-bash-completion.sh dbus-send
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ prune_libtool_files
+}
diff --git a/dev-libs/dbus-glib/dbus-glib-0.104.ebuild b/dev-libs/dbus-glib/dbus-glib-0.104.ebuild
new file mode 100644
index 00000000000..4a51eee415e
--- /dev/null
+++ b/dev-libs/dbus-glib/dbus-glib-0.104.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit bash-completion-r1 eutils multilib-minimal
+
+DESCRIPTION="D-Bus bindings for glib"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
+IUSE="debug static-libs test"
+
+CDEPEND="
+ >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.8[${MULTILIB_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-baselibs-20131008-r8
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+set_TBD() {
+ # out of sources build dir for make check
+ export TBD="${BUILD_DIR}-tests"
+}
+
+src_prepare() {
+ epatch_user
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --localstatedir="${EPREFIX}"/var
+ --enable-bash-completion
+ --disable-gtk-doc
+ $(use_enable debug asserts)
+ $(use_enable static-libs static)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ ln -s "${S}"/doc/reference/html doc/reference/html #460042
+
+ if use test; then
+ set_TBD
+ mkdir "${TBD}"
+ cd "${TBD}"
+ einfo "Running configure in ${TBD}"
+ ECONF_SOURCE="${S}" econf \
+ "${myconf[@]}" \
+ $(use_enable test checks) \
+ $(use_enable test tests) \
+ $(use_enable test asserts) \
+ $(use_with test test-socket-dir "${T}"/dbus-test-socket)
+ fi
+}
+
+multilib_src_compile() {
+ emake
+
+ if use test; then
+ set_TBD
+ cd "${TBD}"
+ einfo "Running make in ${TBD}"
+ emake
+ fi
+}
+
+multilib_src_test() {
+ set_TBD
+ cd "${TBD}"
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newbashcomp "${ED}"/etc/bash_completion.d/dbus-bash-completion.sh dbus-send
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ prune_libtool_files
+}
diff --git a/dev-libs/dbus-glib/metadata.xml b/dev-libs/dbus-glib/metadata.xml
new file mode 100644
index 00000000000..1e26d76c79f
--- /dev/null
+++ b/dev-libs/dbus-glib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+ <maintainer>
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:freedesktop:dbus-glib</remote-id>
+ </upstream>
+</pkgmetadata>