summaryrefslogtreecommitdiff
path: root/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-10-06 00:45:51 +0100
committerRobin H. Johnson <robbat2@gentoo.org>2017-01-22 12:58:48 -0800
commit2749083e16c416005352bc0634ca2690a0b44f34 (patch)
treece81c0d3be89db2428668377b65ca36017f02b3f /dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild
parentfa1de8635f750da81d4a4cacc08fffb1e44afb53 (diff)
downloadgentoo-2749083e16c416005352bc0634ca2690a0b44f34.tar.gz
gentoo-2749083e16c416005352bc0634ca2690a0b44f34.tar.xz
dev-libs/device-atlas-api-c: API to detect devices based on the User-Agent HTTP header
Package-Manager: portage-2.3.0 (cherry picked from commit b9475e94910837345e1ff1e426c0d573a23131aa) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild')
-rw-r--r--dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild
new file mode 100644
index 00000000000..f866a8d0af3
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit unpacker cmake-multilib
+
+MY_P="deviceatlas-enterprise-c-${PV}"
+
+DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
+HOMEPAGE="https://deviceatlas.com"
+SRC_URI="${MY_P}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+RESTRICT="fetch mirror bindist"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-cmake-install.patch"
+)
+
+pkg_nofetch() {
+ eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
+ eerror "And download DeviceAtlas C API"
+ eerror "Then place the file in ${DISTDIR}/${MY_P}.zip"
+}
+
+multilib_src_install_all() {
+ if use doc ; then
+ local -a HTML_DOCS=( Documentation )
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${P}/examples
+ doins examples/daexutil.h
+ doins examples/example{0,1,2,3}.c
+ doins examples/util.c
+ doins examples/EXAMPLES.USAGE
+ fi
+
+ einstalldocs
+}