summaryrefslogtreecommitdiff
path: root/dev-libs/double-conversion
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/double-conversion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/double-conversion')
-rw-r--r--dev-libs/double-conversion/Manifest1
-rw-r--r--dev-libs/double-conversion/double-conversion-2.0.1.ebuild46
-rw-r--r--dev-libs/double-conversion/files/double-conversion-2.0.1-scons.patch12
-rw-r--r--dev-libs/double-conversion/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/double-conversion/Manifest b/dev-libs/double-conversion/Manifest
new file mode 100644
index 00000000000..2f1155bc3e5
--- /dev/null
+++ b/dev-libs/double-conversion/Manifest
@@ -0,0 +1 @@
+DIST double-conversion-2.0.1.tar.gz 7014061 SHA256 671f0439b4531c7344ace5b2ddaab4bdd860e80cee586efcfebf37b4eedd7cf0 SHA512 ab9e63ef97664d470cdd8b2a5d3b8f9d0b8558980f463d30369577c4e54804ee210321a979f4550ea2299cc0a2a0360f780de63458db942ba0ac34793b8f98ec WHIRLPOOL 559a0d2f165000abab87d77f0483dcac1503fa090382fead605e05a30ecea0c8afa1730caf51cdcba10a48d0c0b58fa855a9193b28fc5061dcf86d6505f02f85
diff --git a/dev-libs/double-conversion/double-conversion-2.0.1.ebuild b/dev-libs/double-conversion/double-conversion-2.0.1.ebuild
new file mode 100644
index 00000000000..ce247e789da
--- /dev/null
+++ b/dev-libs/double-conversion/double-conversion-2.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit scons-utils eutils
+
+DESCRIPTION="Binary-decimal and decimal-binary routines forIEEE doubles"
+HOMEPAGE="http://code.google.com/p/double-conversion/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+LIBNAME=lib${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-scons.patch
+}
+
+src_compile() {
+ escons ${LIBNAME}.so.1
+ use static-libs && escons ${LIBNAME}.a
+}
+
+src_test() {
+ escons run_tests
+ export LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}"
+ ./run_tests --list | tr -d '<' | xargs ./run_tests || die
+}
+
+src_install() {
+ dolib.so ${LIBNAME}.so*
+ use static-libs && dolib.a ${LIBNAME}.a
+ insinto /usr/include/double-conversion
+ doins src/{double-conversion,utils}.h
+ dodoc README Changelog AUTHORS
+}
diff --git a/dev-libs/double-conversion/files/double-conversion-2.0.1-scons.patch b/dev-libs/double-conversion/files/double-conversion-2.0.1-scons.patch
new file mode 100644
index 00000000000..da7f2f9cb3a
--- /dev/null
+++ b/dev-libs/double-conversion/files/double-conversion-2.0.1-scons.patch
@@ -0,0 +1,12 @@
+--- SConstruct.orig 2014-03-31 12:40:22.186757814 -0700
++++ SConstruct 2014-03-31 12:46:21.726024868 -0700
+@@ -18,7 +18,8 @@
+ # for shared lib, requires scons 2.3.0
+ env['SHLIBVERSION'] = '1.0.0'
+
+-CCFLAGS = []
++CCFLAGS = [os.environ['CXXFLAGS']]
++
+ if int(debug):
+ CCFLAGS.append(ARGUMENTS.get('CXXFLAGS', '-g -Wall -Werror'))
+ if int(optimize):
diff --git a/dev-libs/double-conversion/metadata.xml b/dev-libs/double-conversion/metadata.xml
new file mode 100644
index 00000000000..e74139346bf
--- /dev/null
+++ b/dev-libs/double-conversion/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang='en'>
+ This library consists of efficient conversion routines that have
+ been extracted from the V8 JavaScript engine. The code has been
+ refactored and improved so that it can be used more easily in other
+ projects.
+</longdescription>
+</pkgmetadata>