summaryrefslogtreecommitdiff
path: root/dev-libs/eio
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/eio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/eio')
-rw-r--r--dev-libs/eio/Manifest3
-rw-r--r--dev-libs/eio/eio-1.7.10.ebuild36
-rw-r--r--dev-libs/eio/eio-1.7.8.ebuild29
-rw-r--r--dev-libs/eio/eio-1.7.9.ebuild29
-rw-r--r--dev-libs/eio/eio-9999.ebuild36
-rw-r--r--dev-libs/eio/metadata.xml5
6 files changed, 138 insertions, 0 deletions
diff --git a/dev-libs/eio/Manifest b/dev-libs/eio/Manifest
new file mode 100644
index 00000000000..c43ae0abfd5
--- /dev/null
+++ b/dev-libs/eio/Manifest
@@ -0,0 +1,3 @@
+DIST eio-1.7.10.tar.bz2 361892 SHA256 2859c984cb34c65707834d77da8d1ec106d378ef5bf7f9a10662c464a656b6cc SHA512 08edec460a27d7db039c9128fed13bef0ff2855047fbd367b0a4bd7efbd6496395eb949f4a46435fd142a4ccc0db22b59d39f71080cf21453d95b6cb3ea5864e WHIRLPOOL b0035536df200e53facafd45dbc507d50193254e7ea564de2b46dc02553631cb4eaf7b22aa3a2f70899fcee85c611c701ebe46198475b628e335ab87a129bb9f
+DIST eio-1.7.8.tar.bz2 362049 SHA256 8e26055e052b01f74b175ec98941ce9947a485db84a10c35855da54297a3363b SHA512 7aae70da2737230d76dfedc164f96fb8c51fa031d857c70f0b59f2593682264792e8d4fd764e4696e8bf9d485e7bd0efcf75a6be6a9e6ec7de1d904942d7515b WHIRLPOOL cfa447f2bab3cf62854149aab594e59afc28779a5dcd796a41e7c0ffccce987891cb52b9561a872cc036466378e2382597e71a7c292b19e093b94c446c1d2509
+DIST eio-1.7.9.tar.bz2 362141 SHA256 dbd62331c40e82609a8e6ed3c9de53c6e8a1349c54a9797250566c65049f6e8a SHA512 4003094ed83d127a2a088b964fe4069c699e35c0ef5ee224b8eac3a06b5ed5b302a41a42b189ad280f01fcd259b1fb1af4192b414ada1494159220d8e4050ddf WHIRLPOOL b3c6f8533f03dd96d965c602ba4e6babd9d3473169ad0b62165b28f29171199510b2e60d5cbb7888887e0930c776b43feb8649b0375036380fae6d12c6aff97a
diff --git a/dev-libs/eio/eio-1.7.10.ebuild b/dev-libs/eio/eio-1.7.10.ebuild
new file mode 100644
index 00000000000..bdb8bc9ffe7
--- /dev/null
+++ b/dev-libs/eio/eio-1.7.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's integration to IO"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/EIO"
+
+LICENSE="LGPL-2"
+IUSE="examples static-libs"
+
+RDEPEND=">=dev-libs/ecore-${PV}
+ >=dev-libs/eet-${PV}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ E_ECONF=(
+ --enable-posix-threads
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ )
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eio/eio-1.7.8.ebuild b/dev-libs/eio/eio-1.7.8.ebuild
new file mode 100644
index 00000000000..2d631b529a3
--- /dev/null
+++ b/dev-libs/eio/eio-1.7.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's integration to IO"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/EIO"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples static-libs"
+
+RDEPEND=">=dev-libs/ecore-1.7.8
+ >=dev-libs/eet-1.7.8"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ E_ECONF+=(
+ --enable-posix-threads
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ )
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eio/eio-1.7.9.ebuild b/dev-libs/eio/eio-1.7.9.ebuild
new file mode 100644
index 00000000000..7990fa9207f
--- /dev/null
+++ b/dev-libs/eio/eio-1.7.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's integration to IO"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/EIO"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples static-libs"
+
+RDEPEND=">=dev-libs/ecore-1.7.9
+ >=dev-libs/eet-1.7.9"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ E_ECONF+=(
+ --enable-posix-threads
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ )
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eio/eio-9999.ebuild b/dev-libs/eio/eio-9999.ebuild
new file mode 100644
index 00000000000..bdb8bc9ffe7
--- /dev/null
+++ b/dev-libs/eio/eio-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's integration to IO"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/EIO"
+
+LICENSE="LGPL-2"
+IUSE="examples static-libs"
+
+RDEPEND=">=dev-libs/ecore-${PV}
+ >=dev-libs/eet-${PV}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ E_ECONF=(
+ --enable-posix-threads
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ )
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eio/metadata.xml b/dev-libs/eio/metadata.xml
new file mode 100644
index 00000000000..99165add909
--- /dev/null
+++ b/dev-libs/eio/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+</pkgmetadata>